Bug 356782 - krfb stops sending updates after the first frame
Summary: krfb stops sending updates after the first frame
Status: RESOLVED FIXED
Alias: None
Product: krfb
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR grave with 50 votes (vote)
Target Milestone: ---
Assignee: George Goldberg
URL:
Keywords:
: 218557 363217 376614 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-12-16 15:22 UTC by Rohan Garg
Modified: 2017-08-16 16:34 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rohan Garg 2015-12-16 15:22:03 UTC
krfb doesn't seem to update the screen on the client after it sends the first frame. The mouse still updates though.

Reproducible: Always

Steps to Reproduce:
1. Start krfb
2. Login
3. Try to open applications

Actual Results:  
Nothing seems to update except the cursor

Expected Results:  
Client screen is updated
Comment 1 Julien Bramary 2016-04-18 10:17:49 UTC
I observe the same using krfb 5.0 on Plasma 5. The only frame sent is the very first frame visible when krfb starts. No more updates are ever made. The mouse works as described in the report.
Comment 2 Julien Bramary 2016-04-18 10:21:04 UTC
Here is the stdout log in case this helps:
krfb 
found plugin at  "/usr/lib64/qt5/plugins/krfb/krfb_framebuffer_x11.so"                                                                                                                                            
Loaded plugin with name  "x11"                                                                                                                                                                                    
found plugin at  "/usr/lib64/qt5/plugins/krfb/krfb_framebuffer_qt.so"                                                                                                                                             
Loaded plugin with name  "qt"                                                                                                                                                                                     
Using FrameBuffer: "x11"                                                                                                                                                                                          
Got image. bpp:  32 , depth:  24 , padded width:  15360  (sent:  15360 )                                                                                                                                          
                                                                                                                                                                                                                  
Pass a valid window to KWallet::Wallet::openWallet().                                                                                                                                                             
cannot find .rc file "krfbui.rc" for component "krfb"                                                                                                                                                             
Starting server. Listen port: 6900 Listen Address: "0.0.0.0" Password enabled: true
Comment 3 manuel fernández 2016-05-20 02:04:10 UTC
exactly same problem here.
kubuntu 16.04
plasma 5.5.5
kenrel 4.4.0-23-generic
qt 5.5.1
Comment 4 Robert Hollencamp 2016-07-15 19:11:55 UTC
*** This bug has been confirmed by popular vote. ***
Comment 5 Dave Flogeras 2016-08-02 16:21:23 UTC
Still not working as of 16.08 beta.

Using:
KDE Frameworks 5.23.0
Qt 5.6.1 (built against 5.6.1)
The xcb windowing system
Comment 6 Alexey Min 2016-12-29 09:22:27 UTC
Bug still here, with latest git version 5.0 (commit 699d7f9a27f9adb3e9aad79c11d30d55002eb922),
KDE Frameworks 5.29.0
Qt 5.7.1

I found a workaround, if you force krfb to use different screenshot taker plugin, it works. Change preferred frame buffer plugin from x11 to qt. For this you need to edit your ~/.config/krfbrc, add the following lines:

$ nano ~/.config/krfbrc

[FrameBuffer]
preferredFrameBufferPlugin=qt
Comment 7 Julien Bramary 2017-01-20 14:03:57 UTC
(In reply to Alexey from comment #6)
> Bug still here, with latest git version 5.0 (commit
> 699d7f9a27f9adb3e9aad79c11d30d55002eb922),
> KDE Frameworks 5.29.0
> Qt 5.7.1
> 
> I found a workaround, if you force krfb to use different screenshot taker
> plugin, it works. Change preferred frame buffer plugin from x11 to qt. For
> this you need to edit your ~/.config/krfbrc, add the following lines:
> 
> $ nano ~/.config/krfbrc
> 
> [FrameBuffer]
> preferredFrameBufferPlugin=qt

Thanks Alexey, this work around works for me!
Comment 8 manuel fernández 2017-01-27 17:27:21 UTC
The workaround of Alexei worked fine for me.
Comment 9 manuel fernández 2017-01-27 17:27:47 UTC
Thank you!
Comment 10 Raf 2017-02-03 20:03:19 UTC
Works fine, thanks a lot Alexey !
Comment 11 Albert Astals Cid 2017-03-23 23:21:34 UTC
Git commit c0ceb8a83de5d5a2be0f842eafd84024bfeea6ed by Albert Astals Cid.
Committed on 23/03/2017 at 23:20.
Pushed by aacid into branch 'Applications/17.04'.

Set default framebuffer plugin to "qt" instead of "x11"

Make default "qt" framebuffer plugin instead of "x11". Workaround for bug https://bugs.kde.org/show_bug.cgi?id=356782
Not a proper fix, ideally "x11" plugin needs to be fixed.

REVIEW: 129721

M  +1    -1    krfb/krfb.kcfg

https://commits.kde.org/krfb/c0ceb8a83de5d5a2be0f842eafd84024bfeea6ed
Comment 12 Albert Astals Cid 2017-03-23 23:23:17 UTC
The fix was by Alexey, i forgot to give him credit when doing the git commit, very sorry about that :/
Comment 13 Albert Astals Cid 2017-03-23 23:25:47 UTC
*** Bug 376614 has been marked as a duplicate of this bug. ***
Comment 14 Albert Astals Cid 2017-03-23 23:26:13 UTC
*** Bug 363217 has been marked as a duplicate of this bug. ***
Comment 15 Alexey Min 2017-07-30 08:23:56 UTC
(In reply to Albert Astals Cid from comment #14)
> *** Bug 363217 has been marked as a duplicate of this bug. ***

https://bugs.kde.org/show_bug.cgi?id=218557 is probably the same, but much older... can be closed?
Comment 16 Albert Astals Cid 2017-07-30 21:45:29 UTC
*** Bug 218557 has been marked as a duplicate of this bug. ***