Bug 355920 - plasma session doesn't clear tty it uses.
Summary: plasma session doesn't clear tty it uses.
Status: RESOLVED UPSTREAM
Alias: None
Product: kwin
Classification: Unclassified
Component: platform-drm (show other bugs)
Version: git master
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 364499 407305 416557 426980 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-11-26 07:35 UTC by Bhushan Shah
Modified: 2021-06-21 22:46 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In: SDDM 0.19


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bhushan Shah 2015-11-26 07:35:58 UTC
-> login to plasmawayland
-> it shows stuff on tty2 
-> logout 
-> login to x session
-> gets shown on vt7
-> now I can't switch to tty2

Reproducible: Always
Comment 1 Martin Flöser 2016-08-27 14:26:52 UTC
is that still the case? I assume it might have been related to kwin crashing on tear down. So with a clean shutdown: does it work?
Comment 2 Bhushan Shah 2016-08-27 14:33:50 UTC
Yes, I guess its still case. But I haven't tried in while.. will do and report later.
Comment 3 Gauthier POGAM--LE MONTAGNER 2017-05-17 07:56:57 UTC
I can confirm it's still the case with plasma 5.10 beta. The TTY2 remain unusable after logging out of a plasma wayland session.
Comment 4 Martin Flöser 2017-07-02 15:06:42 UTC
Is that problem also reproducable with Weston?
Comment 5 Alexander Mentyu 2018-07-19 08:42:19 UTC
Can't logout from Weston session - logging out hangs with blank screen

Distribution: Netrunner Rolling
Kernel: 4.18.0-1-MANJARO
Plasma: 5.13.3
Apps: 18.04.3
Qt: 5.11.1
Frameworks: 5.48.0
Wayland: 1.15.0
Graphics:  Card-1: Intel Haswell-ULT Integrated Graphics driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:0a16 
           Display: wayland server: X.Org 1.20.0 driver: intel unloaded: modesetting alternate: fbdev,vesa 
           compositor: kwin wayland tty: N/A 
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.1.4 compat-v: 3.0 direct render: Yes
Comment 6 Patrick Silva 2019-02-13 01:25:14 UTC
This problem persists with plasma 5.15 on Arch linux.
Every time I restart Wayland session, the next TTY becomes unusable with cursor blinking in the upper left corner.
I restart Wayland session, TTY2 becomes unusable, so I restart plasma Wayland again and TTY3 becomes unusable, etc.
Comment 7 Benjamin Smith 2020-02-29 03:09:51 UTC
This still happens on Plasma 5.18.2. I used the Wayland session, logged out, and switched back to Xorg.  If I switch to TTY2, it is unusable, just a lot of "@" symbols followed by a blinking cursor.  If I create another Plasma Wayland session, it uses TTY3, then TTY4, and so on.
Comment 8 Arjan van Olphen 2020-06-10 16:07:55 UTC
Same here but for some reason a lot of processes keep file descriptors open to multiple terminals at the same time.

What is shown here is the result of Wayland Plasma after 2 logouts en 3 loggins 
Where tty4 is the current wayland terminal.

I'm using Kubuntu 20.04 KDE Plasma 5.18.5.
But maybe it is not KDE Plasma but a Kubuntu integration problem.

--

user@adelaide:~$ who -la
           system boot  Jun 10 17:33
           run-level 5  Jun 10 17:33
           tty2         Jun 10 17:42              1569 id=      term=0 exit=0
user    + pts/0        Jun 10 17:44 00:01        3605 (:1)
           tty3         Jun 10 17:44              2544 id=      term=0 exit=0
user    - pts/1        Jun 10 17:45   .          4094 (:1)
user    + tty4         Jun 10 17:44 00:12        3479

user@adelaide:~$ lsof /dev/tty3
COMMAND    PID  USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
dbus-run- 3479 user   25u   CHR    4,3      0t0   24 /dev/tty3
dbus-daem 3487 user   25u   CHR    4,3      0t0   24 /dev/tty3
startplas 3488 user   25u   CHR    4,3      0t0   24 /dev/tty3
Xwayland  3522 user   25u   CHR    4,3      0t0   24 /dev/tty3
startplas 3581 user   25u   CHR    4,3      0t0   24 /dev/tty3
plasma_se 3682 user   25u   CHR    4,3      0t0   24 /dev/tty3
ksmserver 3688 user   25u   CHR    4,3      0t0   24 /dev/tty3
baloo_fil 3712 user   25u   CHR    4,3      0t0   24 /dev/tty3
plasmashe 3715 user   25u   CHR    4,3      0t0   24 /dev/tty3
xembedsni 3717 user   25u   CHR    4,3      0t0   24 /dev/tty3
gmenudbus 3755 user   25u   CHR    4,3      0t0   24 /dev/tty3
DiscoverN 3757 user   25u   CHR    4,3      0t0   24 /dev/tty3
kdeconnec 3790 user   25u   CHR    4,3      0t0   24 /dev/tty3
agent     3796 user   25u   CHR    4,3      0t0   24 /dev/tty3
org_kde_p 3807 user   25u   CHR    4,3      0t0   24 /dev/tty3
at-spi-bu 3817 user   25u   CHR    4,3      0t0   24 /dev/tty3
kmix      3827 user   25u   CHR    4,3      0t0   24 /dev/tty3
ksysguard 3897 user   25u   CHR    4,3      0t0   24 /dev/tty3
konsole   4070 user   25u   CHR    4,3      0t0   24 /dev/tty3
bash      4094 user   25u   CHR    4,3      0t0   24 /dev/tty3

user@adelaide:~$ lsof /dev/tty2
COMMAND    PID  USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
baloo_fil 2784 user   28u   CHR    4,2      0t0   23 /dev/tty2
agent     2868 user   28u   CHR    4,2      0t0   23 /dev/tty2
dbus-run- 3479 user   28u   CHR    4,2      0t0   23 /dev/tty2
dbus-daem 3487 user   28u   CHR    4,2      0t0   23 /dev/tty2
startplas 3488 user   28u   CHR    4,2      0t0   23 /dev/tty2
Xwayland  3522 user   28u   CHR    4,2      0t0   23 /dev/tty2
startplas 3581 user   28u   CHR    4,2      0t0   23 /dev/tty2
plasma_se 3682 user   28u   CHR    4,2      0t0   23 /dev/tty2
ksmserver 3688 user   28u   CHR    4,2      0t0   23 /dev/tty2
baloo_fil 3712 user   28u   CHR    4,2      0t0   23 /dev/tty2
plasmashe 3715 user   28u   CHR    4,2      0t0   23 /dev/tty2
xembedsni 3717 user   28u   CHR    4,2      0t0   23 /dev/tty2
gmenudbus 3755 user   28u   CHR    4,2      0t0   23 /dev/tty2
DiscoverN 3757 user   28u   CHR    4,2      0t0   23 /dev/tty2
kdeconnec 3790 user   28u   CHR    4,2      0t0   23 /dev/tty2
agent     3796 user   28u   CHR    4,2      0t0   23 /dev/tty2
org_kde_p 3807 user   28u   CHR    4,2      0t0   23 /dev/tty2
at-spi-bu 3817 user   28u   CHR    4,2      0t0   23 /dev/tty2
kmix      3827 user   28u   CHR    4,2      0t0   23 /dev/tty2
ksysguard 3897 user   28u   CHR    4,2      0t0   23 /dev/tty2
konsole   4070 user   28u   CHR    4,2      0t0   23 /dev/tty2
bash      4094 user   28u   CHR    4,2      0t0   23 /dev/tty2

user@adelaide:~$ lsof /dev/tty4
COMMAND    PID  USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
dbus-run- 3479 user    0u   CHR    4,4      0t0   25 /dev/tty4
startplas 3488 user    0u   CHR    4,4      0t0   25 /dev/tty4
user@adelaide:~$
Comment 9 Zamundaaa 2020-11-23 20:49:29 UTC
This bug is not a KWin bug but a sddm one and has been fixed with 0.19: https://github.com/sddm/sddm/pull/1273
I tested it on Manjaro and ttys are no longer being used up.
Comment 10 Nate Graham 2020-11-23 21:31:54 UTC
*** Bug 407305 has been marked as a duplicate of this bug. ***
Comment 11 Vadym Krevs 2021-02-08 22:21:50 UTC
I'm on openSUSE 15.2 with sddm-0.19.0-lp152.96.6.x86_64 and the issue is still present. Or does it also require "ReuseSession=true" to work?
Comment 12 Nate Graham 2021-02-08 22:28:52 UTC
Probably, yeah.
Comment 13 Nate Graham 2021-06-21 22:46:15 UTC
*** Bug 426980 has been marked as a duplicate of this bug. ***
Comment 14 Nate Graham 2021-06-21 22:46:18 UTC
*** Bug 416557 has been marked as a duplicate of this bug. ***
Comment 15 Nate Graham 2021-06-21 22:46:51 UTC
*** Bug 364499 has been marked as a duplicate of this bug. ***