Bug 407305 - A bunch of "unused" sessions after login in and out of an account while leaving one open in the background, which can block re-login
Summary: A bunch of "unused" sessions after login in and out of an account while leavi...
Status: RESOLVED DUPLICATE of bug 355920
Alias: None
Product: ksmserver
Classification: Unclassified
Component: general (show other bugs)
Version: 5.14.5
Platform: Fedora RPMs Linux
: VHI major with 20 votes (vote)
Target Milestone: ---
Assignee: David Edmundson
URL:
Keywords:
: 372275 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-07 15:32 UTC by whoopsdecade
Modified: 2021-06-21 22:57 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Unused sessions (2.40 MB, image/jpeg)
2019-07-12 22:24 UTC, whoopsdecade
Details

Note You need to log in before you can comment on or make changes to this bug.
Description whoopsdecade 2019-05-07 15:32:49 UTC
SUMMARY
Logging in and out of a session while leaving a second one "locked" creates a bunch of "unused" sessions.

STEPS TO REPRODUCE
1. Login to account A and switch users (should stay in background
2. Log in to account B and then log out
3. Open account A once again and switch users, you will see an "unused" session in the menu.
4. Repeat the same process N times and you will get N "unused" sessions.

OBSERVED RESULT
https://i.imgur.com/vS4MOWD.jpg

EXPECTED RESULT
Just switching users with no "unused" sessions.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: YES
(available in About System)
KDE Plasma Version: 5.14.5
KDE Frameworks Version: 5.55.0
Qt Version: 5.11.3

ADDITIONAL INFORMATION
I'm Fedora 29 KDE spin
Comment 1 Nate Graham 2019-05-09 21:36:12 UTC
This was fixed in Plasma 5.15.
Comment 2 whoopsdecade 2019-07-12 22:24:57 UTC
Created attachment 121486 [details]
Unused sessions

It's not resolved yet. This screenshot is from today on Plasma 5.15.5. I've also had it happen several times before. It eventually cleans up but it's not predictable.. and if I select one of the "unused" sessions the session might never log the second user in (remains loading the desktop, blank screen) and I have to use the hotkey to get back to the first user and kill the other users processes.
Comment 3 whoopsdecade 2019-07-17 13:08:52 UTC
Sometimes when I try to go back to the previous user the screen just stays blank, no login occurs and it just hangs there and I have to force-restart my machine. Changing user sessions is basic guys and it has always been very unreliable in Plasma, you need to figure this out.
Comment 4 61.1p57 2019-09-18 09:12:13 UTC
FWIW, I see a geoclue agent process running even after I called `loginctl terminate-user`. The unused session goes away when I kill that process.
Comment 5 Nate Graham 2020-01-31 18:41:27 UTC
I can confirm now.
Comment 6 Nate Graham 2020-01-31 22:30:29 UTC
*** Bug 416557 has been marked as a duplicate of this bug. ***
Comment 7 Patrick Silva 2020-02-09 23:39:25 UTC
bug 401928 seems related
Comment 8 Nate Graham 2020-09-26 15:55:52 UTC
*** Bug 426980 has been marked as a duplicate of this bug. ***
Comment 9 David Edmundson 2020-11-07 23:48:09 UTC

*** This bug has been marked as a duplicate of bug 422322 ***
Comment 10 Nate Graham 2020-11-23 21:31:54 UTC
This is actually a duplicate of Bug 355920 instead, which turned out to be an SDDM issue which was fixed in version 0.19.

*** This bug has been marked as a duplicate of bug 355920 ***
Comment 11 Nate Graham 2021-06-21 22:57:41 UTC
*** Bug 372275 has been marked as a duplicate of this bug. ***