Bug 364499 - Allow closing extra session
Summary: Allow closing extra session
Status: RESOLVED DUPLICATE of bug 355920
Alias: None
Product: kscreenlocker
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR minor
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-19 11:39 UTC by azrdev
Modified: 2021-06-21 22:46 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description azrdev 2016-06-19 11:39:16 UTC
In my lockscreen, I have the option to start a new session. If I do so, apparently a new X instance is spawned on a different tty. There is a button to switch between these sessions, but none to close the current one (to go back to the state of having only one session)
Comment 1 Martin Flöser 2016-06-20 06:17:11 UTC
Just switching back should close the newly created session.
Comment 2 Justin Zobel 2020-11-25 00:29:37 UTC
Can you please confirm Martin's suggestion in Comment 1 resolves this issue?

I've set the bug status to "needsinfo" pending your response, please change back to "reported" or "resolved" when you respond, thanks.
Comment 3 Bug Janitor Service 2020-12-10 04:34:35 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2020-12-25 04:34:25 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!
Comment 5 azrdev 2020-12-25 13:12:09 UTC
Just switching back does *not* stop the second Xorg instance, it keeps running.

If i click then on "switch user"  (in the lockscreen of the first session) it shows one session "unused" and two buttons "use this session" and "new session".
The latter opens a third session/login screen, which also stays open when switching back, leaving me with 3 Xorg instances.
Comment 6 Nate Graham 2021-06-21 22:46:51 UTC
Fixed in sddm 0.19; see Bug 355920.

*** This bug has been marked as a duplicate of bug 355920 ***