Bug 347602 - Update Manager systray icon and info still reports pending updates after updates applied
Summary: Update Manager systray icon and info still reports pending updates after upda...
Status: RESOLVED NOT A BUG
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: 5.22.1
Platform: Ubuntu Packages Linux
: HI normal
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
: 347291 347479 347639 347795 348108 352287 354411 354462 355450 356194 358018 360098 360118 360324 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-12 11:49 UTC by h.k.ghost
Modified: 2021-06-17 20:21 UTC (History)
49 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Output with patch applied (4.18 KB, text/plain)
2015-05-29 02:11 UTC, pdf
Details
List of available updates (12.14 KB, image/png)
2015-12-08 03:03 UTC, Andreas
Details
White shield with green circle (1.00 KB, image/jpeg)
2016-06-10 07:29 UTC, John
Details
No updates on Discover or terminal but on system tray. (914.68 KB, image/png)
2019-03-29 12:01 UTC, gcjuan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description h.k.ghost 2015-05-12 11:49:25 UTC
The Muon Update Manager continues to show the pending updates icon and information (i.e. "X packages to update, ....") even after all updates have been applied.

Reproducible: Always

Steps to Reproduce:
1. Wait for Muon Update Manager to report there're pending updates for system
2. Use MUM to apply the updates
3. 

Actual Results:  
The systray icon and the info it reports when the popup is displayed does not change state to reflect the fact that there're no more pending updates because they're already applied.

Expected Results:  
The shield icon for the systray and its popup info change state to reflect updates have been applied.
Comment 1 Aleix Pol 2015-05-14 11:12:34 UTC
*** Bug 347639 has been marked as a duplicate of this bug. ***
Comment 2 Aleix Pol 2015-05-14 11:13:03 UTC
*** Bug 347496 has been marked as a duplicate of this bug. ***
Comment 3 Aleix Pol 2015-05-14 11:13:34 UTC
*** Bug 347291 has been marked as a duplicate of this bug. ***
Comment 4 Aleix Pol 2015-05-14 14:42:26 UTC
*** Bug 347479 has been marked as a duplicate of this bug. ***
Comment 5 Aleix Pol 2015-05-20 12:18:19 UTC
*** Bug 347795 has been marked as a duplicate of this bug. ***
Comment 6 Aleix Pol 2015-05-22 15:51:34 UTC
*** Bug 348108 has been marked as a duplicate of this bug. ***
Comment 7 Aleix Pol 2015-05-22 16:09:44 UTC
Hi,
I'll need some help with this issue because I'm not running Kubuntu at the moment and I'm having a bit of a hard time debugging it.
I checked on a Kubuntu system in the office and I saw /var/lib/update-notifier/dpkg-run-stamp being updated but then ApplicationNotifier::recheckSystemUpdateNeeded isn't really being called.
I would really appreciate if somebody could apply the patch and test the process. You can check the newly added debug output using "plasmawindowed org.kde.muonnotifier".

Thanks!

diff --git a/libmuon/backends/ApplicationBackend/ApplicationNotifier.cpp b/libmuon/backends/ApplicationBackend/ApplicationNotifier.cpp
index 967e22f..bc07761 100644
--- a/libmuon/backends/ApplicationBackend/ApplicationNotifier.cpp
+++ b/libmuon/backends/ApplicationBackend/ApplicationNotifier.cpp
@@ -26,6 +26,7 @@
 #include <QtCore/QStandardPaths>
 #include <QtCore/QProcess>
 #include <QtGui/QIcon>
+#include <QDebug>
 
 // KDE includes
 #include <KDirWatch>
@@ -118,8 +119,9 @@ void ApplicationNotifier::recheckSystemUpdateNeeded()
     m_updateCheckerProcess = new QProcess(this);
     connect(m_updateCheckerProcess, SIGNAL(finished(int)), this, SLOT(parseUpdateInfo()));
     m_updateCheckerProcess->start("/usr/lib/update-notifier/apt-check");
+    qDebug() << "A";
 }
-    
+
 void ApplicationNotifier::parseUpdateInfo()
 {
 #warning why does this parse stdout and not use qapt, wtf...
@@ -132,6 +134,7 @@ void ApplicationNotifier::parseUpdateInfo()
 
     // Format updates;security
     int eqpos = line.indexOf(';');
+    qDebug() << "B" << line;
 
     if (eqpos > 0) {
         QByteArray updatesString = line.left(eqpos);
Comment 8 Rohan Garg 2015-05-27 13:40:11 UTC
It seems to work for me on Kubuntu Vivid
Comment 9 h.k.ghost 2015-05-28 03:19:11 UTC
I'm also using vivid. Mine is an upgrade from 14.10. Is it the same for you or are you using a clean install?
Comment 10 h.k.ghost 2015-05-28 03:20:42 UTC
Sorry, I'm not sure if you were talking about the patch above or just the bug report. I'm referring to the original bug report, not the code.
Comment 11 pdf 2015-05-28 03:21:58 UTC
@Alex, where should I be looking for the logs after applying this patch?
Comment 12 Aleix Pol 2015-05-28 03:31:16 UTC
You can run the plasmoid by calling "plasmawindowed org.kde.muonnotifier". It should output things when upgrades happen (either from muon-updater or apt-get).
Comment 13 pdf 2015-05-28 04:11:50 UTC
Alright, I don't have any updates pending currently (I thought I did, because the plasmoid was telling me I did ;-)), so I'll capture some logs next time some updates are available.
Comment 14 pdf 2015-05-29 02:11:35 UTC
Created attachment 92899 [details]
Output with patch applied

Here's the output with the earlier patch applied.  Produced via:
1. Execute `plasmawindowed org.kde.muonnotifier`
2. Execute `sudo apt-get update` to trigger population of pending updates
3. Use the `Update` button and proceed through the upgrade via Muon proper

At the end of the process, the plasmoid still shows pending updates, however all updates have been applied.
Comment 15 chcgowrtr 2015-07-02 15:26:19 UTC
FWIW, I am having the same issue, running Kubuntu 15.04, Plasma 5.3.1. The plasmoid icon remains in the panel and shows I have six updates pending, two of which are security updates, even though I have no updates pending according to Muon Package Manager.
Comment 16 Ernie 2015-07-08 01:51:41 UTC
Seems related, I guess. Muon can't count.
This morning I had, according to the widget, 28 updates, 14 of which are security updates. I click update and see 7 updates.

I quit the updater and look at updates with apt:

$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
linux-generic linux-headers-generic linux-image-generic
The following packages will be upgraded:
cups-browsed cups-filters cups-filters-core-drivers cups-filters-ippusbxd
libcupsfilters1 libfontembed1 linux-libc-dev
7 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Need to get 1,603 kB of archives.
After this operation, 3,072 B of additional disk space will be used.
Do you want to continue? [Y/n]
I got out of that and updated with muon.
I accepted the expected kernel packages, gave it the password and it is updating.........

~$ tail --lines=5 /var/log/apt/history.log

Start-Date: 2015-07-07 11:31:17
Install: linux-image-3.19.0-22-generic:i386 (3.19.0-22.22, automatic), linux-headers-3.19.0-22:i386 (3.19.0-22.22, automatic), linux-image-extra-3.19.0-22-generic:i386 (3.19.0-22.22, automatic), linux-headers-3.19.0-22-generic:i386 (3.19.0-22.22, automatic)
Upgrade: libfontembed1:i386 (1.0.67-0ubuntu2, 1.0.67-0ubuntu2.2), cups-filters-ippusbxd:i386 (1.0.67-0ubuntu2, 1.0.67-0ubuntu2.2), libcupsfilters1:i386 (1.0.67-0ubuntu2, 1.0.67-0ubuntu2.2), cups-filters:i386 (1.0.67-0ubuntu2, 1.0.67-0ubuntu2.2), linux-generic:i386 (3.19.0.21.20, 3.19.0.22.21), linux-libc-dev:i386 (3.19.0-21.21, 3.19.0-22.22), linux-image-generic:i386 (3.19.0.21.20, 3.19.0.22.21), linux-headers-generic:i386 (3.19.0.21.20, 3.19.0.22.21), cups-browsed:i386 (1.0.67-0ubuntu2, 1.0.67-0ubuntu2.2), cups-filters-core-drivers:i386 (1.0.67-0ubuntu2, 1.0.67-0ubuntu2.2)
End-Date: 2015-07-07 11:34:17
That's what? 10 packages in all? What happened to 18 more?
Comment 17 Thorsten Rochelmeyer 2015-08-27 13:03:22 UTC
Pretty much the same issue here with Kubuntu 15.04 / KDE Plasma 5.3.2. The indicator remains red even after installing all updates. Although the message displayed says "system is up to date". Rebooting makes the indicator turn green.
Comment 18 Terry Coles 2015-10-23 10:49:57 UTC
This is still apparent on Kubuntu 15.10 / Updater 5.4.2.

I had previously seen this on earlier versions, but an explicit sudo apt-get update / apt-get upgrade from the console generally fixed it.  That no longer seems to work.
Comment 19 Terry Coles 2015-10-23 11:12:04 UTC
A little more information re Kubuntu 15.10 / Updater 5.4.2.  This morning, the updater flagged six updates, which were duly applied successfully.  However, after the process was complete, the System Tray icon still showed a red cross instead of a green tick and hovering over it still stated that 6 updates were available.  That was the situation when I posted earlier.

Since then I have rebooted and, so far, there is no sign of the Updater icon.  I'm not sure how long after a reboot the updater rechecks for updates, but my system uptime is 16 minutes.

I don't know if this information is helpful, but hopefully it yields some clues to the problem or to a possible work-round.
Comment 20 gamesh.g 2015-10-27 23:00:51 UTC
I also see this on 15.10. I upgraded from 15.04 a few days ago and didn't have that issue there - although there were others.

It also gets the numbers wrong. It said 30 packages to update, of which 10 are security updates - but there was only 10 updates. Probably that's a separate bug as I saw similar behaviour on 15.04, though it was 2x the number there instead of 3x.
Comment 21 h.k.ghost 2015-10-28 05:45:19 UTC
(In reply to Aleix Pol from comment #7)
> Hi,
> I'll need some help with this issue because I'm not running Kubuntu at the
> moment and I'm having a bit of a hard time debugging it.

You might want to consider setting up a simple virtual machine to reproduce it there, if you haven't already. Either Ubuntu or Kubuntu should show the problem.
Comment 22 Jacob Morley Carson 2015-11-14 17:07:48 UTC
I have this problem as well. My Ubuntu version info is
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.10
Release:        15.10
Codename:       wily

My KDE version is 15.08.2.

I also see the counting problem Ernie mentioned in comment 16, but one thing at a time.
Comment 23 Defrenne M 2015-11-15 09:14:45 UTC
even this but seems to be corrected it stays on my system even after "sudo apt-get update" and "sudo apt-get upgrade" + "sudo apt-get autoremove".
Please make sure this is corrected as I want my system uptodate and secure.
Thanks
Comment 24 h.k.ghost 2015-11-15 10:08:35 UTC
(In reply to Defrenne M from comment #23)
> even this but seems to be corrected it stays on my system even after "sudo
> apt-get update" and "sudo apt-get upgrade" + "sudo apt-get autoremove".
> Please make sure this is corrected as I want my system uptodate and secure.
> Thanks

Hi Defrenne,

This bug report does not impact your system's ability to actually be up to date, since it will still report packages that need to be updated, update them normally, and so on. The issue only relates to the notification itself not being visibly accurate, e.g. system indicates you have 5 packages that need updating, and after applying the updates, it still continues to report that updates are needed.

In other words, it does not "see" that the updates have already been applied.
Comment 25 robert leleu 2015-11-20 08:41:47 UTC
reciprocally this morning the systray icon stood green as a message signaled a new package (from a non official package devoted to Musescore). The upgrade ran smoothly.
Comment 26 Paul Chaffey 2015-11-20 09:25:25 UTC
The update widget itself when applied to the panel works fine and seems to count updates always correctly. Its just present all the time (green when no updates are available). The updates icon in the system tray is whats buggy which puzzle me as I thought that this would reuse the same code as the updates widget. 

This bug is present in 15.04 and 15.10 on 4 different machines. Some are fresh 15.10 installs and some are upgrade from 15.04 or earlier.

My solution which is bit of a bodge is to remove updates from the system tray and then I added the updates widget to another panel on the second monitor (out of the way so it is not too visible and it doesn't annoy me ;-) ).
Comment 27 themroc 2015-11-21 22:59:24 UTC
Same here after upgrading on Kubuntu 15.10 with Plasma 5.4.2, but only on after upgrade (in Kubuntu 15.04 this bug was not present). 

But I think the problem is not limited to the update icon, because the kdeconnect symbol don't disappears too when idle (if wifi is off again on smartphone).
Comment 28 Andreas 2015-12-06 00:07:12 UTC
I have the same problem. The "Updates" icon remains red even after all updates are applied (and no reboot is required). If I click on the icon, it tells me that there are no remaining updates.

System is 15.10, fresh install.
Comment 29 Andreas 2015-12-08 03:03:40 UTC
Created attachment 95932 [details]
List of available updates

Here is what happened today: the Updater window stated that there are 24 outstanding updates. In the end, only 8 updates were available. The displayed count was wrong.
Comment 30 Fabian Rost 2016-01-06 11:10:08 UTC
I have the same issue on Kubuntu 15.10.
When the system was up to date and the Update icon showed available updates, I realized the following: I unchecked the Update icon in the System Tray Settings and clicked Apply. Then I checked it again and clicked apply again. Now the icon shows the correct status.
Comment 31 Tim Goodwin 2016-01-06 11:15:40 UTC
Hi Fabian - this only works until the next updates come through. Then you have to do it all again. Very annoying bug.
Comment 32 Tim Goodwin 2016-01-06 11:16:01 UTC
Hi Fabian - this only works until the next updates come through. Then you have to do it all again. Very annoying bug.
Comment 33 Jean Revertera 2016-01-20 07:34:54 UTC
I have three machines running Kubuntu 15.10 / Plasma 5.4.2, all of them are affected.
Comment 34 pfoo 2016-01-20 11:55:58 UTC
Could this be related to #352055 plasma-pa plasmoid not shown in systemtray after startup ? (https://bugs.kde.org/show_bug.cgi?id=352055)

Unchecking the Update icon in the System Tray Settings, applying, then checking it again and applying again make the issue disappears.
The fix is the same for bug #352055 involving plasma-pa at startup
Comment 35 Tim Goodwin 2016-01-20 12:03:09 UTC
(In reply to pfoo from comment #34)
> Could this be related to #352055 plasma-pa plasmoid not shown in systemtray
> after startup ? (https://bugs.kde.org/show_bug.cgi?id=352055)
> 
> Unchecking the Update icon in the System Tray Settings, applying, then
> checking it again and applying again make the issue disappears.
> The fix is the same for bug #352055 involving plasma-pa at startup

This is *not* a fix. It simply makes the issue go away until the next updates appear. Then the issue comes back. I wish people would read the comments before they say that things are 'fixed' when they obviously are not.
Comment 36 pfoo 2016-01-20 12:12:44 UTC
I had, I'm experiencing the issue, and yes the bug will appear again when new updates are released by ubuntu. I'm fully aware of this. And yes, this is a -temporary or hot if you wish- fix as it makes your systray looks as it should for the time being.
I'm just pointing that this hotfix is working on other(s ?) bugreports, and that It may be related (systray not updating icons as it should ?)
Comment 37 h.k.ghost 2016-01-20 12:38:03 UTC
(In reply to pfoo from comment #36)
> I had, I'm experiencing the issue, and yes the bug will appear again when
> new updates are released by ubuntu. I'm fully aware of this. And yes, this
> is a -temporary or hot if you wish- fix as it makes your systray looks as it
> should for the time being.
> I'm just pointing that this hotfix is working on other(s ?) bugreports, and
> that It may be related (systray not updating icons as it should ?)

I think the point you're missing is that, in bug reports, the term "fix" actually means something very specific. The fact that you have found a *workaround* is not the same as saying that there is a *fix*. There is no fix until a patch has been applied to the code and is shown to work as expected without having to play with the system tray for the issue to be hidden away temporarily (i.e. a "workaround").
Comment 38 deadlydud 2016-01-26 15:33:53 UTC
apt-get upgrade does not seem to fix the issue.
Comment 39 Aleix Pol 2016-01-28 17:29:47 UTC
*** Bug 354462 has been marked as a duplicate of this bug. ***
Comment 40 Aleix Pol 2016-01-28 17:30:16 UTC
*** Bug 358018 has been marked as a duplicate of this bug. ***
Comment 41 Aleix Pol 2016-01-28 17:33:26 UTC
Can somebody give this patch a try?
https://git.reviewboard.kde.org/r/126923/
Comment 42 Aleix Pol 2016-02-02 03:51:07 UTC
ping?
Comment 43 pdf 2016-02-02 04:23:33 UTC
On 02/02/2016 14:51, Aleix Pol via KDE Bugzilla wrote:
> https://bugs.kde.org/show_bug.cgi?id=347602
>
> --- Comment #42 from Aleix Pol <aleixpol@kde.org> ---
> ping?

I don't have a system running recent enough bits to test the patch
currently, if no one else has done so in the next couple of weeks I'll
try and put something together.
Comment 44 boaz.dodin 2016-02-02 05:34:34 UTC
(In reply to Aleix Pol from comment #42)
> ping?

How can I test the patch?
Comment 45 Aleix Pol 2016-02-02 14:34:53 UTC
Git commit 7ded9bf1de57f7954be552a48aa9abdb3e4db400 by Aleix Pol, on behalf of Aleix Pol Gonzalez.
Committed on 02/02/2016 at 14:28.
Pushed by apol into branch 'Plasma/5.5'.

Make sure qapt-check doesn't get called repeatedly

Simplify the process that checks for system upgrades.
- Makes sure it's only run when needed.
- Doesn't recreate the QProcess instance.

Tested by soee as discussed in #kubuntu-devel.

REVIEW: 126923
Related: bug 358359

M  +18   -12   libdiscover/backends/ApplicationBackend/ApplicationNotifier.cpp

http://commits.kde.org/discover/7ded9bf1de57f7954be552a48aa9abdb3e4db400
Comment 46 Aleix Pol 2016-02-02 14:37:17 UTC
Apparently this still happens. Will need more investigation.
Comment 47 Aleix Pol 2016-03-16 14:43:33 UTC
*** Bug 354411 has been marked as a duplicate of this bug. ***
Comment 48 Aleix Pol 2016-03-16 14:47:19 UTC
*** Bug 356194 has been marked as a duplicate of this bug. ***
Comment 49 Aleix Pol 2016-03-16 14:48:25 UTC
*** Bug 360118 has been marked as a duplicate of this bug. ***
Comment 50 Martin Muzatko 2016-03-16 16:07:17 UTC
Fixing this issue would be very much appreciated. Is there any way to assist in this issue?
Comment 51 Aleix Pol 2016-03-16 16:15:31 UTC
Git commit 749f5be5ebc7b56143e9952d085f396f3bd65905 by Aleix Pol.
Committed on 16/03/2016 at 16:12.
Pushed by apol into branch 'Plasma/5.5'.

Fix refresh on the notifier plasmoid for QApt backend

M  +4    -2    libdiscover/backends/ApplicationBackend/ApplicationNotifier.cpp

http://commits.kde.org/discover/749f5be5ebc7b56143e9952d085f396f3bd65905
Comment 52 boaz.dodin 2016-03-16 16:19:07 UTC
(In reply to Aleix Pol from comment #51)
> Git commit 749f5be5ebc7b56143e9952d085f396f3bd65905 by Aleix Pol.
> Committed on 16/03/2016 at 16:12.
> Pushed by apol into branch 'Plasma/5.5'.
> 
> Fix refresh on the notifier plasmoid for QApt backend
> 
> M  +4    -2   
> libdiscover/backends/ApplicationBackend/ApplicationNotifier.cpp
> 
> http://commits.kde.org/discover/749f5be5ebc7b56143e9952d085f396f3bd65905

Aleix, may this fix be backported to Plasma 5.4?
Comment 53 Aleix Pol 2016-03-16 16:22:40 UTC
You can try it, but note that the last stable Plasma release is 5.5.5.
Comment 54 Aleix Pol 2016-03-17 00:31:28 UTC
*** Bug 360098 has been marked as a duplicate of this bug. ***
Comment 55 Aleix Pol 2016-03-22 13:02:45 UTC
*** Bug 355450 has been marked as a duplicate of this bug. ***
Comment 56 Aleix Pol 2016-03-22 13:05:34 UTC
*** Bug 352287 has been marked as a duplicate of this bug. ***
Comment 57 Aleix Pol 2016-03-22 13:36:43 UTC
*** Bug 360324 has been marked as a duplicate of this bug. ***
Comment 58 Adam Felson 2016-04-20 02:58:54 UTC
Any chance this fix or any other kde fixes will ever be released via the update manager or must everybody wait until the next full kubuntu release?  I really tire of bugs like this (and the konsole window size bug) being marked as fixed and having to suffer with the bug for the better part of a year or two.
Comment 59 Shmerl 2016-04-20 03:03:46 UTC
@Adam Felson: This sounds like distro problem, not KDE problem. You are using a periodic release distro, where new Plasma comes in only very rarely. You can switch to a rolling distro to get it in a timely fashion. Given that Plasma 5 is still pretty buggy in many areas, it makes sense to do that if you are using it for your primary desktop.
Comment 60 Aleix Pol 2016-04-20 11:24:09 UTC
@Adam, I have done everything I could to make sure the patch would land on Kubuntu, please ask Kubuntu developers as to why it hasn't happened.
Comment 61 soee 2016-04-20 12:40:11 UTC
@Adam Kubuntu developers are doing what they can to make system stable and fix bugs they can fix but atm. all the resources are focused on 16.04 release. As you know this bug is fixed in Xenial and it is strongly recommended to update to LTS when it is released (tomorrow) as it will also get new Plasma etc.
Comment 62 andreaconsole 2016-04-30 09:12:12 UTC
I recently update my pc from kubuntu 15.10 to 16.04 LTS.
I see that this bug is considered fixed, but indeed it still affects my distro. How can I fix it?
Thank you for your support.
Comment 63 Adam Felson 2016-04-30 23:22:04 UTC
Live with it or wait for 16.10, perhaps 17.04.  The regular updates channel doesn't seem to include fixes like this.
Comment 64 h.k.ghost 2016-05-01 02:35:06 UTC
(In reply to Adam Felson from comment #63)
> Live with it or wait for 16.10, perhaps 17.04.  The regular updates channel
> doesn't seem to include fixes like this.

I did a fresh-install of 16.04 on my desktop and the update manager seems to be working as intended regarding the update reports before and after they get applied. That might suggest that the 15.10 -> 16.04 update process is not properly taking care of updating certain things, at least in some situations.

This is probably stating the obvious, but it looks like there's a clear need for improvement in the 'regular update channels'. Having to 'live with it' while waiting for months, or even over a year, for full releases for basic usability seems like a stretch, to put it politely, especially when KDE markets itself as user friendly. (The point here is not to say that KDE is "not user friendly" due to some bug. Rather, that highly visible bugs can cause more frustration, especially on new users determining their future expectations from their basic experience.)

Before being handed the often standard "there's nothing we can do" response, please think a bit harder about it. Being so involved in the process, there's probably someone you know, or someone you know who knows someone, who might be able to not only acknowledge the inefficiency, but have the ability to at least start a wider discussion to see what sort of solutions might be proposed, and perhaps even adopted.

Still, some users can grow more annoyed/frustrated than others and might choose to stop using KDE altogether. (Small bugs do have a larger cumulative effect, after all.)

Appreciate the work and effort BTW.
Comment 65 John 2016-05-01 09:12:46 UTC
The icon is working correctly on both my PCs, but the count of updates is still wrong. This morning it told me that there was one update, but actually listed and updated 11.
Comment 66 John 2016-06-07 11:59:20 UTC
It has now stopped working altogether. It hasn't indicated any updates lately, so I clicked on it. The pop up said "1 package to update". Clicking on the Update button brought up a list of 8 updates, which installed successfully.
Comment 67 Terry Coles 2016-06-07 12:07:48 UTC
I can confirm that the updater doesn't indicate any updates until 'sudo apt-get update' is executed in a shell.  The process then completes normally if I click on the icon.

I had noticed this some time ago, but was holding off reporting it because I was uncertain whether the check was occurring on start-up and the actual updates arrived later.  I'm now pretty sure that isn't the case
Comment 68 h.k.ghost 2016-06-07 12:25:01 UTC
I can confirm the behavior in the recent comments. It's not working as intended.
Comment 69 John 2016-06-10 07:29:09 UTC
Created attachment 99433 [details]
White shield with green circle
Comment 70 John 2016-06-10 07:35:11 UTC
There are two versions of the icons. On startup, there is a white shield with a small green circle lower right, containing a tick. If I run 'sudo apt-get update' in a shell, and there are updates, it changes to a red shield with a white cross in the centre. After the updates finish, it changes to a green shield with a white tick in the centre.

If I run 'sudo apt-get update' in a shell, and there are no updates, the white shield with the tick stays.

***** Please ignore previous comment - I was trying to add a jpeg to a comment *****
Comment 71 Aleix Pol 2016-06-10 16:56:48 UTC
If you think it's a new issue, please open a new bug report. The original issue was fixed.
Comment 72 Adam Felson 2016-07-24 01:56:30 UTC
Either not fixed as of 7/23/16, or it was never released as an update available in the update manager.
Comment 73 Aleix Pol 2016-07-25 22:20:57 UTC
@Adam, what version are you using?
Comment 74 Adam Felson 2016-07-26 00:05:09 UTC
Hard to say.  There are no files in the system containing the letters 'systray' except for ksystraycmd.mo part of kde-l10n-engb (version 4:15.12.3-0ubun) and the hp-system-tray.

"Discover" and  is version 5.6.2
muon-updater and notifier are both 4:5.6.2-1ubuntu
Comment 75 Adam Felson 2016-07-26 00:05:46 UTC
Hard to say.  There are no files in the system containing the letters 'systray' except for ksystraycmd.mo part of kde-l10n-engb (version 4:15.12.3-0ubun) and the hp-system-tray.

"Discover" and  is version 5.6.2
muon-updater and notifier are both 4:5.6.2-1ubuntu
Comment 76 gcjuan 2019-03-29 12:01:05 UTC
Created attachment 119113 [details]
No updates on Discover or terminal but on system tray.

This issue affects me right now on KDE neon 15.5.3 (Discover 15.5.3).

System tray updates icon shows that there are packages to update although there are actually no packages to update (checked on Discover and through the terminal as shown on the attachment).

Log out and in into the session doesn't resolve it. Restarting the system either.
Comment 77 gcjuan 2019-03-29 12:04:02 UTC
This issue affects me right now on KDE neon 15.5.3 (Discover 15.5.3).

System tray updates icon shows that there are packages to update although there are actually no packages to update (checked on Discover and through the terminal as shown on the attachment I've uploaded).

Log out and in into the session doesn't resolve it. Restarting the system either.
Comment 78 Patrick Silva 2019-03-29 18:53:16 UTC
probably you are affected by bug 385754
Comment 79 gcjuan 2019-04-02 09:45:29 UTC
(In reply to Patrick Silva from comment #78)
> probably you are affected by bug 385754

Exactly!

The problem was that I had flatpak packages to update and they seem not to be updated with Discover. I've run "flatpak update" to update all my flatpak packages and the updater tray icon notification is gone.

Many thanks =) I close it again as resolved.