Bug 345287 - plasma crashes on shutdown
Summary: plasma crashes on shutdown
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2015-03-18 00:32 UTC by Andrei Kramer
Modified: 2015-03-18 06:46 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Kramer 2015-03-18 00:32:38 UTC
Application: plasma-desktop (4.11.14)
KDE Platform Version: 4.14.3
Qt Version: 4.8.5
Operating System: Linux 3.18.7-gentoo x86_64
Distribution (Platform): Gentoo Packages

-- Information about the crash:
it happens almost every time. Very rarely the shutdown process goes smooth (about 1 in 20)

- What I was doing when the application crashed:
closed all applications
pressed the red button

-widgets
I don't have many widgets: basically, the defaults. I have the digital clock widget on the desktop and the battery monitor. (no system monitors whatsoever).

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f4e976e8780 (LWP 4972))]

Thread 3 (Thread 0x7f4e6ea57700 (LWP 4975)):
#0  0x00007f4e95fb2781 in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f4e91e911d1 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f4e91e4ea60 in g_main_context_acquire () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f4e91e4f815 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f4e91e4fa5c in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f4e9636eebe in QEventDispatcherGlib::processEvents (this=0x7f4e680008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:452
#6  0x00007f4e963404bf in QEventLoop::processEvents (this=this@entry=0x7f4e6ea56e20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f4e963407b5 in QEventLoop::exec (this=this@entry=0x7f4e6ea56e20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f4e9623cabf in QThread::exec (this=this@entry=0xc83520) at thread/qthread.cpp:536
#9  0x00007f4e963215d3 in QInotifyFileSystemWatcherEngine::run (this=0xc83520) at io/qfilesystemwatcher_inotify.cpp:256
#10 0x00007f4e9623f1ff in QThreadPrivate::start (arg=0xc83520) at thread/qthread_unix.cpp:338
#11 0x00007f4e95faf1da in start_thread () from /lib64/libpthread.so.0
#12 0x00007f4e94d599cd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f4e62899700 (LWP 4976)):
#0  0x00007f4e94d2993d in nanosleep () from /lib64/libc.so.6
#1  0x00007f4e94d297e1 in sleep () from /lib64/libc.so.6
#2  0x00007f4e88e6d572 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#3  0x00007f4e88e6d5f9 in ?? () from /usr/lib64/qt4/libQtScript.so.4
#4  0x00007f4e95faf1da in start_thread () from /lib64/libpthread.so.0
#5  0x00007f4e94d599cd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f4e976e8780 (LWP 4972)):
[KCrash Handler]
#6  0x00007f4e956cb859 in QRasterWindowSurface::~QRasterWindowSurface (this=0x3441b40, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x00007f4e956cb8d9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x3441b40, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x00007f4e956e3d3c in QWidgetBackingStore::~QWidgetBackingStore (this=0x347dc40, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x00007f4e95522219 in QWidgetBackingStoreTracker::destroy (this=0x3469490) at kernel/qwidget.cpp:225
#10 0x00007f4e955223b9 in QWidgetPrivate::deleteExtra (this=this@entry=0x2d358f0) at kernel/qwidget.cpp:1833
#11 0x00007f4e955225ed in QWidgetPrivate::~QWidgetPrivate (this=0x2d358f0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#12 0x00007f4e955228a9 in QWidgetPrivate::~QWidgetPrivate (this=0x2d358f0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#13 0x00007f4e9635a925 in cleanup (pointer=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x2d35898, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x2d35890, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#16 0x00007f4e9552b1ca in QWidget::~QWidget (this=0x2d35890, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#17 0x00007f4e7fa686e0 in ~XSyncBasedPoller (this=0x2d35890, __in_chrg=<optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.14.3-r1/work/kdelibs-4.14.3/kutils/kidletime/xsyncbasedpoller.cpp:100
#18 XSyncBasedPoller::~XSyncBasedPoller (this=0x2d35890, __in_chrg=<optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.14.3-r1/work/kdelibs-4.14.3/kutils/kidletime/xsyncbasedpoller.cpp:102
#19 0x00007f4e7fa6856d in ~XSyncBasedPollerHelper (this=0x2d35310, __in_chrg=<optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.14.3-r1/work/kdelibs-4.14.3/kutils/kidletime/xsyncbasedpoller.cpp:33
#20 destroy () at /var/tmp/portage/kde-base/kdelibs-4.14.3-r1/work/kdelibs-4.14.3/kutils/kidletime/xsyncbasedpoller.cpp:38
#21 0x00007f4e94ca7319 in ?? () from /lib64/libc.so.6
#22 0x00007f4e94ca73a5 in exit () from /lib64/libc.so.6
#23 0x00000000004080dc in launch (argc=argc@entry=1, _name=_name@entry=0x6cb888 "/usr/bin/plasma-desktop", args=args@entry=0x6cb8a0 "", cwd=cwd@entry=0x0, envc=envc@entry=0, envs=<optimized out>, envs@entry=0x6cb8a8 "", reset_env=false, tty=tty@entry=0x0, avoid_loops=false, startup_id_str=startup_id_str@entry=0x40a906 "0") at /var/tmp/portage/kde-base/kdelibs-4.14.3-r1/work/kdelibs-4.14.3/kinit/kinit.cpp:726
#24 0x0000000000408f6b in handle_launcher_request (sock=7, who=<optimized out>) at /var/tmp/portage/kde-base/kdelibs-4.14.3-r1/work/kdelibs-4.14.3/kinit/kinit.cpp:1218
#25 0x00000000004095d3 in handle_requests (waitForPid=waitForPid@entry=0) at /var/tmp/portage/kde-base/kdelibs-4.14.3-r1/work/kdelibs-4.14.3/kinit/kinit.cpp:1411
#26 0x000000000040531d in main (argc=2, argv=0x7fff978e9ad8, envp=0x7fff978e9af0) at /var/tmp/portage/kde-base/kdelibs-4.14.3-r1/work/kdelibs-4.14.3/kinit/kinit.cpp:1899

Possible duplicates by query: bug 344044, bug 341844, bug 335349, bug 334657.

Reported using DrKonqi
Comment 1 Christoph Feck 2015-03-18 06:46:43 UTC

*** This bug has been marked as a duplicate of bug 261539 ***