Bug 334657 - plasma desktop crash
Summary: plasma desktop crash
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.11.9
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-05-12 12:42 UTC by vikram goyal
Modified: 2014-05-13 01:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vikram goyal 2014-05-12 12:42:52 UTC
Application: plasma-desktop (4.11.9)
KDE Platform Version: 4.12.5
Qt Version: 4.8.6
Operating System: Linux 3.14.3-200.fc20.x86_64 x86_64
Distribution: "Fedora release 20 (Heisenbug)"

-- Information about the crash:
- What I was doing when the application crashed:

I had heavily modified the desktop with extra panels, new color schemes, animated cursors etc. I had closed all apps before logout.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f035fb228c0 (LWP 25822))]

Thread 4 (Thread 0x7f0346e1e700 (LWP 25842)):
#0  0x00000036418bc98d in nanosleep () at ../sysdeps/unix/syscall-template.S:81
#1  0x00000036418bc824 in __sleep (seconds=0) at ../sysdeps/unix/sysv/linux/sleep.c:137
#2  0x00000038c178eee2 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x38c1a8df00 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2363
#3  0x00000038c178ef69 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0x0000003641c07f33 in start_thread (arg=0x7f0346e1e700) at pthread_create.c:309
#5  0x00000036418f4ded in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7f02bbfff700 (LWP 25857)):
#0  0x0000003641c0a0d8 in __GI___pthread_mutex_lock (mutex=0x7f02b4000a60) at ../nptl/pthread_mutex_lock.c:125
#1  0x000000364448a5a1 in g_mutex_lock (mutex=mutex@entry=0x7f02b40009a0) at gthread-posix.c:213
#2  0x000000364444959a in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7f02b40029b0, timeout=-1, context=0x7f02b40009a0) at gmain.c:4002
#3  g_main_context_iterate (context=context@entry=0x7f02b40009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3708
#4  0x00000036444496dc in g_main_context_iteration (context=0x7f02b40009a0, may_block=1) at gmain.c:3774
#5  0x00000038b7db5af6 in QEventDispatcherGlib::processEvents (this=0x7f02b40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0x00000038b7d8595f in QEventLoop::processEvents (this=this@entry=0x7f02bbffecc0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00000038b7d85cad in QEventLoop::exec (this=this@entry=0x7f02bbffecc0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00000038b7c79e8f in QThread::exec (this=this@entry=0x2030740) at thread/qthread.cpp:538
#9  0x00000038b7d662e3 in QInotifyFileSystemWatcherEngine::run (this=0x2030740) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00000038b7c7c6bf in QThreadPrivate::start (arg=0x2030740) at thread/qthread_unix.cpp:349
#11 0x0000003641c07f33 in start_thread (arg=0x7f02bbfff700) at pthread_create.c:309
#12 0x00000036418f4ded in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7f02a3fff700 (LWP 2277)):
#0  0x000000364448a5d1 in g_mutex_unlock (mutex=<optimized out>) at gthread-posix.c:232
#1  0x0000003644449549 in g_main_context_iterate (context=context@entry=0x7f029c0009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3715
#2  0x00000036444496dc in g_main_context_iteration (context=0x7f029c0009a0, may_block=1) at gmain.c:3774
#3  0x00000038b7db5af6 in QEventDispatcherGlib::processEvents (this=0x7f029c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#4  0x00000038b7d8595f in QEventLoop::processEvents (this=this@entry=0x7f02a3ffecc0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00000038b7d85cad in QEventLoop::exec (this=this@entry=0x7f02a3ffecc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00000038b7c79e8f in QThread::exec (this=this@entry=0x2b67910) at thread/qthread.cpp:538
#7  0x00000038b7d662e3 in QInotifyFileSystemWatcherEngine::run (this=0x2b67910) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00000038b7c7c6bf in QThreadPrivate::start (arg=0x2b67910) at thread/qthread_unix.cpp:349
#9  0x0000003641c07f33 in start_thread (arg=0x7f02a3fff700) at pthread_create.c:309
#10 0x00000036418f4ded in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7f035fb228c0 (LWP 25822)):
[KCrash Handler]
#6  0x0000003f36bc8b69 in QRasterWindowSurface::~QRasterWindowSurface (this=0x213c710, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#7  0x0000003f36bc8be9 in QRasterWindowSurface::~QRasterWindowSurface (this=0x213c710, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#8  0x0000003f36be17ac in QWidgetBackingStore::~QWidgetBackingStore (this=0xc16ef0, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#9  0x0000003f36a10af9 in QWidgetBackingStoreTracker::destroy (this=0x18084d0) at kernel/qwidget.cpp:225
#10 0x0000003f36a10ca9 in QWidgetPrivate::deleteExtra (this=this@entry=0x2f97730) at kernel/qwidget.cpp:1833
#11 0x0000003f36a10ebd in QWidgetPrivate::~QWidgetPrivate (this=0x2f97730, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#12 0x0000003f36a11149 in QWidgetPrivate::~QWidgetPrivate (this=0x2f97730, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#13 0x00000038b7da09e5 in cleanup (pointer=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#14 ~QScopedPointer (this=0x2f96fc8, __in_chrg=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#15 QObject::~QObject (this=0x2f96fc0, __in_chrg=<optimized out>) at kernel/qobject.cpp:844
#16 0x0000003f36a1a14c in QWidget::~QWidget (this=0x2f96fc0, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#17 0x0000003f2e609960 in ~XSyncBasedPoller (this=0x2f96fc0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.12.5/kutils/kidletime/xsyncbasedpoller.cpp:100
#18 XSyncBasedPoller::~XSyncBasedPoller (this=0x2f96fc0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.12.5/kutils/kidletime/xsyncbasedpoller.cpp:102
#19 0x0000003f2e6097ed in ~XSyncBasedPollerHelper (this=0x2f96fa0, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.12.5/kutils/kidletime/xsyncbasedpoller.cpp:33
#20 destroy () at /usr/src/debug/kdelibs-4.12.5/kutils/kidletime/xsyncbasedpoller.cpp:38
#21 0x00000036418394c9 in __run_exit_handlers (status=0, listp=0x3641bb86c8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#22 0x0000003641839515 in __GI_exit (status=<optimized out>) at exit.c:104
#23 0x0000003641821d6c in __libc_start_main (main=0x400940 <main(int, char**)>, argc=1, argv=0x7fff724d34b8, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff724d34a8) at libc-start.c:319
#24 0x0000000000400971 in _start ()

Possible duplicates by query: bug 330038, bug 327798, bug 324407, bug 324180, bug 320766.

Reported using DrKonqi
Comment 1 Jekyll Wu 2014-05-13 01:24:10 UTC

*** This bug has been marked as a duplicate of bug 261539 ***