Bug 335349 - crash at shutdown after install of ATI Radeon video card.
Summary: crash at shutdown after install of ATI Radeon video card.
Status: RESOLVED DUPLICATE of bug 261539
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: 4.11.9
Platform: openSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-05-26 00:57 UTC by Jim Ohlmacher
Modified: 2014-05-26 10:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Ohlmacher 2014-05-26 00:57:46 UTC
Application: plasma-desktop (4.11.9)
KDE Platform Version: 4.11.5
Qt Version: 4.8.5
Operating System: Linux 3.11.10-11-default i686
Distribution: "openSUSE 13.1 (Bottle) (i586)"

-- Information about the crash:
Seems to happen every time.  System re-boots OK.

The crash can be reproduced every time.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb53db740 (LWP 1082))]

Thread 4 (Thread 0xae0bfb40 (LWP 1084)):
#0  0xb76e3430 in __kernel_vsyscall ()
#1  0xb6b9df3c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb0f0c832 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=this@entry=0xb10087e0 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#3  0xb0f0c87f in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=0xb10087e0 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#4  0xb6b9a07a in start_thread () from /lib/libpthread.so.0
#5  0xb5f1d80e in clone () from /lib/libc.so.6

Thread 3 (Thread 0xa66a3b40 (LWP 1109)):
#0  0xb58c6cbb in ?? () from /usr/lib/libglib-2.0.so.0
#1  0xb58c9481 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#2  0xb58c9a9a in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb58c9c48 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb6d5d60f in QEventDispatcherGlib::processEvents (this=0xa5d00468, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#5  0xb6d2ca03 in QEventLoop::processEvents (this=this@entry=0xa66a3258, flags=...) at kernel/qeventloop.cpp:149
#6  0xb6d2cd29 in QEventLoop::exec (this=this@entry=0xa66a3258, flags=...) at kernel/qeventloop.cpp:204
#7  0xb6c1b30d in QThread::exec (this=this@entry=0x91ea5d8) at thread/qthread.cpp:536
#8  0xb6d0ce14 in QInotifyFileSystemWatcherEngine::run (this=0x91ea5d8) at io/qfilesystemwatcher_inotify.cpp:256
#9  0xb6c1dc5f in QThreadPrivate::start (arg=0x91ea5d8) at thread/qthread_unix.cpp:338
#10 0xb6b9a07a in start_thread () from /lib/libpthread.so.0
#11 0xb5f1d80e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xa49ffb40 (LWP 1119)):
#0  0xb6b9c2ac in pthread_mutex_lock () from /lib/libpthread.so.0
#1  0xb590cc70 in g_mutex_lock () from /usr/lib/libglib-2.0.so.0
#2  0xb58c8c76 in g_main_context_release () from /usr/lib/libglib-2.0.so.0
#3  0xb58c9ab0 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0xb58c9c48 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0xb6d5d60f in QEventDispatcherGlib::processEvents (this=0xa4000468, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#6  0xb6d2ca03 in QEventLoop::processEvents (this=this@entry=0xa49ff258, flags=...) at kernel/qeventloop.cpp:149
#7  0xb6d2cd29 in QEventLoop::exec (this=this@entry=0xa49ff258, flags=...) at kernel/qeventloop.cpp:204
#8  0xb6c1b30d in QThread::exec (this=this@entry=0x94e8798) at thread/qthread.cpp:536
#9  0xb6d0ce14 in QInotifyFileSystemWatcherEngine::run (this=0x94e8798) at io/qfilesystemwatcher_inotify.cpp:256
#10 0xb6c1dc5f in QThreadPrivate::start (arg=0x94e8798) at thread/qthread_unix.cpp:338
#11 0xb6b9a07a in start_thread () from /lib/libpthread.so.0
#12 0xb5f1d80e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb53db740 (LWP 1082)):
[KCrash Handler]
#7  0xb643b622 in QRasterWindowSurface::~QRasterWindowSurface (this=0x970e2b8, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:117
#8  0xb643b6ac in QRasterWindowSurface::~QRasterWindowSurface (this=0x970e2b8, __in_chrg=<optimized out>) at painting/qwindowsurface_raster.cpp:121
#9  0xb6456764 in QWidgetBackingStore::~QWidgetBackingStore (this=<optimized out>, __in_chrg=<optimized out>) at painting/qbackingstore.cpp:909
#10 0xb6265973 in QWidgetBackingStoreTracker::destroy (this=0x90f9bd0) at kernel/qwidget.cpp:225
#11 0xb6265b28 in QWidgetPrivate::deleteExtra (this=this@entry=0x9c359b8) at kernel/qwidget.cpp:1833
#12 0xb6265d2d in QWidgetPrivate::~QWidgetPrivate (this=0x9c359b8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:365
#13 0xb6265fdc in QWidgetPrivate::~QWidgetPrivate (this=0x9c359b8, __in_chrg=<optimized out>) at kernel/qwidget.cpp:370
#14 0xb6d47d86 in cleanup (pointer=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:62
#15 ~QScopedPointer (this=0x9c2b33c, __in_chrg=<optimized out>) at ../../src/corelib/tools/qscopedpointer.h:100
#16 QObject::~QObject (this=0x9c2b338, __in_chrg=<optimized out>) at kernel/qobject.cpp:816
#17 0xb626f625 in QWidget::~QWidget (this=<optimized out>, __in_chrg=<optimized out>) at kernel/qwidget.cpp:1554
#18 0xaf966bbc in AbstractSystemPoller::~AbstractSystemPoller (this=0x9c2b338, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.11.5/kutils/kidletime/abstractsystempoller.cpp:26
#19 0xaf968f4f in ~XSyncBasedPoller (this=0x9c2b338, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.11.5/kutils/kidletime/xsyncbasedpoller.cpp:100
#20 XSyncBasedPoller::~XSyncBasedPoller (this=0x9c2b338, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.11.5/kutils/kidletime/xsyncbasedpoller.cpp:102
#21 0xaf968dc9 in ~XSyncBasedPollerHelper (this=0x9c359a8, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.11.5/kutils/kidletime/xsyncbasedpoller.cpp:33
#22 destroy () at /usr/src/debug/kdelibs-4.11.5/kutils/kidletime/xsyncbasedpoller.cpp:38
#23 0xaf966619 in KCleanUpGlobalStatic::~KCleanUpGlobalStatic (this=0xaf96f17c <._273::operator->()::cleanUpObject>, __in_chrg=<optimized out>) at /usr/src/debug/kdelibs-4.11.5/kdecore/kernel/kglobal.h:62
#24 0xb5e605a1 in __run_exit_handlers () from /lib/libc.so.6
#25 0xb5e605fd in exit () from /lib/libc.so.6
#26 0x0804fbab in _start ()

Possible duplicates by query: bug 334657, bug 330038, bug 327798, bug 324407, bug 324180.

Reported using DrKonqi
Comment 1 Christoph Feck 2014-05-26 10:03:02 UTC

*** This bug has been marked as a duplicate of bug 261539 ***