Bug 342666 - Digikam crashes during find new items.
Summary: Digikam crashes during find new items.
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Metadata-Video (show other bugs)
Version: 4.1.0
Platform: Mint (Debian based) Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-09 18:45 UTC by Casey Finnerty
Modified: 2018-02-28 12:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Casey Finnerty 2015-01-09 18:45:31 UTC
Application: digikam (4.1.0)
KDE Platform Version: 4.14.1
Qt Version: 4.8.6
Operating System: Linux 3.16.0-4-amd64 x86_64
Distribution: SolydK 64-bit

-- Information about the crash:
- What I was doing when the application crashed:
Digikam crashes at startup about 40% into finding new items. Running Digikam 4.1 on SolydK (based on Debian stable). Using MySQL database. Same problem appears when setting up Digikam using an sqlite database.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7fb1ed596b00 (LWP 5918))]

Thread 4 (Thread 0x7fb1c5c17700 (LWP 5919)):
#0  0x00007fb1e64350ed in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb1c9dcefd8 in ?? () from /lib/x86_64-linux-gnu/libusb-1.0.so.0
#2  0x00007fb1e22d00a4 in start_thread (arg=0x7fb1c5c17700) at pthread_create.c:309
#3  0x00007fb1e643dc2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 3 (Thread 0x7fb1bad5f700 (LWP 5920)):
[KCrash Handler]
#5  0x00007fb1e638d077 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#6  0x00007fb1e638e458 in __GI_abort () at abort.c:89
#7  0x00007fb1e63cafb4 in __libc_message (do_abort=do_abort@entry=1, fmt=fmt@entry=0x7fb1e64bdbc0 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/posix/libc_fatal.c:175
#8  0x00007fb1e63d078e in malloc_printerr (action=1, str=0x7fb1e64bdd80 "free(): invalid next size (fast)", ptr=<optimized out>) at malloc.c:4996
#9  0x00007fb1e63d1496 in _int_free (av=<optimized out>, p=<optimized out>, have_lock=0) at malloc.c:3840
#10 0x00007fb1e32bb4f9 in Exiv2::RiffVideo::infoTagsHandler() () from /usr/lib/x86_64-linux-gnu/libexiv2.so.13
#11 0x00007fb1e32bf355 in Exiv2::RiffVideo::decodeBlock() () from /usr/lib/x86_64-linux-gnu/libexiv2.so.13
#12 0x00007fb1e32bef88 in Exiv2::RiffVideo::tagDecoder(Exiv2::DataBuf&, unsigned long) () from /usr/lib/x86_64-linux-gnu/libexiv2.so.13
#13 0x00007fb1e32bf355 in Exiv2::RiffVideo::decodeBlock() () from /usr/lib/x86_64-linux-gnu/libexiv2.so.13
#14 0x00007fb1e32bf6f8 in Exiv2::RiffVideo::readMetadata() () from /usr/lib/x86_64-linux-gnu/libexiv2.so.13
#15 0x00007fb1eb1b3e0d in KExiv2Iface::KExiv2::load(QString const&) const () from /usr/lib/libkexiv2.so.11
#16 0x00007fb1eaaa86f6 in Digikam::DMetadata::load(QString const&) const () from /usr/lib/digikam/libdigikamcore.so.4.1.0
#17 0x00007fb1ea4c4a47 in Digikam::ImageScanner::loadFromDisk() () from /usr/lib/digikam/libdigikamdatabase.so.4.1.0
#18 0x00007fb1ea4c4c30 in Digikam::ImageScanner::newFile(int) () from /usr/lib/digikam/libdigikamdatabase.so.4.1.0
#19 0x00007fb1ea456dd6 in Digikam::CollectionScanner::scanNewFile(QFileInfo const&, int) () from /usr/lib/digikam/libdigikamdatabase.so.4.1.0
#20 0x00007fb1ea45a4c2 in Digikam::CollectionScanner::scanAlbum(Digikam::CollectionLocation const&, QString const&) () from /usr/lib/digikam/libdigikamdatabase.so.4.1.0
#21 0x00007fb1ea45a37c in Digikam::CollectionScanner::scanAlbum(Digikam::CollectionLocation const&, QString const&) () from /usr/lib/digikam/libdigikamdatabase.so.4.1.0
#22 0x00007fb1ea45a37c in Digikam::CollectionScanner::scanAlbum(Digikam::CollectionLocation const&, QString const&) () from /usr/lib/digikam/libdigikamdatabase.so.4.1.0
#23 0x00007fb1ea45ad13 in Digikam::CollectionScanner::scanAlbumRoot(Digikam::CollectionLocation const&) () from /usr/lib/digikam/libdigikamdatabase.so.4.1.0
#24 0x00007fb1ea45c555 in Digikam::CollectionScanner::completeScan() () from /usr/lib/digikam/libdigikamdatabase.so.4.1.0
#25 0x00000000005f7050 in ?? ()
#26 0x00007fb1e722c3ff in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#27 0x00007fb1e22d00a4 in start_thread (arg=0x7fb1bad5f700) at pthread_create.c:309
#28 0x00007fb1e643dc2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 2 (Thread 0x7fb1ba55e700 (LWP 5921)):
#0  0x00007fb1e64350ed in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007fb1dea01ee4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb1dea01ffc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb1e7365167 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#4  0x00007fb1e7334801 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#5  0x00007fb1e7334b65 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007fb1e7229b99 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007fb1e7315303 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007fb1e722c3ff in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007fb1e22d00a4 in start_thread (arg=0x7fb1ba55e700) at pthread_create.c:309
#10 0x00007fb1e643dc2d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:111

Thread 1 (Thread 0x7fb1ed596b00 (LWP 5918)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fb1e722c956 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#2  0x00007fb1e722bf8e in QThread::wait(unsigned long) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#3  0x00000000005f560b in ?? ()
#4  0x00000000005f58d7 in ?? ()
#5  0x00007fb1e638fb39 in __run_exit_handlers (status=1, listp=0x7fb1e66fa5a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:82
#6  0x00007fb1e638fb85 in __GI_exit (status=<optimized out>) at exit.c:104
#7  0x00007fb1e7dc28a8 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#8  0x00007fb1e8acdb90 in KApplication::xioErrhandler(_XDisplay*) () from /usr/lib/libkdeui.so.5
#9  0x00007fb1e49154fe in _XIOError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#10 0x00007fb1e4912e5d in _XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#11 0x00007fb1e4904700 in XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#12 0x00007fb1e7dfbabc in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#13 0x00007fb1dea018c1 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#14 0x00007fb1dea01e83 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#15 0x00007fb1dea01ffc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#16 0x00007fb1e736514d in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#17 0x00007fb1e7dfc056 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#18 0x00007fb1e7334801 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#19 0x00007fb1e7334b65 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#20 0x00000000005f2a31 in ?? ()
#21 0x0000000000525a07 in ?? ()
#22 0x00007fb1e734f2c1 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#23 0x00007fb1e7d5731c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#24 0x00007fb1e7d5de18 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#25 0x00007fb1e8acf13a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#26 0x00007fb1e7335cad in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#27 0x00007fb1e7339541 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#28 0x00007fb1e7365003 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#29 0x00007fb1dea01c5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007fb1dea01f48 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007fb1dea01ffc in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007fb1e736514d in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#33 0x00007fb1e7dfc056 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#34 0x00007fb1e7334801 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#35 0x00007fb1e7334b65 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#36 0x00007fb1e733a5c7 in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#37 0x0000000000493d36 in ?? ()
#38 0x00007fb1e6379b45 in __libc_start_main (main=0x492bf0, argc=5, argv=0x7fffd8ff3f48, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffd8ff3f38) at libc-start.c:287
#39 0x000000000049632f in _start ()

Possible duplicates by query: bug 340808, bug 340373, bug 335225, bug 335224, bug 333332.

Report to https://bugs.kde.org/
Comment 1 caulier.gilles 2015-01-09 19:37:20 UTC

*** This bug has been marked as a duplicate of bug 340373 ***
Comment 2 caulier.gilles 2018-02-28 12:37:55 UTC
With 6.0.0, we have now a FFMpeg low level metadata parser based on libav C API
for video files database registration.

The Exiv2 video support is not used anymore as this code is buggous and nobody
sound motivated in Exiv2 to finalize the code.

The original post for this file must be fixed now and video metadata support
with ffmpeg must be enough to populate database entries.

Gilles Caulier