Bug 336685 - Plasma-Desktop generated error notification
Summary: Plasma-Desktop generated error notification
Status: RESOLVED WORKSFORME
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kshareddatacache (show other bugs)
Version: 4.13.2
Platform: Kubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-25 00:26 UTC by pbea
Modified: 2018-11-30 04:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pbea 2014-06-25 00:26:50 UTC
Hello . . .

As above, I received an error notification when I logged into KDE  SC 4.13.2. I followed the prompts but somehow I lost the wizard. I found this text in my home directory. Hope it helps. This is above my pay grade so I know nothing about the text!

Application: plasma-desktop (4.11.10)
KDE Platform Version: 4.13.2
Qt Version: 4.8.6
Operating System: Linux 3.13.0-30-generic i686
Distribution: Ubuntu 14.04 LTS

-- Information about the crash:
<In detail, tell us what you were doing  when the application crashed.>
I logged into KDE and the message showed.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Bus error
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1152a40 (LWP 3382))]

Thread 4 (Thread 0xa3d9fb40 (LWP 3385)):
#0  0xb774d424 in __kernel_vsyscall ()
#1  0xb20f8d4b in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:187
#2  0xb75fc8ec in __pthread_cond_wait (cond=0xb32068d0, mutex=0xb32068b8) at forward.c:149
#3  0xb3103c92 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb3103cdf in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb20f4f70 in start_thread (arg=0xa3d9fb40) at pthread_create.c:312
#6  0xb75ef70e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:129

Thread 3 (Thread 0xa2101b40 (LWP 3386)):
#0  0xb20f81f4 in __GI___pthread_mutex_unlock (mutex=0xa1800558) at pthread_mutex_unlock.c:310
#1  0xb75fcb34 in pthread_mutex_unlock (mutex=0xa1800558) at forward.c:194
#2  0xb201d140 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb1fd7515 in g_main_context_release () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb1fd8390 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb1fd8528 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb605d95f in QEventDispatcherGlib::processEvents (this=0xa1800468, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#7  0xb602c823 in QEventLoop::processEvents (this=this@entry=0xa2101258, flags=...) at kernel/qeventloop.cpp:149
#8  0xb602cb49 in QEventLoop::exec (this=this@entry=0xa2101258, flags=...) at kernel/qeventloop.cpp:204
#9  0xb5f1923d in QThread::exec (this=this@entry=0xa96ae98) at thread/qthread.cpp:537
#10 0xb600cc44 in QInotifyFileSystemWatcherEngine::run (this=0xa96ae98) at io/qfilesystemwatcher_inotify.cpp:265
#11 0xb5f1bb6f in QThreadPrivate::start (arg=0xa96ae98) at thread/qthread_unix.cpp:349
#12 0xb20f4f70 in start_thread (arg=0xa2101b40) at pthread_create.c:312
#13 0xb75ef70e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:129

Thread 2 (Thread 0xa0450b40 (LWP 3387)):
#0  0xb20f7021 in __GI___pthread_mutex_lock (mutex=0x9fb00558) at ../nptl/pthread_mutex_lock.c:63
#1  0xb75fcaf4 in pthread_mutex_lock (mutex=0x9fb00558) at forward.c:192
#2  0xb201d100 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb1fd8398 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb1fd8528 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb605d95f in QEventDispatcherGlib::processEvents (this=0x9fb00468, flags=...) at kernel/qeventdispatcher_glib.cpp:436
#6  0xb602c823 in QEventLoop::processEvents (this=this@entry=0xa0450258, flags=...) at kernel/qeventloop.cpp:149
#7  0xb602cb49 in QEventLoop::exec (this=this@entry=0xa0450258, flags=...) at kernel/qeventloop.cpp:204
#8  0xb5f1923d in QThread::exec (this=this@entry=0xa592bf0) at thread/qthread.cpp:537
#9  0xb600cc44 in QInotifyFileSystemWatcherEngine::run (this=0xa592bf0) at io/qfilesystemwatcher_inotify.cpp:265
#10 0xb5f1bb6f in QThreadPrivate::start (arg=0xa592bf0) at thread/qthread_unix.cpp:349
#11 0xb20f4f70 in start_thread (arg=0xa0450b40) at pthread_create.c:312
#12 0xb75ef70e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:129

Thread 1 (Thread 0xb1152a40 (LWP 3382)):
[KCrash Handler]
#7  0xb642f575 in lock (this=0xa034c20) at ../../kdecore/util/kshareddatacache.cpp:1235
#8  cautiousLock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1259
#9  CacheLocker (_d=<optimized out>, this=<synthetic pointer>) at ../../kdecore/util/kshareddatacache.cpp:1309
#10 KSharedDataCache::clear (this=this@entry=0xa034b68) at ../../kdecore/util/kshareddatacache.cpp:1650
#11 0xb670ea10 in KImageCache::clear (this=0xa034b68) at ../../kdeui/util/kimagecache.cpp:167
#12 0xb739e52b in Plasma::ThemePrivate::discardCache (this=0xa0361b8, caches=...) at ../../plasma/theme.cpp:380
#13 0xb739e60b in Plasma::ThemePrivate::notifyOfChanged (this=0xa0361b8) at ../../plasma/theme.cpp:437
#14 0xb73a6ea3 in Plasma::Theme::qt_static_metacall (_o=<optimized out>, _id=<optimized out>, _a=0xbfb3d698, _c=<optimized out>) at ./theme.moc:101
#15 0xb60430f7 in QMetaObject::activate (sender=sender@entry=0xa033970, m=m@entry=0xb619a518 <QTimer::staticMetaObject>, local_signal_index=local_signal_index@entry=0, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#16 0xb6093435 in QTimer::timeout (this=this@entry=0xa033970) at .moc/release-shared/moc_qtimer.cpp:147
#17 0xb604c926 in QTimer::timerEvent (this=0xa033970, e=0xbfb3da10) at kernel/qtimer.cpp:280
#18 0xb604755c in QObject::event (this=0xa033970, e=0xbfb3da10) at kernel/qobject.cpp:1156
#19 0xb55397f4 in QApplicationPrivate::notify_helper (this=0x9f3ddd8, receiver=0xa033970, e=0xbfb3da10) at kernel/qapplication.cpp:4567
#20 0xb55402d3 in QApplication::notify (this=0x9f08330, receiver=receiver@entry=0xa033970, e=e@entry=0xbfb3da10) at kernel/qapplication.cpp:4353
#21 0xb66a21f4 in KApplication::notify (this=0x9f08330, receiver=0xa033970, event=0xbfb3da10) at ../../kdeui/kernel/kapplication.cpp:311
#22 0xb602de4a in QCoreApplication::notifyInternal (this=0x9f08330, receiver=0xa033970, event=event@entry=0xbfb3da10) at kernel/qcoreapplication.cpp:953
#23 0xb60607bb in sendEvent (event=0xbfb3da10, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QTimerInfoList::activateTimers (this=this@entry=0x9f43c9c) at kernel/qeventdispatcher_unix.cpp:621
#25 0xb605d788 in timerSourceDispatch (source=0x9f43c68) at kernel/qeventdispatcher_glib.cpp:193
#26 0xb1fd81e3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#27 0xb1fd8468 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#28 0xb1fd8528 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#29 0xb605d93b in QEventDispatcherGlib::processEvents (this=this@entry=0x9ed7eb8, flags=...) at kernel/qeventdispatcher_glib.cpp:434
#30 0xb55ee5de in QGuiEventDispatcherGlib::processEvents (this=0x9ed7eb8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#31 0xb602c823 in QEventLoop::processEvents (this=this@entry=0xbfb3dc38, flags=...) at kernel/qeventloop.cpp:149
#32 0xb602cb49 in QEventLoop::exec (this=this@entry=0xbfb3dc38, flags=...) at kernel/qeventloop.cpp:204
#33 0xb60328fe in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1225
#34 0xb5537a24 in QApplication::exec () at kernel/qapplication.cpp:3828
#35 0xb7709d27 in kdemain (argc=1, argv=0xbfb3ddd4) at ../../../../plasma/desktop/shell/main.cpp:126
#36 0x0804855b in main (argc=1, argv=0xbfb3ddd4) at plasma-desktop_dummy.cpp:3

Possible duplicates by query: bug 333475, bug 330525, bug 329564.


Reproducible: Sometimes

Steps to Reproduce:
1. log into KDE (sometimes)
2. the error message shows
3.


Expected Results:  
I received the expected results even with the message. KDE opened.
Comment 1 Andrew Crouthamel 2018-10-31 03:54:38 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 2 Bug Janitor Service 2018-11-15 10:48:10 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2018-11-30 04:01:08 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!