Bug 336155 - "Rin command interface" crashed at startup
Summary: "Rin command interface" crashed at startup
Status: RESOLVED NOT A BUG
Alias: None
Product: krunner
Classification: Unclassified
Component: general (show other bugs)
Version: 4.11.9
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Vishesh Handa
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-06-13 08:24 UTC by Andrew
Modified: 2014-06-13 17:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2014-06-13 08:24:17 UTC
Application: krunner (4.11.9)
KDE Platform Version: 4.12.5
Qt Version: 4.8.6
Operating System: Linux 3.14.6-200.fc20.x86_64 x86_64
Distribution: "Fedora release 20 (Heisenbug)"

-- Information about the crash:
Happened while KDE startup (session restore enabled). Two more apps crashed similarly (kmix, konsole).
Don't reproduces for now.

-- Backtrace:
Application: Run Command Interface (krunner), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f1f7c59b8c0 (LWP 2162))]

Thread 2 (Thread 0x7f1f70182700 (LWP 2170)):
#0  0x0000003e0621a680 in pthread_mutex_lock@plt () from /lib64/libglib-2.0.so.0
#1  0x0000003e0628a5a1 in g_mutex_lock () from /lib64/libglib-2.0.so.0
#2  0x0000003e06248bf9 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#3  0x0000003e062494bb in g_main_context_iterate.isra () from /lib64/libglib-2.0.so.0
#4  0x0000003e062496dc in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#5  0x00000031437b5af6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#6  0x000000314378595f in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#7  0x0000003143785cad in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib64/libQtCore.so.4
#8  0x0000003143679e8f in QThread::exec() () from /lib64/libQtCore.so.4
#9  0x00000031437662e3 in QInotifyFileSystemWatcherEngine::run() () from /lib64/libQtCore.so.4
#10 0x000000314367c6bf in QThreadPrivate::start(void*) () from /lib64/libQtCore.so.4
#11 0x0000003e03607f33 in start_thread () from /lib64/libpthread.so.0
#12 0x0000003e032f4ded in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f1f7c59b8c0 (LWP 2162)):
[KCrash Handler]
#5  0x0000003e03611298 in __lll_unlock_elision () from /lib64/libpthread.so.0
#6  0x0000003f4c03c32b in KSharedDataCache::find(QString const&, QByteArray*) const () from /lib64/libkdecore.so.5
#7  0x0000003f4caae6c5 in KImageCache::findPixmap(QString const&, QPixmap*) const () from /lib64/libkdeui.so.5
#8  0x0000003f55fd5463 in Plasma::Theme::findInCache(QString const&, QPixmap&) () from /lib64/libplasma.so.3
#9  0x0000003f55fd110f in Plasma::SvgPrivate::findInCache(QString const&, QSizeF const&) () from /lib64/libplasma.so.3
#10 0x0000003f55fd165d in Plasma::Svg::paint(QPainter*, QRectF const&, QString const&) () from /lib64/libplasma.so.3
#11 0x0000003f55f6497e in Plasma::FrameSvgPrivate::generateFrameBackground(Plasma::FrameData*) () from /lib64/libplasma.so.3
#12 0x0000003f55f66bb3 in Plasma::FrameSvgPrivate::generateBackground(Plasma::FrameData*) () from /lib64/libplasma.so.3
#13 0x0000003f55f67e70 in Plasma::FrameSvgPrivate::alphaMask() () from /lib64/libplasma.so.3
#14 0x0000003f55f68752 in Plasma::FrameSvg::mask() const () from /lib64/libplasma.so.3
#15 0x0000003f51422b94 in KRunnerDialog::updateMask() () from /lib64/libkdeinit4_krunner.so
#16 0x0000003f51423298 in KRunnerDialog::checkBorders(QRect const&) () from /lib64/libkdeinit4_krunner.so
#17 0x0000003f51423d26 in KRunnerDialog::updatePresentation() () from /lib64/libkdeinit4_krunner.so
#18 0x0000003f5142412d in KRunnerDialog::KRunnerDialog(Plasma::RunnerManager*, QWidget*, QFlags<Qt::WindowType>) () from /lib64/libkdeinit4_krunner.so
#19 0x0000003f5142a04f in Interface::Interface(Plasma::RunnerManager*, QWidget*) () from /lib64/libkdeinit4_krunner.so
#20 0x0000003f514270e4 in KRunnerApp::initialize() () from /lib64/libkdeinit4_krunner.so
#21 0x0000003f5142771e in KRunnerApp::KRunnerApp() () from /lib64/libkdeinit4_krunner.so
#22 0x0000003f51427775 in KRunnerApp::self() () from /lib64/libkdeinit4_krunner.so
#23 0x0000003f51427c4d in kdemain () from /lib64/libkdeinit4_krunner.so
#24 0x0000003e03221d65 in __libc_start_main () from /lib64/libc.so.6
#25 0x00000000004008d1 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 317595.

Possible duplicates by query: bug 317595.

Reported using DrKonqi
Comment 1 Rex Dieter 2014-06-13 12:59:07 UTC
Your sycoca cache is likely corrupt.

To force regeneration as a workaround, run:
 kbuildsycoca4 --noincremental
Comment 2 Christoph Feck 2014-06-13 17:12:44 UTC
Reported as bug 336156.