Bug 317595 - KDE Crashes seemingly randomly
Summary: KDE Crashes seemingly randomly
Status: RESOLVED DUPLICATE of bug 249362
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kshareddatacache (show other bugs)
Version: 4.8.5
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-30 10:00 UTC by Scott Neville
Modified: 2016-09-06 12:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Scott Neville 2013-03-30 10:00:25 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.8.5 (4.8.5) "release 2"
Qt Version: 4.8.1
Operating System: Linux 3.4.33-2.24-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Useing firefox to browse ebay, without warning KDE desktop crashes, task bar and plasma desktop go.  They restart, a little while later, still browsing ebay (though with a different search term, not that it should make much difference), desktop crashes again this time it does not restart.  

Used ctrl + alt + F2 to get to the console, done init 3, init 5, logged back on.  Used VirtualBox over X11 forwarding to a local server, KDE desktop crashes again and restarts again.  Used the KDE reporting tool to report the issue, installing the debug packages through YaST, KDE crashes again and restarts again.

-- Backtrace:
Application: Plasma Desktop Shell (kdeinit4), signal: Bus error
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9242ca9780 (LWP 3074))]

Thread 3 (Thread 0x7f921e9b6700 (LWP 3078)):
#0  0x00007f92402e614f in poll () from /lib64/libc.so.6
#1  0x00007f923cff3684 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f923cff37a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9241932956 in QEventDispatcherGlib::processEvents (this=0x7f92100008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f924190373f in QEventLoop::processEvents (this=this@entry=0x7f921e9b5df0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f92419039c8 in QEventLoop::exec (this=0x7f921e9b5df0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9241807e40 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f92418e411f in QInotifyFileSystemWatcherEngine::run (this=0x158a5b0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f924180addb in QThreadPrivate::start (arg=0x158a5b0) at thread/qthread_unix.cpp:298
#9  0x00007f9241574e0e in start_thread () from /lib64/libpthread.so.0
#10 0x00007f92402ee2cd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f921df7d700 (LWP 3079)):
#0  0x00007f92415788f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f923653a217 in QTWTF::TCMalloc_PageHeap::scavengerThread (this=0x7f9236847640 <QTWTF::pageheap_memory>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:2359
#2  0x00007f923653a249 in QTWTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at ../3rdparty/javascriptcore/JavaScriptCore/wtf/FastMalloc.cpp:1464
#3  0x00007f9241574e0e in start_thread () from /lib64/libpthread.so.0
#4  0x00007f92402ee2cd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f9242ca9780 (LWP 3074)):
[KCrash Handler]
#6  0x00007f9241e8438b in SharedMemory::findNamedEntry (this=0x7f92214df000, key=...) at /usr/src/debug/kdelibs-4.8.5/kdecore/util/kshareddatacache.cpp:766
#7  0x00007f9241e81674 in KSharedDataCache::find (this=0x15ea810, key=..., destination=0x7fff7b88f980) at /usr/src/debug/kdelibs-4.8.5/kdecore/util/kshareddatacache.cpp:1637
#8  0x00007f92426fe672 in KImageCache::findPixmap (this=0x15ea810, key=..., destination=0x7fff7b88f9e0) at /usr/src/debug/kdelibs-4.8.5/kdeui/util/kimagecache.cpp:150
#9  0x00007f9238533c83 in Plasma::Theme::findInCache (this=0xd93110, key=..., pix=...) at /usr/src/debug/kdelibs-4.8.5/plasma/theme.cpp:963
#10 0x00007f92384ca940 in Plasma::FrameSvgPrivate::generateBackground (this=0x24a0b00, frame=0x2500b00) at /usr/src/debug/kdelibs-4.8.5/plasma/framesvg.cpp:671
#11 0x00007f92384c6aad in Plasma::FrameSvgPrivate::alphaMask (this=0x24a0b00) at /usr/src/debug/kdelibs-4.8.5/plasma/framesvg.cpp:646
#12 0x00007f92384cb98e in Plasma::FrameSvg::mask (this=<optimized out>) at /usr/src/debug/kdelibs-4.8.5/plasma/framesvg.cpp:459
#13 0x00007f9238505a6e in Plasma::ToolTip::resizeEvent (this=0x246a3c0, e=0x7fff7b8904f0) at /usr/src/debug/kdelibs-4.8.5/plasma/private/tooltip.cpp:344
#14 0x00007f9240ae3e46 in QWidget::event (this=0x246a3c0, event=0x7fff7b8904f0) at kernel/qwidget.cpp:8516
#15 0x00007f9240a9474c in QApplicationPrivate::notify_helper (this=this@entry=0xc5e760, receiver=receiver@entry=0x246a3c0, e=e@entry=0x7fff7b8904f0) at kernel/qapplication.cpp:4554
#16 0x00007f9240a98c7a in QApplication::notify (this=0xc2f1c0, receiver=0x246a3c0, e=0x7fff7b8904f0) at kernel/qapplication.cpp:4415
#17 0x00007f924269d006 in KApplication::notify (this=0xc2f1c0, receiver=0x246a3c0, event=0x7fff7b8904f0) at /usr/src/debug/kdelibs-4.8.5/kdeui/kernel/kapplication.cpp:311
#18 0x00007f924190473e in QCoreApplication::notifyInternal (this=0xc2f1c0, receiver=0x246a3c0, event=0x7fff7b8904f0) at kernel/qcoreapplication.cpp:876
#19 0x00007f9240ade746 in sendEvent (event=0x7fff7b8904f0, receiver=0x246a3c0) at ../../src/corelib/kernel/qcoreapplication.h:231
#20 QWidgetPrivate::sendPendingMoveAndResizeEvents (this=this@entry=0x2539550, recursive=recursive@entry=false, disableUpdates=<optimized out>, disableUpdates@entry=false) at kernel/qwidget.cpp:7432
#21 0x00007f9240ae60d1 in QWidgetPrivate::show_helper (this=this@entry=0x2539550) at kernel/qwidget.cpp:7483
#22 0x00007f9240ae64d2 in QWidget::setVisible (this=0x246a3c0, visible=<optimized out>) at kernel/qwidget.cpp:7764
#23 0x00007f923853f25c in show (this=<optimized out>) at /usr/include/QtGui/qwidget.h:494
#24 Plasma::ToolTipManagerPrivate::showToolTip (this=0xe93340) at /usr/src/debug/kdelibs-4.8.5/plasma/tooltipmanager.cpp:423
#25 0x00007f923853f4e9 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /usr/src/debug/kdelibs-4.8.5/build/plasma/tooltipmanager.moc:65
#26 Plasma::ToolTipManager::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /usr/src/debug/kdelibs-4.8.5/build/plasma/tooltipmanager.moc:57
#27 0x00007f924191af5f in QMetaObject::activate (sender=0xe92e40, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3556
#28 0x00007f9241918edc in QObject::event (this=0xe92e40, e=<optimized out>) at kernel/qobject.cpp:1166
#29 0x00007f9240a9474c in QApplicationPrivate::notify_helper (this=this@entry=0xc5e760, receiver=receiver@entry=0xe92e40, e=e@entry=0x7fff7b891010) at kernel/qapplication.cpp:4554
#30 0x00007f9240a98c7a in QApplication::notify (this=0xc2f1c0, receiver=0xe92e40, e=0x7fff7b891010) at kernel/qapplication.cpp:4415
#31 0x00007f924269d006 in KApplication::notify (this=0xc2f1c0, receiver=0xe92e40, event=0x7fff7b891010) at /usr/src/debug/kdelibs-4.8.5/kdeui/kernel/kapplication.cpp:311
#32 0x00007f924190473e in QCoreApplication::notifyInternal (this=0xc2f1c0, receiver=0xe92e40, event=0x7fff7b891010) at kernel/qcoreapplication.cpp:876
#33 0x00007f92419351c1 in sendEvent (event=0x7fff7b891010, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#34 QTimerInfoList::activateTimers (this=0xc5ccb0) at kernel/qeventdispatcher_unix.cpp:626
#35 0x00007f92419322d4 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#36 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#37 0x00007f92419322f1 in idleTimerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:233
#38 0x00007f923cff33b5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#39 0x00007f923cff36e8 in ?? () from /usr/lib64/libglib-2.0.so.0
#40 0x00007f923cff37a4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#41 0x00007f9241932936 in QEventDispatcherGlib::processEvents (this=0xc5dd40, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#42 0x00007f9240b348ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#43 0x00007f924190373f in QEventLoop::processEvents (this=this@entry=0x7fff7b891290, flags=...) at kernel/qeventloop.cpp:149
#44 0x00007f92419039c8 in QEventLoop::exec (this=0x7fff7b891290, flags=...) at kernel/qeventloop.cpp:204
#45 0x00007f92419083a8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#46 0x00007f922ff1e5b5 in kdemain (argc=1, argv=0xbe62b0) at /usr/src/debug/kde-workspace-4.8.5/plasma/desktop/shell/main.cpp:120
#47 0x0000000000408892 in _start ()

Possible duplicates by query: bug 311920.

Reported using DrKonqi
Comment 1 Dominik Haumann 2016-09-06 12:21:06 UTC

*** This bug has been marked as a duplicate of bug 249362 ***