Bug 336157 - konsole crash at startup
Summary: konsole crash at startup
Status: RESOLVED NOT A BUG
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 2.12.4
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-06-13 08:27 UTC by Andrew
Modified: 2014-06-15 17:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Trace for Kopete crash, another PC (3.60 KB, text/plain)
2014-06-15 15:59 UTC, Andrew
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew 2014-06-13 08:27:57 UTC
Application: konsole (2.12.4)
KDE Platform Version: 4.12.5
Qt Version: 4.8.6
Operating System: Linux 3.14.6-200.fc20.x86_64 x86_64
Distribution: "Fedora release 20 (Heisenbug)"

-- Information about the crash:
Happened while KDE startup (session restore enabled). Two more apps crashed similarly ("run command interface" and kmix).
Don't reproduces for now.

-- Backtrace:
Application: Konsole (konsole), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#5  0x0000003e03611298 in __lll_unlock_elision () from /lib64/libpthread.so.0
#6  0x0000003f4c03c32b in KSharedDataCache::find(QString const&, QByteArray*) const () from /lib64/libkdecore.so.5
#7  0x0000003f4c9fd728 in KIconLoaderPrivate::findCachedPixmapWithPath(QString const&, QPixmap&, QString&) () from /lib64/libkdeui.so.5
#8  0x0000003f4c9fdafa in KIconLoader::loadIcon(QString const&, KIconLoader::Group, int, int, QStringList const&, QString*, bool) const () from /lib64/libkdeui.so.5
#9  0x0000003f4c9fed5e in SmallIcon(QString const&, int, int, QStringList const&) () from /lib64/libkdeui.so.5
#10 0x0000003f4cb00ea3 in KLineEdit::updateClearButtonIcon(QString const&) () from /lib64/libkdeui.so.5
#11 0x0000003f4cb01739 in KLineEdit::setClearButtonShown(bool) () from /lib64/libkdeui.so.5
#12 0x0000003f4fe6ee4f in Konsole::IncrementalSearchBar::IncrementalSearchBar(QWidget*) () from /lib64/libkonsoleprivate.so
#13 0x0000003f4fec1917 in Konsole::ViewContainer::searchBar() () from /lib64/libkonsoleprivate.so
#14 0x0000003f4fec2325 in Konsole::TabbedViewContainer::TabbedViewContainer(Konsole::ViewContainer::NavigationPosition, Konsole::ViewManager*, QObject*) () from /lib64/libkonsoleprivate.so
#15 0x0000003f4fec5db8 in Konsole::ViewManager::createContainer() () from /lib64/libkonsoleprivate.so
#16 0x0000003f4fecb918 in Konsole::ViewManager::createView(Konsole::Session*) () from /lib64/libkonsoleprivate.so
#17 0x0000003f4fece271 in Konsole::ViewManager::restoreSessions(KConfigGroup const&) () from /lib64/libkonsoleprivate.so
#18 0x0000003f4cb07823 in KMainWindow::readPropertiesInternal(KConfig*, int) () from /lib64/libkdeui.so.5
#19 0x0000003f4cb079ca in KMainWindow::restore(int, bool) () from /lib64/libkdeui.so.5
#20 0x0000003f4fa170bc in restoreSession(Konsole::Application&) () from /lib64/libkdeinit4_konsole.so
#21 0x0000003f4fa17b95 in kdemain () from /lib64/libkdeinit4_konsole.so
#22 0x0000003e03221d65 in __libc_start_main () from /lib64/libc.so.6
#23 0x0000000000400871 in _start ()

The reporter indicates this bug may be a duplicate of or related to bug 334640.

Possible duplicates by query: bug 334846, bug 334640, bug 333544.

Reported using DrKonqi
Comment 1 Rex Dieter 2014-06-13 12:59:38 UTC
Your sycoca cache is likely corrupt.

To force regeneration as a workaround, run:
 kbuildsycoca4 --noincremental
Comment 2 Christoph Feck 2014-06-13 17:13:15 UTC
Reported as bug 336156.
Comment 3 Andrew 2014-06-15 15:58:39 UTC
(In reply to comment #1)
I'm not sure regarding "invalid" resolution—the crash should be absent anyway, as for me.

As for workaround, thanks for the point but restarted after that it was fine without any additional actions.

Besides that, caught something similar with Kopete at another machine. Can't report it with DrKonqi because of strange error at the end of submission process: "error 32000, the version value 1.6.2 is not active".
Attaching here.
Comment 4 Andrew 2014-06-15 15:59:36 UTC
Created attachment 87205 [details]
Trace for Kopete crash, another PC
Comment 5 Christoph Feck 2014-06-15 17:00:10 UTC
This bug is invalid, because you already reported it as bug 336156. We do not mark duplicates from the same reporter, as to not skew the duplicate count statistics.

The Kopete crash is completely unrelated, and you already know it as bug 302563.