Bug 335249 - Dolphin failed when undoing a "move to trash" operation
Summary: Dolphin failed when undoing a "move to trash" operation
Status: RESOLVED DUPLICATE of bug 325359
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 4.11.5
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-05-23 16:05 UTC by K. A. Sayeed
Modified: 2014-05-23 16:14 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description K. A. Sayeed 2014-05-23 16:05:54 UTC
Application: dolphin (4.11.5)
KDE Platform Version: 4.11.5
Qt Version: 4.8.4
Operating System: Linux 3.11.0-20-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:

1. Moved folders to Trash

2. Then tried to undo the "Move to Trash" operation

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f75964397c0 (LWP 2067))]

Thread 4 (Thread 0x7f757ab5d700 (LWP 2292)):
#0  0x00007f7595ceff7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f758d7336a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f758d7337ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7591bafa76 in QEventDispatcherGlib::processEvents (this=0x7f75740008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f7591b815ef in QEventLoop::processEvents (this=this@entry=0x7f757ab5cd70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f7591b818e5 in QEventLoop::exec (this=this@entry=0x7f757ab5cd70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f7591a8088f in QThread::exec (this=this@entry=0x1d28380) at thread/qthread.cpp:542
#7  0x00007f7591b62d13 in QInotifyFileSystemWatcherEngine::run (this=0x1d28380) at io/qfilesystemwatcher_inotify.cpp:265
#8  0x00007f7591a82f2f in QThreadPrivate::start (arg=0x1d28380) at thread/qthread_unix.cpp:338
#9  0x00007f758dc0bf6e in start_thread (arg=0x7f757ab5d700) at pthread_create.c:311
#10 0x00007f7595cfc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f7579c38700 (LWP 2308)):
#0  0x00007f7595cee6bd in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f758d772670 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f758d7331cc in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f758d73363b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f758d7337ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f7591bafa76 in QEventDispatcherGlib::processEvents (this=0x7f756c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f7591b815ef in QEventLoop::processEvents (this=this@entry=0x7f7579c37d70, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f7591b818e5 in QEventLoop::exec (this=this@entry=0x7f7579c37d70, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f7591a8088f in QThread::exec (this=this@entry=0x1f1d650) at thread/qthread.cpp:542
#9  0x00007f7591b62d13 in QInotifyFileSystemWatcherEngine::run (this=0x1f1d650) at io/qfilesystemwatcher_inotify.cpp:265
#10 0x00007f7591a82f2f in QThreadPrivate::start (arg=0x1f1d650) at thread/qthread_unix.cpp:338
#11 0x00007f758dc0bf6e in start_thread (arg=0x7f7579c38700) at pthread_create.c:311
#12 0x00007f7595cfc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f757891d700 (LWP 2473)):
#0  0x00007f7595ceff7d in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f758d7336a4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f758d7337ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7591bafa76 in QEventDispatcherGlib::processEvents (this=0x7f75700008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f7591b815ef in QEventLoop::processEvents (this=this@entry=0x7f757891cd70, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f7591b818e5 in QEventLoop::exec (this=this@entry=0x7f757891cd70, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f7591a8088f in QThread::exec (this=this@entry=0x249b4d0) at thread/qthread.cpp:542
#7  0x00007f7591b65e6d in QDnotifySignalThread::run (this=0x249b4d0) at io/qfilesystemwatcher_dnotify.cpp:179
#8  0x00007f7591a82f2f in QThreadPrivate::start (arg=0x249b4d0) at thread/qthread_unix.cpp:338
#9  0x00007f758dc0bf6e in start_thread (arg=0x7f757891d700) at pthread_create.c:311
#10 0x00007f7595cfc9cd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f75964397c0 (LWP 2067)):
[KCrash Handler]
#5  0x00007f75950027a3 in KFileItemModel::lessThan(KFileItemModel::ItemData const*, KFileItemModel::ItemData const*) const () from /usr/lib/libdolphinprivate.so.4
#6  0x00007f7595009aee in KFileItemModel::insertItems(QList<KFileItemModel::ItemData*>&) () from /usr/lib/libdolphinprivate.so.4
#7  0x00007f759500a09f in KFileItemModel::dispatchPendingItemsToInsert() () from /usr/lib/libdolphinprivate.so.4
#8  0x00007f759500a234 in KFileItemModel::slotCompleted() () from /usr/lib/libdolphinprivate.so.4
#9  0x00007f7591b96a58 in QMetaObject::activate (sender=0x222d840, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff7faf4f70) at kernel/qobject.cpp:3539
#10 0x00007f75939edce5 in KDirLister::completed(KUrl const&) () from /usr/lib/libkio.so.5
#11 0x00007f75939f8952 in ?? () from /usr/lib/libkio.so.5
#12 0x00007f7591b96a58 in QMetaObject::activate (sender=0x29c6140, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff7faf51f0) at kernel/qobject.cpp:3539
#13 0x00007f759200b752 in KJob::result(KJob*) () from /usr/lib/libkdecore.so.5
#14 0x00007f759200b790 in KJob::emitResult() () from /usr/lib/libkdecore.so.5
#15 0x00007f75939d7a4a in KIO::SimpleJob::slotFinished() () from /usr/lib/libkio.so.5
#16 0x00007f75939dc44e in KIO::ListJob::slotFinished() () from /usr/lib/libkio.so.5
#17 0x00007f7591b96a58 in QMetaObject::activate (sender=0x2c4f7f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#18 0x00007f7593a76e96 in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /usr/lib/libkio.so.5
#19 0x00007f7593a7498e in KIO::SlaveInterface::dispatch() () from /usr/lib/libkio.so.5
#20 0x00007f7593a695f6 in KIO::Slave::gotInput() () from /usr/lib/libkio.so.5
#21 0x00007f7591b96a58 in QMetaObject::activate (sender=0x29e2080, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#22 0x00007f75939a58d1 in ?? () from /usr/lib/libkio.so.5
#23 0x00007f7591b9adce in QObject::event (this=0x29e2080, e=<optimized out>) at kernel/qobject.cpp:1194
#24 0x00007f7592573dfc in QApplicationPrivate::notify_helper (this=this@entry=0x1b311d0, receiver=receiver@entry=0x29e2080, e=e@entry=0x29f4410) at kernel/qapplication.cpp:4567
#25 0x00007f759257a470 in QApplication::notify (this=0x7fff7faf5f20, receiver=0x29e2080, e=0x29f4410) at kernel/qapplication.cpp:4353
#26 0x00007f759327da6a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#27 0x00007f7591b828bd in QCoreApplication::notifyInternal (this=0x7fff7faf5f20, receiver=receiver@entry=0x29e2080, event=event@entry=0x29f4410) at kernel/qcoreapplication.cpp:946
#28 0x00007f7591b85e1f in sendEvent (event=0x29f4410, receiver=0x29e2080) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#29 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x1af3180) at kernel/qcoreapplication.cpp:1570
#30 0x00007f7591b862c3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#31 0x00007f7591bb0073 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#32 postEventSourceDispatch (s=0x1b1a6f0) at kernel/qeventdispatcher_glib.cpp:279
#33 0x00007f758d7333b6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007f758d733708 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#35 0x00007f758d7337ac in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#36 0x00007f7591bafa55 in QEventDispatcherGlib::processEvents (this=0x1af4a40, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#37 0x00007f75926159d6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#38 0x00007f7591b815ef in QEventLoop::processEvents (this=this@entry=0x7fff7faf5df0, flags=...) at kernel/qeventloop.cpp:149
#39 0x00007f7591b818e5 in QEventLoop::exec (this=this@entry=0x7fff7faf5df0, flags=...) at kernel/qeventloop.cpp:204
#40 0x00007f7591b86e5b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#41 0x00007f759601b587 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_dolphin.so
#42 0x00007f7595c23de5 in __libc_start_main (main=0x4006d0, argc=3, ubp_av=0x7fff7faf6058, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff7faf6048) at libc-start.c:260
#43 0x00000000004006fe in _start ()

Possible duplicates by query: bug 334655, bug 332144, bug 332102, bug 330731, bug 326566.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2014-05-23 16:14:37 UTC
Thanks for the bug report. This issue has been fixed some time ago - you are encouraged to upgrade to a newer Dolphin/KDE SC version.

*** This bug has been marked as a duplicate of bug 325359 ***