Bug 326566 - Dolphin crashes while browsing through directory tree
Summary: Dolphin crashes while browsing through directory tree
Status: RESOLVED DUPLICATE of bug 325359
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 4.11.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-10-24 14:44 UTC by v.vogelhuber
Modified: 2013-10-24 19:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description v.vogelhuber 2013-10-24 14:44:23 UTC
Application: dolphin (4.11.2)
KDE Platform Version: 4.11.2
Qt Version: 4.8.4
Operating System: Linux 3.11.0-12-generic x86_64
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:

Moved mouse after clicking on a directory tree item. I couldn't reproduce it, so it might not be directly related to the mouse input

The crash does not seem to be reproducible.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6a2f40d7c0 (LWP 2808))]

Thread 4 (Thread 0x7f6a13a07700 (LWP 2817)):
#0  0x00007f6a26be6055 in pthread_mutex_lock () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007f6a2674b391 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6a2670b11c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6a2670b62b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6a2670b79c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6a2ab87a76 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f6a2ab595ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f6a2ab598e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007f6a2aa5888f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f6a2ab3ad13 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007f6a2aa5af2f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#11 0x00007f6a26be3f6e in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#12 0x00007f6a2ecd19cd in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 3 (Thread 0x7f6a12b45700 (LWP 2818)):
#0  0x00007f6a2674b0da in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f6a2674b3b9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6a2670b289 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6a2670b6f8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6a2670b79c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6a2ab87a76 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f6a2ab595ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f6a2ab598e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007f6a2aa5888f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f6a2ab3ad13 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007f6a2aa5af2f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#11 0x00007f6a26be3f6e in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#12 0x00007f6a2ecd19cd in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 2 (Thread 0x7f6a03fff700 (LWP 3101)):
#0  0x00007f6a26be5f7a in pthread_mutex_lock () from /lib/x86_64-linux-gnu/libpthread.so.0
#1  0x00007f6a2674b391 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6a2670a928 in g_main_context_release () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6a2670b641 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6a2670b79c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6a2ab87a76 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#6  0x00007f6a2ab595ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#7  0x00007f6a2ab598e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#8  0x00007f6a2aa5888f in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#9  0x00007f6a2ab3ad13 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007f6a2aa5af2f in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#11 0x00007f6a26be3f6e in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#12 0x00007f6a2ecd19cd in clone () from /lib/x86_64-linux-gnu/libc.so.6

Thread 1 (Thread 0x7f6a2f40d7c0 (LWP 2808)):
[KCrash Handler]
#5  0x00007f6a2dfd833e in KFileItemModel::lessThan(KFileItemModel::ItemData const*, KFileItemModel::ItemData const*) const () from /usr/lib/libdolphinprivate.so.4
#6  0x00007f6a2dfdf55e in KFileItemModel::insertItems(QList<KFileItemModel::ItemData*>&) () from /usr/lib/libdolphinprivate.so.4
#7  0x00007f6a2dfdfb0f in KFileItemModel::dispatchPendingItemsToInsert() () from /usr/lib/libdolphinprivate.so.4
#8  0x00007f6a2dfdfca4 in KFileItemModel::slotCompleted() () from /usr/lib/libdolphinprivate.so.4
#9  0x00007f6a2ab6ea58 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#10 0x00007f6a2c9c40d5 in KDirLister::completed(KUrl const&) () from /usr/lib/libkio.so.5
#11 0x00007f6a2c9d14bf in ?? () from /usr/lib/libkio.so.5
#12 0x00007f6a2c9d163a in KDirLister::Private::CachedItemsJob::done() () from /usr/lib/libkio.so.5
#13 0x00007f6a2ab72dce in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#14 0x00007f6a2b54bdfc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#15 0x00007f6a2b552470 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#16 0x00007f6a2c255a6a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#17 0x00007f6a2ab5a8bd in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#18 0x00007f6a2ab5de1f in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#19 0x00007f6a2ab88073 in ?? () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#20 0x00007f6a2670b3a6 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007f6a2670b6f8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007f6a2670b79c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f6a2ab87a55 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#24 0x00007f6a2b5ed9d6 in ?? () from /usr/lib/x86_64-linux-gnu/libQtGui.so.4
#25 0x00007f6a2ab595ef in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#26 0x00007f6a2ab598e5 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#27 0x00007f6a2ab5ee5b in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQtCore.so.4
#28 0x00007f6a2eff0417 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_dolphin.so
#29 0x00007f6a2ebf8de5 in __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
#30 0x00000000004006fe in _start ()

Possible duplicates by query: bug 325359, bug 325059, bug 321744, bug 312679.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2013-10-24 19:37:09 UTC
Thanks for the bug report! There have been some changes recently to make the relevant code more robust, see https://git.reviewboard.kde.org/r/113070/.

I think that this kind of crash will probably not happen any more in Dolphin 4.12. If you see a crash with this backtrace again in Dolphin 4.12 when it's out, please let us know.

*** This bug has been marked as a duplicate of bug 325359 ***