Bug 330731 - while browsing, files show in wrong folder, then dolphin crashes
Summary: while browsing, files show in wrong folder, then dolphin crashes
Status: RESOLVED DUPLICATE of bug 325359
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 4.11.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2014-02-04 06:18 UTC by kdebugs
Modified: 2014-02-04 09:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kdebugs 2014-02-04 06:18:34 UTC
Application: dolphin (4.11.3)
KDE Platform Version: 4.11.3
Qt Version: 4.8.4
Operating System: Linux 3.11.0-15-generic i686
Distribution: Ubuntu 13.10

-- Information about the crash:
- What I was doing when the application crashed:
Browsing files/folders on an NTFS volume.  I had recently moved a folder into another - then expanded the folders to see if the files were moved okay.  When I clicked the ">" to expand the inner folder, dolphin expanded another outer folder, but showed under it the files which were under the folder I'd clicked instead of the files in the folder it appeared to expand.  (The files were never under that folder, so it wasn't just some kind of delay in moving.)  Then dolphin crashed.

- Custom settings of the application:
Using "details" view, sorting by name, no grouping or filters
Probably unrelated, but I'd been also recently been working with some test files (names with odd characters, super long names, etc.) and had the Name column expanded very wide.

-- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xaf4de740 (LWP 3837))]

Thread 4 (Thread 0xacc4fb40 (LWP 3838)):
#0  0xb4c2d86e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4c2dba8 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4beab18 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4beaca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb598c8df in QEventDispatcherGlib::processEvents (this=0xac300488, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0xb595b9f3 in QEventLoop::processEvents (this=this@entry=0xacc4f178, flags=...) at kernel/qeventloop.cpp:149
#6  0xb595bd19 in QEventLoop::exec (this=this@entry=0xacc4f178, flags=...) at kernel/qeventloop.cpp:204
#7  0xb584ae3d in QThread::exec (this=this@entry=0x99d1390) at thread/qthread.cpp:542
#8  0xb593be14 in QInotifyFileSystemWatcherEngine::run (this=0x99d1390) at io/qfilesystemwatcher_inotify.cpp:265
#9  0xb584d72f in QThreadPrivate::start (arg=0x99d1390) at thread/qthread_unix.cpp:338
#10 0xb1999101 in ?? () from /usr/lib/nvidia-304-updates/libGL.so.1
#11 0x5c8b0824 in ?? ()
#12 0xbab80424 in ?? ()
#13 0x65000000 in ?? ()
#14 0x001015ff in ?? ()
#15 0xd3890000 in ?? ()
#16 0xfff0013d in ?? ()
#17 0xc30173ff in ?? ()
#18 0x0fed12e8 in ?? ()
#19 0x9bc18100 in ?? ()
#20 0x8b00180b in ?? ()
#21 0xffff3089 in ?? ()
#22 0x65d8f7ff in ?? ()
#23 0x00000d03 in ?? ()
#24 0x01890000 in ?? ()
#25 0xc3ffc883 in ?? ()
#26 0x00acec81 in ?? ()
#27 0x9c890000 in ?? ()
#28 0x0000a024 in ?? ()
#29 0xece1e800 in ?? ()
#30 0xc381000f in ?? ()
#31 0x00180b6e in ?? ()
#32 0xa424b489 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 3 (Thread 0xac278b40 (LWP 3839)):
#0  0xb77c2424 in __kernel_vsyscall ()
#1  0xb765a4d2 in clock_gettime (clock_id=1, tp=0xac277f18) at ../sysdeps/unix/clock_gettime.c:115
#2  0xb58a83ec in do_gettime (frac=0xac277f10, sec=0xac277f08) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0xb598dfd2 in updateCurrentTime (this=0xab9020bc) at kernel/qeventdispatcher_unix.cpp:354
#5  QTimerInfoList::timerWait (this=0xab9020bc, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#6  0xb598c67b in timerSourcePrepareHelper (src=<optimized out>, timeout=0xac27800c) at kernel/qeventdispatcher_glib.cpp:136
#7  0xb598c70d in timerSourcePrepare (source=0xab902088, timeout=0xac27800c) at kernel/qeventdispatcher_glib.cpp:169
#8  0xb4bea143 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb4beaa5f in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb4beaca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#11 0xb598c8df in QEventDispatcherGlib::processEvents (this=0xab900488, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0xb595b9f3 in QEventLoop::processEvents (this=this@entry=0xac278178, flags=...) at kernel/qeventloop.cpp:149
#13 0xb595bd19 in QEventLoop::exec (this=this@entry=0xac278178, flags=...) at kernel/qeventloop.cpp:204
#14 0xb584ae3d in QThread::exec (this=this@entry=0x9a3b760) at thread/qthread.cpp:542
#15 0xb593be14 in QInotifyFileSystemWatcherEngine::run (this=0x9a3b760) at io/qfilesystemwatcher_inotify.cpp:265
#16 0xb584d72f in QThreadPrivate::start (arg=0x9a3b760) at thread/qthread_unix.cpp:338
#17 0xb1999101 in ?? () from /usr/lib/nvidia-304-updates/libGL.so.1
#18 0x5c8b0824 in ?? ()
#19 0xbab80424 in ?? ()
#20 0x65000000 in ?? ()
#21 0x001015ff in ?? ()
#22 0xd3890000 in ?? ()
#23 0xfff0013d in ?? ()
#24 0xc30173ff in ?? ()
#25 0x0fed12e8 in ?? ()
#26 0x9bc18100 in ?? ()
#27 0x8b00180b in ?? ()
#28 0xffff3089 in ?? ()
#29 0x65d8f7ff in ?? ()
#30 0x00000d03 in ?? ()
#31 0x01890000 in ?? ()
#32 0xc3ffc883 in ?? ()
#33 0x00acec81 in ?? ()
#34 0x9c890000 in ?? ()
#35 0x0000a024 in ?? ()
#36 0xece1e800 in ?? ()
#37 0xc381000f in ?? ()
#38 0x00180b6e in ?? ()
#39 0xa424b489 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xaa66eb40 (LWP 3898)):
#0  0xb4c2d86e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb4c2dba8 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb4bea59b in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb4beaafa in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb4beaca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb598c8df in QEventDispatcherGlib::processEvents (this=0x9e3ed08, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb595b9f3 in QEventLoop::processEvents (this=this@entry=0xaa66e178, flags=...) at kernel/qeventloop.cpp:149
#7  0xb595bd19 in QEventLoop::exec (this=this@entry=0xaa66e178, flags=...) at kernel/qeventloop.cpp:204
#8  0xb584ae3d in QThread::exec (this=this@entry=0x9e05800) at thread/qthread.cpp:542
#9  0xb593be14 in QInotifyFileSystemWatcherEngine::run (this=0x9e05800) at io/qfilesystemwatcher_inotify.cpp:265
#10 0xb584d72f in QThreadPrivate::start (arg=0x9e05800) at thread/qthread_unix.cpp:338
#11 0xb1999101 in ?? () from /usr/lib/nvidia-304-updates/libGL.so.1
#12 0x5c8b0824 in ?? ()
#13 0xbab80424 in ?? ()
#14 0x65000000 in ?? ()
#15 0x001015ff in ?? ()
#16 0xd3890000 in ?? ()
#17 0xfff0013d in ?? ()
#18 0xc30173ff in ?? ()
#19 0x0fed12e8 in ?? ()
#20 0x9bc18100 in ?? ()
#21 0x8b00180b in ?? ()
#22 0xffff3089 in ?? ()
#23 0x65d8f7ff in ?? ()
#24 0x00000d03 in ?? ()
#25 0x01890000 in ?? ()
#26 0xc3ffc883 in ?? ()
#27 0x00acec81 in ?? ()
#28 0x9c890000 in ?? ()
#29 0x0000a024 in ?? ()
#30 0xece1e800 in ?? ()
#31 0xc381000f in ?? ()
#32 0x00180b6e in ?? ()
#33 0xa424b489 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xaf4de740 (LWP 3837)):
[KCrash Handler]
#7  0xb73673cc in KFileItemModel::lessThan(KFileItemModel::ItemData const*, KFileItemModel::ItemData const*) const () from /usr/lib/libdolphinprivate.so.4
#8  0xb736ec5f in KFileItemModel::insertItems(QList<KFileItemModel::ItemData*>&) () from /usr/lib/libdolphinprivate.so.4
#9  0xb736f45e in KFileItemModel::dispatchPendingItemsToInsert() () from /usr/lib/libdolphinprivate.so.4
#10 0xb736f61e in KFileItemModel::slotCompleted() () from /usr/lib/libdolphinprivate.so.4
#11 0xb7370218 in ?? () from /usr/lib/libdolphinprivate.so.4
#12 0xb5971fc7 in QMetaObject::activate (sender=sender@entry=0x99fea78, m=m@entry=0xb6f0e97c <KDirLister::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0xbfacfdf8) at kernel/qobject.cpp:3539
#13 0xb6d61fd5 in KDirLister::completed (this=0x99fea78, _t1=...) at ./kdirlister.moc:234
#14 0xb6d70226 in KDirListerCache::emitItemsFromCache (this=0x99d4aa8, cachedItemsJob=cachedItemsJob@entry=0xa383168, lister=lister@entry=0x99fea78, _url=..., _reload=<optimized out>, _emitCompleted=_emitCompleted@entry=true) at ../../kio/kio/kdirlister.cpp:356
#15 0xb6d703e4 in KDirLister::Private::CachedItemsJob::done (this=this@entry=0xa383168) at ../../kio/kio/kdirlister.cpp:307
#16 0xb6d70554 in KDirLister::Private::CachedItemsJob::qt_static_metacall (_o=0xa383168, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xa27f8d8) at ./kdirlister_p.moc:160
#17 0xb596e77a in QMetaCallEvent::placeMetaCall (this=0xa3713f0, object=0xa383168) at kernel/qobject.cpp:524
#18 0xb597658b in QObject::event (this=0xa383168, e=0xa3713f0) at kernel/qobject.cpp:1194
#19 0xb5eb7744 in QApplicationPrivate::notify_helper (this=0x97a3320, receiver=0xa383168, e=0xa3713f0) at kernel/qapplication.cpp:4567
#20 0xb5ebe223 in QApplication::notify (this=0xbfad0520, receiver=receiver@entry=0xa383168, e=e@entry=0xa3713f0) at kernel/qapplication.cpp:4353
#21 0xb6a05ff4 in KApplication::notify (this=0xbfad0520, receiver=0xa383168, event=0xa3713f0) at ../../kdeui/kernel/kapplication.cpp:311
#22 0xb595ceda in QCoreApplication::notifyInternal (this=0xbfad0520, receiver=receiver@entry=0xa383168, event=event@entry=0xa3713f0) at kernel/qcoreapplication.cpp:946
#23 0xb59606ad in sendEvent (event=0xa3713f0, receiver=0xa383168) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#24 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0x977b638) at kernel/qcoreapplication.cpp:1570
#25 0xb5960bbc in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#26 0xb598cf6e in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#27 postEventSourceDispatch (s=0x97a3420) at kernel/qeventdispatcher_glib.cpp:279
#28 0xb4bea83e in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#29 0xb4beabe8 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#30 0xb4beaca8 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0xb598c8bf in QEventDispatcherGlib::processEvents (this=this@entry=0x977c378, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#32 0xb5f6c32e in QGuiEventDispatcherGlib::processEvents (this=0x977c378, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#33 0xb595b9f3 in QEventLoop::processEvents (this=this@entry=0xbfad0448, flags=...) at kernel/qeventloop.cpp:149
#34 0xb595bd19 in QEventLoop::exec (this=this@entry=0xbfad0448, flags=...) at kernel/qeventloop.cpp:204
#35 0xb596189e in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#36 0xb5eb5974 in QApplication::exec () at kernel/qapplication.cpp:3828
#37 0xb7768e9a in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_dolphin.so
#38 0x0804855b in ?? ()
#39 0xb756e905 in __libc_start_main (main=0x8048540, argc=6, ubp_av=0xbfad0604, init=0x8048660 <__libc_csu_init>, fini=0x80486d0 <__libc_csu_fini>, rtld_fini=0xb77d25f0 <_dl_fini>, stack_end=0xbfad05fc) at libc-start.c:260
#40 0x0804857e in _start ()

Possible duplicates by query: bug 326566, bug 325359, bug 325059, bug 321744.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2014-02-04 09:09:13 UTC
Thanks for the bug report. Fixed in 4.12.

*** This bug has been marked as a duplicate of bug 325359 ***