Bug 334320 - korganizer since kde 4.13.0 event no more sync
Summary: korganizer since kde 4.13.0 event no more sync
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Google Resource (show other bugs)
Version: 4.13
Platform: OpenSUSE Linux
: NOR normal with 92 votes (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords:
: 335231 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-05-04 10:38 UTC by Philippe ROUBACH
Modified: 2017-03-29 16:59 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.13.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2014-05-04 10:38:24 UTC
i updated from kde 4.12.4 to 4.13.0

if i create an event in korganizer then it not synchronized to google agenda .

i wait during one day but no sync .



Reproducible: Always
Comment 1 Torsten Bielen 2014-05-05 18:52:41 UTC
Same for me. Since 4.13.0 no sync. of calendar neither from google to kontact nor vice versa.

Opensuse 13.1
KDE 4.13
Comment 2 Philippe ROUBACH 2014-05-22 12:49:15 UTC
kde 4.13.1

no more pb form me
Comment 3 Daniel Vrátil 2014-06-02 12:23:42 UTC
*** Bug 335231 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Vrátil 2014-06-02 12:25:29 UTC
Git commit 92fda73949f82b4439e5a7e89fa868cb9532b943 by Dan Vrátil.
Committed on 02/06/2014 at 12:23.
Pushed by dvratil into branch 'KDE/4.13'.

Always restart a job that has failed due to invalid Google OAuth token

Once we refresh the tokens, we must restart the job, because otherwise
the Resource task won't be finished and ResourceScheduler will get
stuck forever.
FIXED-IN: 4.13.2

M  +1    -1    resources/google/common/googleresource.cpp

http://commits.kde.org/kdepim-runtime/92fda73949f82b4439e5a7e89fa868cb9532b943
Comment 5 Philippe ROUBACH 2014-06-06 05:19:40 UTC
in fact it is not fixed with kde 4.13.1
Comment 6 Philippe ROUBACH 2014-06-06 05:24:03 UTC
i discovered a new pb :

i create an event in android gmail calendar then it is well synced in google calendar but not in korganizer
Comment 7 Philippe ROUBACH 2014-06-06 05:27:25 UTC
if i quit then launch kontact the event is not synced

if i reopen a kde session then the event is synced
Comment 8 Daniel Vrátil 2014-06-11 09:31:54 UTC
This will be fixed in 4.13.2, not 4.13.1.

The other issue might be related to this, I'll retest later.
Comment 9 Gordon 2014-06-14 20:05:27 UTC
This has not been completely fixed in 4.13.2.  That is, while additions and deletions of calender entries, tasks and contacts are now synced to Google,  edited entries are not synced. This is a problem for both KOrganizer's Calendar and Tasks as well as KAddressBook where edited entries are not synced to Google's Calendar, Tasks and Address book.

So, it appears that 4.13.2 enabled syncing of new entries and deletions for KOrganizer and KAddressBook to Google. However, edited entries still do not sync.  Another bug has been created for this here: Bug 332410 which may or may not be regarded as a duplicate of this bug.
Comment 10 Philippe ROUBACH 2014-06-14 20:56:21 UTC
opensuse 13.1 x86_64
kde 4.13.2

i confirm no more sync pb when in korganizer if you add or remove an event

i confirm the pb for korganiser , no sync of any editing to google calendar for example adding a description
Comment 11 David Pyke 2014-07-07 15:23:27 UTC
*** This bug has been confirmed by popular vote. ***
Comment 12 Philippe ROUBACH 2014-08-15 07:08:55 UTC
opensuse 13.1 x86_64
kde 4.13.3

no sync to google calendar thus to android calendar when you move an event by a copy-past in korganizer
Comment 13 Lemmiwinks 2014-09-20 10:51:54 UTC
I have the same problem on Kubuntu 14.04 x64.
Edited events on google calendar will not be synced.
Has this been fixed in kde 4.14?
Comment 14 Martin Tlustos 2014-10-01 07:23:13 UTC
Same here - Kubuntu 14.04, kde 4.13.3
Editing is not synced, not even after days. When edited in google, it gets snced to my local copy within minutes, though...
Comment 15 Martin Tlustos 2014-10-01 12:09:18 UTC
weird behaviour that might be related: when editing a contact in kaddressbook, then later editing the same contact in google, the contact gets duplicated - one is the old version, one the new.
Can anybody confirm this?
Comment 16 Philippe ROUBACH 2014-10-01 12:37:15 UTC
please there is a bug report for kaddressbook sync pb
https://bugs.kde.org/show_bug.cgi?id=333907
Comment 17 Philippe ROUBACH 2015-01-01 06:52:23 UTC
opensuse 13.1 x86_64 , kde 4.14.3

no more pb when editing an event. this is well synced to google calendar
Comment 18 Jonny Mo 2015-01-02 11:28:18 UTC
(In reply to Philippe ROUBACH from comment #17)
> opensuse 13.1 x86_64 , kde 4.14.3
> 
> no more pb when editing an event. this is well synced to google calendar

i can only confirm this for the first editing of the event.

After a second try it failed as already described with a test in Bug 332410 - Comment 13.

Plattform: Arch Linux, x86_64 , kde 4.14.3
Comment 19 Philippe ROUBACH 2015-01-02 12:18:05 UTC
opensuse 13.1 , kde 4.14.3-1.15
akonadi
libkgapi2-2 (akonadi google resource) 2.2.0-1.1

i made these experiments to check the sync from korganizer to google calendar . 
all with success .

- create a new event with "apply" then "ok"
- change the hour of the event
- cut-paste the event to a new day and new hour
- change several times "description"
- add an alarm "one day before" to the previous one "15 mn before"

we all must be sure to have same kde 4.14.3 and same akonadi 4.14.3-1.15 and same libkgap2-2 2.2.0-10.1.1 according to be consistent in our report .

note : also for opensuse there are several versions of kde 4.14.3 , akonadi 4.14.3 , libkgapi2-2 2.2.0 : respectively akonadi 1.15 , libkgapi2-2 1.1

perhaps the differences between us comes from different versions .
Comment 20 Gordon 2015-01-02 13:05:55 UTC
I can confirm that edits to the kOrganizer calender appear to now be syncing to the google calendar.  However, edits to kAddressbook still do not sync to the google address book.  As before, additions and deletions within kAddressbook do sync to google, however, edited kAddressbook entries do not sync.

Environment: OpenSUSE 13.2, KDE 4.14.3, Akonadi 4.14.3-4.4, libkgapi2-2 2.2.0-2.1.4.
Comment 21 Philippe ROUBACH 2015-01-02 13:16:38 UTC
(In reply to Gordon from comment #20)
> However, edits to kAddressbook still do not sync to
> the google address book.  As before, additions and deletions within
> kAddressbook do sync to google, however, edited kAddressbook entries do not
> sync.
> 
there is a bug report for kaddressbook+akonadi google resource sync problems
https://bugs.kde.org/show_bug.cgi?id=333907
Comment 22 Gordon 2015-01-02 13:23:33 UTC
Thanks Philippe. I will add my comments to the other bug report.
Comment 23 Jonny Mo 2015-01-20 18:49:21 UTC
No more problems when editing an event. All changes seems to be synced.
Comment 24 Tom Kijas 2015-11-05 14:33:07 UTC
KDE5.4, the bug is still here...
Comment 25 Tom Kijas 2016-01-10 21:57:15 UTC
The bug persist in KDE5.4, synchronysing google-> kontact is OK, but kontact->google doesn't work!
Comment 26 Philippe ROUBACH 2017-03-29 16:59:03 UTC
I close, obsolete