Bug 333907 - kaddressbook contact no more sync
Summary: kaddressbook contact no more sync
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Google Resource (show other bugs)
Version: 4.13
Platform: OpenSUSE Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords:
: 342027 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-04-26 11:35 UTC by Philippe ROUBACH
Modified: 2017-03-29 16:57 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2014-04-26 11:35:06 UTC
i upgraded opensuse 13.1 from kde 4.12.4 to 4.13.0

i change the name of a contact => no sync in gmail contacts

i delete the contact => no sync in gmail contacts

i create a contact => no sync in gmail contacts

i create a contact in gmail contacts = no sync in kaddressbook

no sync pb with calendars

Reproducible: Always
Comment 1 Philippe ROUBACH 2014-04-29 09:38:43 UTC
sync works but it seems there is a big delay
Comment 2 Philippe ROUBACH 2014-06-14 20:57:59 UTC
opensuse 13.1 x86_64
kde 4.13.2

i confirm no more sync pb when in kaddessbook if you add or remove a contact
i confirm the pb for kaddressbook , no sync of any editing to google contacts for example adding a phone number
Comment 3 Philippe ROUBACH 2014-06-19 13:32:49 UTC
opensuse 131. x86_64
kde 4.13.2

i create a contact in android contacts => it is synchronized to gmail contacts
but no sync to kaddressbook
Comment 4 Martin Tlustos 2014-11-26 15:02:27 UTC
Here (Kubuntu 14.10, KDE 4.14.1) it is a bit different: creating and deleting contacts works, but changes to a contact are not synced from korganizer to google. Changes in Gmail contacts are synced to korganizer, but if I change a contact both in korganizer and Google, nothing gets updated from korganizer to google anymore, and changes from within google only get updated randomly to korganizer (address changes seem to work, but url does not etc.)
Comment 5 Philipp 2014-12-27 00:43:23 UTC
(In reply to Martin Tlustos from comment #4)
> Here (Kubuntu 14.10, KDE 4.14.1) it is a bit different: creating and
> deleting contacts works, but changes to a contact are not synced from
> korganizer to google. Changes in Gmail contacts are synced to korganizer,
> but if I change a contact both in korganizer and Google, nothing gets
> updated from korganizer to google anymore, and changes from within google
> only get updated randomly to korganizer (address changes seem to work, but
> url does not etc.)

exactly the same here on kubuntu 14.10 kde 4.14.1.
Comment 6 Philippe ROUBACH 2014-12-27 13:54:39 UTC
opensuse 13.1 x86_64
kde 4.14.3

change in a contact :

- honorific prefixes "M." to <nothing>
- personal / partners name  to <nothing>
- mobile to home / mobile
- contact / categories to "famille"
- notes 

result : closing/opening kontact , closing/opening kde , restarting pc and opening kde

no sync from kaddressbook to google contacts 
but after a delay all changes disappear because of a sync from google contacts to kaddressbook.

this is a big pb . i lost data about my contacts .
today after more than 6 months of this bug i can say akonadi google contacts is a beta application .

for my case i use more my pc to manage my contacts than my phone . it is rare when i change something with my smartphone .

i know there are not many developers but in this case kde pim team must prevent users from using  this akonadi google contacts agent .

if i want to keep using akonadi google contacts i must now only manage my contacts with google contacts site but i can't manage field as personal/categories which does not exist in google contatcs .
Comment 7 Gordon 2015-01-02 13:33:27 UTC
I can confirm that edits to kAddressbook do not sync to the google address book. Additions and deletions within kAddressbook do sync to google, however, edited kAddressbook entries do not sync thus requiring that my addressbook be managed entirely with google gmail instead of with kAddressbook.

***THIS IS A BIG DEAL*** - This bug makes kAddressbook unusable for Android users and other users that sync to google's gmail. Also, the bug has been around for over 8 months without reolution or even confirmation.  

My environment: OpenSUSE 13.2, KDE 4.14.3, Akonadi 4.14.3-4.4, libkgapi2-2 2.2.0-2.1.4.
Comment 8 Paulo 2015-02-11 19:54:19 UTC
Indeed it is a major drawback. Would it be possible to correct this bug? Is there a way to cooperate if needed ?

Best regards
Comment 9 Martin Tlustos 2015-05-07 12:44:40 UTC
*** Bug 342027 has been marked as a duplicate of this bug. ***
Comment 10 Philippe ROUBACH 2016-09-26 09:34:26 UTC
akonadi google contacts 5.1

problem still there!
Comment 11 Philippe ROUBACH 2016-12-23 15:25:37 UTC
opensuse 42.2 kontact 16.08

no more problem
Comment 12 Philippe ROUBACH 2017-01-14 13:35:03 UTC
i reopen report

i change  a data about a person in android contacts app.
then
i go to https://mail.google.com/mail/ca/u/0/#contacts
then
changes are well there
but
after several days changes are not there in kaddressbook.

sync from kaddressbook to google contacts runs well.

it's really a pity. since 2014 there is problem.
Comment 13 Philippe ROUBACH 2017-01-21 06:46:22 UTC
my 2 previous comment are about the 5 version. don't take account of these ones.

i opened a bug report for the 5 vesion. t's clearer.
Comment 14 Philippe ROUBACH 2017-03-29 16:57:49 UTC
i close, obsolete