Bug 300314 - Crash krdc
Summary: Crash krdc
Status: RESOLVED DUPLICATE of bug 291426
Alias: None
Product: krdc
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Urs Wolfer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-19 14:15 UTC by Meconio
Modified: 2012-05-20 01:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Meconio 2012-05-19 14:15:51 UTC
Application: krdc (4.8.2 (4.8.2))
KDE Platform Version: 4.8.2 (4.8.2)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-24-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

Tryed to acces in my office pc (Kubuntu 12) from my home pc (Kubuntu 12)

The crash can be reproduced every time.

-- Backtrace:
Application: KRDC (krdc), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe9d1817780 (LWP 4869))]

Thread 3 (Thread 0x7fe9bbca2700 (LWP 4870)):
#0  0x00007fe9ce403b03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe9caf88ff6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe9caf89124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe9ceb84426 in QEventDispatcherGlib::processEvents (this=0x7fe9b40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fe9ceb53c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fe9ceb53ed7 in QEventLoop::exec (this=0x7fe9bbca1dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fe9cea52fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fe9ceb339ff in QInotifyFileSystemWatcherEngine::run (this=0x2288210) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fe9cea55fcb in QThreadPrivate::start (arg=0x2288210) at thread/qthread_unix.cpp:298
#9  0x00007fe9cb455e9a in start_thread (arg=0x7fe9bbca2700) at pthread_create.c:308
#10 0x00007fe9ce40f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fe9bb41a700 (LWP 4871)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fe9cea564db in wait (time=18446744073709551615, this=0x7fe9ac0038a0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7fe9ac003880, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fe9cea52314 in QSemaphore::acquire (this=0x7fe9bb419a40, n=1) at thread/qsemaphore.cpp:144
#4  0x00007fe9ceb6977c in QMetaObject::activate (sender=0x29b2b60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3525
#5  0x00007fe9bdc69c58 in VncClientThread::passwdHandler (cl=<optimized out>) at ../../../krdc/vnc/vncclientthread.cpp:177
#6  0x00007fe9bda2f0ef in ?? () from /usr/lib/libvncclient.so.0
#7  0x00007fe9bda2f79f in InitialiseRFBConnection () from /usr/lib/libvncclient.so.0
#8  0x00007fe9bda315be in rfbInitClient () from /usr/lib/libvncclient.so.0
#9  0x00007fe9bdc6a81d in VncClientThread::run (this=0x29b2b60) at ../../../krdc/vnc/vncclientthread.cpp:369
#10 0x00007fe9cea55fcb in QThreadPrivate::start (arg=0x29b2b60) at thread/qthread_unix.cpp:298
#11 0x00007fe9cb455e9a in start_thread (arg=0x7fe9bb41a700) at pthread_create.c:308
#12 0x00007fe9ce40f4bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe9d1817780 (LWP 4869)):
[KCrash Handler]
#6  0x00000000004254f4 in MainWindow::statusChanged (this=0x242e750, status=RemoteView::Authenticating) at ../../krdc/mainwindow.cpp:445
#7  0x000000000042b3a6 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=0x242e750, _c=<optimized out>) at ./mainwindow.moc:123
#8  MainWindow::qt_static_metacall (_o=0x242e750, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./mainwindow.moc:104
#9  0x00007fe9ceb69281 in QMetaObject::activate (sender=0x29b2b00, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8992fb90) at kernel/qobject.cpp:3547
#10 0x00007fe9d0b2a4f1 in RemoteView::statusChanged (this=<optimized out>, _t1=RemoteView::Authenticating) at ./moc_remoteview.cpp:206
#11 0x00007fe9bdc6d47a in VncView::requestPassword (this=0x29b2b00) at ../../../krdc/vnc/vncview.cpp:231
#12 0x00007fe9ceb6e446 in QObject::event (this=0x29b2b00, e=<optimized out>) at kernel/qobject.cpp:1195
#13 0x00007fe9cf599b7b in QWidget::event (this=0x29b2b00, event=0x7fe9ac003930) at kernel/qwidget.cpp:8821
#14 0x00007fe9cf549894 in notify_helper (e=0x7fe9ac003930, receiver=0x29b2b00, this=0x220e030) at kernel/qapplication.cpp:4559
#15 QApplicationPrivate::notify_helper (this=0x220e030, receiver=0x29b2b00, e=0x7fe9ac003930) at kernel/qapplication.cpp:4531
#16 0x00007fe9cf54e713 in QApplication::notify (this=0x7fff899308c0, receiver=0x29b2b00, e=0x7fe9ac003930) at kernel/qapplication.cpp:4420
#17 0x00007fe9d0282b46 in KApplication::notify (this=0x7fff899308c0, receiver=0x29b2b00, event=0x7fe9ac003930) at ../../kdeui/kernel/kapplication.cpp:311
#18 0x00007fe9ceb54e9c in QCoreApplication::notifyInternal (this=0x7fff899308c0, receiver=0x29b2b00, event=0x7fe9ac003930) at kernel/qcoreapplication.cpp:876
#19 0x00007fe9ceb58c6a in sendEvent (event=0x7fe9ac003930, receiver=0x29b2b00) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x21e9520) at kernel/qcoreapplication.cpp:1500
#21 0x00007fe9ceb83f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#22 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#23 0x00007fe9caf88c9a in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007fe9caf89060 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007fe9caf89124 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#26 0x00007fe9ceb843bf in QEventDispatcherGlib::processEvents (this=0x21eae00, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#27 0x00007fe9cf5f1d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#28 0x00007fe9ceb53c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#29 0x00007fe9ceb53ed7 in QEventLoop::exec (this=0x7fff89930850, flags=...) at kernel/qeventloop.cpp:204
#30 0x00007fe9ceb58f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#31 0x0000000000415648 in main (argc=3, argv=0x7fff89930e88) at ../../krdc/main.cpp:104

Possible duplicates by query: bug 291426.

Reported using DrKonqi
Comment 1 Christoph Feck 2012-05-20 01:31:48 UTC

*** This bug has been marked as a duplicate of bug 291426 ***