Bug 307707 - KRDC crash when opening a connection
Summary: KRDC crash when opening a connection
Status: RESOLVED DUPLICATE of bug 291426
Alias: None
Product: krdc
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Urs Wolfer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-10-02 09:04 UTC by PNA
Modified: 2012-10-02 09:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description PNA 2012-10-02 09:04:18 UTC
Application: krdc (4.9.1)
KDE Platform Version: 4.9.1
Qt Version: 4.8.2
Operating System: Linux 3.5.4-2.fc17.x86_64 x86_64
Distribution: "Fedora release 17 (Beefy Miracle)"

-- Information about the crash:
1 Opened KRCD
2 Click on a saved bookmark
3 KDE Wallet asks for master password
4 KRDC crashed

The crash can be reproduced some of the time.

-- Backtrace:
Application: KRDC (krdc), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f5c9a87e880 (LWP 2437))]

Thread 2 (Thread 0x7f5c8c7e1700 (LWP 2438)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:166
#1  0x0000003cd787baeb in wait (time=18446744073709551615, this=0x7f5c8406c5b0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x7f5c84061d30, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x0000003cd7877aa7 in QSemaphore::acquire (this=0x7f5c8c7e0910, n=1) at thread/qsemaphore.cpp:144
#4  0x0000003cd798d06d in QMetaObject::activate (sender=0x26fb3f0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7f5c8c7e09a0) at kernel/qobject.cpp:3525
#5  0x00007f5c8e21e4e7 in VncClientThread::imageUpdated (this=this@entry=0x26fb3f0, _t1=_t1@entry=0, _t2=_t2@entry=0, _t3=_t3@entry=296, _t4=_t4@entry=24) at /usr/src/debug/kdenetwork-4.9.1/x86_64-redhat-linux-gnu/krdc/vnc/moc_vncclientthread.cpp:128
#6  0x00007f5c8e21ee30 in emitUpdated (h=24, w=296, y=0, x=0, this=0x26fb3f0) at /usr/src/debug/kdenetwork-4.9.1/krdc/vnc/vncclientthread.cpp:321
#7  VncClientThread::updatefb (cl=0x7f5c84002920, x=0, y=0, w=296, h=24) at /usr/src/debug/kdenetwork-4.9.1/krdc/vnc/vncclientthread.cpp:154
#8  0x00007f5c8dfd783b in HandleRFBServerMessage (client=0x7f5c84002920) at rfbproto.c:2153
#9  0x00007f5c8e21fb02 in VncClientThread::run (this=0x26fb3f0) at /usr/src/debug/kdenetwork-4.9.1/krdc/vnc/vncclientthread.cpp:390
#10 0x0000003cd787b5eb in QThreadPrivate::start (arg=0x26fb3f0) at thread/qthread_unix.cpp:307
#11 0x0000003cd0807d14 in start_thread (arg=0x7f5c8c7e1700) at pthread_create.c:309
#12 0x0000003ccfcf167d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f5c9a87e880 (LWP 2437)):
[KCrash Handler]
#6  0x0000000000423d81 in MainWindow::statusChanged (this=0x23ce9c0, status=RemoteView::Connecting) at /usr/src/debug/kdenetwork-4.9.1/krdc/mainwindow.cpp:440
#7  0x00000000004290d6 in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /usr/src/debug/kdenetwork-4.9.1/x86_64-redhat-linux-gnu/krdc/mainwindow.moc:122
#8  MainWindow::qt_static_metacall (_o=0x23ce9c0, _c=40970401, _id=1, _a=0xffffffffffffffff) at /usr/src/debug/kdenetwork-4.9.1/x86_64-redhat-linux-gnu/krdc/mainwindow.moc:103
#9  0x0000003cd798cb9f in QMetaObject::activate (sender=0x26fb390, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff4f7357d0) at kernel/qobject.cpp:3547
#10 0x0000003cdb007821 in RemoteView::statusChanged (this=this@entry=0x26fb390, _t1=_t1@entry=RemoteView::Connecting) at /usr/src/debug/kdenetwork-4.9.1/x86_64-redhat-linux-gnu/krdc/core/moc_remoteview.cpp:205
#11 0x0000003cdb007870 in RemoteView::setStatus (this=0x26fb390, s=RemoteView::Connected) at /usr/src/debug/kdenetwork-4.9.1/krdc/core/remoteview.cpp:83
#12 0x00007f5c8e2226b3 in VncView::updateImage (this=0x26fb390, x=0, y=0, w=<optimized out>, h=<optimized out>) at /usr/src/debug/kdenetwork-4.9.1/krdc/vnc/vncview.cpp:330
#13 0x0000003cd798acee in QObject::event (this=0x26fb390, e=<optimized out>) at kernel/qobject.cpp:1195
#14 0x0000003cd80193da in QWidget::event (this=0x26fb390, event=0x7f5c8406b5f0) at kernel/qwidget.cpp:8830
#15 0x0000003cd7fca37c in QApplicationPrivate::notify_helper (this=this@entry=0x2295fd0, receiver=receiver@entry=0x26fb390, e=e@entry=0x7f5c8406b5f0) at kernel/qapplication.cpp:4551
#16 0x0000003cd7fce7fa in QApplication::notify (this=0x7fff4f7365a0, receiver=0x26fb390, e=0x7f5c8406b5f0) at kernel/qapplication.cpp:4412
#17 0x0000003ce0846366 in KApplication::notify (this=0x7fff4f7365a0, receiver=0x26fb390, event=0x7f5c8406b5f0) at /usr/src/debug/kdelibs-4.9.1/kdeui/kernel/kapplication.cpp:311
#18 0x0000003cd79763ee in QCoreApplication::notifyInternal (this=0x7fff4f7365a0, receiver=receiver@entry=0x26fb390, event=event@entry=0x7f5c8406b5f0) at kernel/qcoreapplication.cpp:915
#19 0x0000003cd7979ea1 in sendEvent (event=0x7f5c8406b5f0, receiver=0x26fb390) at kernel/qcoreapplication.h:231
#20 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x226f8c0) at kernel/qcoreapplication.cpp:1539
#21 0x0000003cd79a4353 in sendPostedEvents () at kernel/qcoreapplication.h:236
#22 postEventSourceDispatch (s=0x2295da0) at kernel/qeventdispatcher_glib.cpp:279
#23 0x0000003cd1847825 in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
#24 0x0000003cd1847b58 in ?? () from /lib64/libglib-2.0.so.0
#25 0x0000003cd1847c14 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
#26 0x0000003cd79a44e6 in QEventDispatcherGlib::processEvents (this=0x22711a0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#27 0x0000003cd806a2ee in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#28 0x0000003cd797513f in QEventLoop::processEvents (this=this@entry=0x7fff4f736400, flags=...) at kernel/qeventloop.cpp:149
#29 0x0000003cd79753c8 in QEventLoop::exec (this=0x7fff4f736400, flags=...) at kernel/qeventloop.cpp:204
#30 0x0000003cd797a1b8 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#31 0x00000000004154c0 in main (argc=<optimized out>, argv=0x7fff4f7366f8) at /usr/src/debug/kdenetwork-4.9.1/krdc/main.cpp:104

Possible duplicates by query: bug 300314, bug 297300, bug 291426.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-10-02 09:24:33 UTC

*** This bug has been marked as a duplicate of bug 291426 ***