Bug 332610 - Dolphin information panel config - six duplicates and missing "Comment" entry
Summary: Dolphin information panel config - six duplicates and missing "Comment" entry
Status: RESOLVED DUPLICATE of bug 338314
Alias: None
Product: Baloo
Classification: Unclassified
Component: Widgets (show other bugs)
Version: unspecified
Platform: Kubuntu Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Vishesh Handa
URL: http://imgbox.com/7zdmaERs
Keywords:
: 340053 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-03-26 01:20 UTC by Shokushu
Modified: 2014-12-01 11:28 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Duplicates in Dolphin's info box (63.64 KB, image/png)
2014-04-14 19:57 UTC, Shokushu
Details
Duplicate entries in info and config. (36.75 KB, image/png)
2014-04-27 15:12 UTC, Paul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shokushu 2014-03-26 01:20:15 UTC
I've just installed 4.13 Beta 3 using the packages for Kubuntu Trusty Tahr x64 and rebooted.

The configuration dialog for the information panel in Dolphin has six duplicate entries as well as one missing entry. (see link above for screenshot, configuring the displayed items for a video file)

The following six entries are duplicate:
- framerate
- bitrate
- width
- duration
- height
- title

The entry for "Comment" is missing from the config dialog, so you cannot uncheck it if you don't want the "Comment" item displayed in the information panel.

Reproducible: Always

Steps to Reproduce:
1. Launch Dolphin
2. Right-click on the information panel and select "Configure"
Actual Results:  
Six items in the config dialog are duplicate (see above for details), while the the entry for "Comment" is missing.

Expected Results:  
No duplicates, and all possible entries are listed, including "Comment".
Comment 1 Frank Reininghaus 2014-03-26 07:07:26 UTC
Thanks for the bug report. The widget that shows the entries in the Information Panel is part of the Baloo library, so I'll reassign.
Comment 2 Shokushu 2014-04-14 19:57:51 UTC
Created attachment 86092 [details]
Duplicates in Dolphin's info box

Just recently upgraded to 4.13 final, and the bug got worse rather than better. Now the info box in Dolphin itself often shows duplicates, not just the config dialog (see attachment).
Comment 3 Paul 2014-04-27 15:12:46 UTC
Created attachment 86295 [details]
Duplicate entries in info and config.

Confirmed also on openSUSE 13.1
Dolphin: Version 4.13.0
KDE Development Platform: 4.13.0
Comment 4 Emmanuel Pescosta 2014-10-17 12:33:37 UTC
*** Bug 340053 has been marked as a duplicate of this bug. ***
Comment 5 Vishesh Handa 2014-12-01 11:28:56 UTC
The code is shared between the config menu and the information panel.

*** This bug has been marked as a duplicate of bug 338314 ***