Bug 321744 - Crash while collapsing directories in tree view
Summary: Crash while collapsing directories in tree view
Status: RESOLVED DUPLICATE of bug 317104
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 2.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-29 04:21 UTC by Martin Girard
Modified: 2022-09-03 20:46 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (10.56 KB, patch)
2020-09-21 14:32 UTC, gregorib
Details
New crash information added by DrKonqi (5.12 KB, text/plain)
2022-09-03 20:46 UTC, BEEDELL ROKE JULIAN LOCKHART
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Girard 2013-06-29 04:21:26 UTC
Application: dolphin (2.2)
KDE Platform Version: 4.10.3 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.11-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
Just what the title implies, save for the fact I was trying to get rid of spurious entries (see below).

- Unusual behavior I noticed:
It's very common for Dolphin to automatically show recently generated or updated files (I'm using KDevelop+make) from some collapsed folder, under an irrelevant folder (most often the first one on top). Usually these can be made to go away by expanding and collapsing the latter folder, but this time there were so many that the program just freaked out, producing more every time until it crashed.

-- Backtrace:
Application: Dolphin (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fcc12e0e780 (LWP 1311))]

Thread 2 (Thread 0x7fcbf9101700 (LWP 1332)):
#0  0x00007fff013ff60c in ?? ()
#1  0x00007fff013ff8ac in clock_gettime ()
#2  0x00007fcc1045e53d in clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:115
#3  0x00007fcc119c3d94 in do_gettime (frac=0x7fcbf9100b28, sec=0x7fcbf9100b20) at tools/qelapsedtimer_unix.cpp:123
#4  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#5  0x00007fcc11a98bed in QTimerInfoList::updateCurrentTime (this=this@entry=0x7fcbf4002860) at kernel/qeventdispatcher_unix.cpp:354
#6  0x00007fcc11a98f33 in QTimerInfoList::timerWait (this=0x7fcbf4002860, tm=...) at kernel/qeventdispatcher_unix.cpp:461
#7  0x00007fcc11a9799c in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7fcbf9100c14) at kernel/qeventdispatcher_glib.cpp:136
#8  0x00007fcc11a97a45 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#9  0x00007fcc0d38f338 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#10 0x00007fcc0d38f9cb in ?? () from /usr/lib64/libglib-2.0.so.0
#11 0x00007fcc0d38fbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#12 0x00007fcc11a982e6 in QEventDispatcherGlib::processEvents (this=0x7fcbf40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#13 0x00007fcc11a68adf in QEventLoop::processEvents (this=this@entry=0x7fcbf9100dd0, flags=...) at kernel/qeventloop.cpp:149
#14 0x00007fcc11a68d68 in QEventLoop::exec (this=0x7fcbf9100dd0, flags=...) at kernel/qeventloop.cpp:204
#15 0x00007fcc1196b0f0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#16 0x00007fcc11a4929f in QInotifyFileSystemWatcherEngine::run (this=0x246fd30) at io/qfilesystemwatcher_inotify.cpp:256
#17 0x00007fcc1196e0cc in QThreadPrivate::start (arg=0x246fd30) at thread/qthread_unix.cpp:338
#18 0x00007fcc116d7e0f in start_thread (arg=0x7fcbf9101700) at pthread_create.c:308
#19 0x00007fcc1044c7dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fcc12e0e780 (LWP 1311)):
[KCrash Handler]
#6  QUrlPrivate::parse (this=this@entry=0x26b7100, parseOptions=parseOptions@entry=QUrlPrivate::ParseAndSet) at io/qurl.cpp:3841
#7  0x00007fcc11a1d59a in QUrl::path (this=0x7fff0132d340) at io/qurl.cpp:4938
#8  0x00007fcc11eeba7b in KUrl::path(KUrl::AdjustPathOption) const () from /usr/lib64/libkdecore.so.5
#9  0x00007fcbff0aff9a in KFileItemModel::expandedParentsCountCompare(KFileItemModel::ItemData const*, KFileItemModel::ItemData const*) const () from /usr/lib64/libdolphinprivate.so.4
#10 0x00007fcbff0b0392 in KFileItemModel::lessThan(KFileItemModel::ItemData const*, KFileItemModel::ItemData const*) const () from /usr/lib64/libdolphinprivate.so.4
#11 0x00007fcbff0b05af in KFileItemModel::insertItems(KFileItemList const&) () from /usr/lib64/libdolphinprivate.so.4
#12 0x00007fcbff0b085f in KFileItemModel::dispatchPendingItemsToInsert() () from /usr/lib64/libdolphinprivate.so.4
#13 0x00007fcbff0b08c4 in KFileItemModel::slotCompleted() () from /usr/lib64/libdolphinprivate.so.4
#14 0x00007fcc11a7f29f in QMetaObject::activate (sender=0x25e5180, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff0132d620) at kernel/qobject.cpp:3548
#15 0x00007fcc0a70d6d5 in KDirLister::completed (this=this@entry=0x25e5180, _t1=...) at /usr/src/debug/kdelibs-4.10.3/build/kio/kdirlister.moc:234
#16 0x00007fcc0a716607 in KDirListerCache::emitItemsFromCache (this=0x2484b80, cachedItemsJob=cachedItemsJob@entry=0x2f31f80, lister=lister@entry=0x25e5180, _url=..., _reload=false, _emitCompleted=true) at /usr/src/debug/kdelibs-4.10.3/kio/kio/kdirlister.cpp:356
#17 0x00007fcc0a716810 in KDirLister::Private::CachedItemsJob::done (this=0x2f31f80) at /usr/src/debug/kdelibs-4.10.3/kio/kio/kdirlister.cpp:307
#18 0x00007fcc11a7e77e in QObject::event (this=0x2f31f80, e=<optimized out>) at kernel/qobject.cpp:1203
#19 0x00007fcc10bf786c in QApplicationPrivate::notify_helper (this=this@entry=0x224dcd0, receiver=receiver@entry=0x2f31f80, e=e@entry=0x323e730) at kernel/qapplication.cpp:4562
#20 0x00007fcc10bfbceb in QApplication::notify (this=0x7fff0132e150, receiver=0x2f31f80, e=0x323e730) at kernel/qapplication.cpp:4423
#21 0x00007fcc1280d146 in KApplication::notify (this=0x7fff0132e150, receiver=0x2f31f80, event=0x323e730) at /usr/src/debug/kdelibs-4.10.3/kdeui/kernel/kapplication.cpp:311
#22 0x00007fcc11a69d8e in QCoreApplication::notifyInternal (this=0x7fff0132e150, receiver=receiver@entry=0x2f31f80, event=event@entry=0x323e730) at kernel/qcoreapplication.cpp:946
#23 0x00007fcc11a6d6f1 in sendEvent (event=0x323e730, receiver=0x2f31f80) at kernel/qcoreapplication.h:231
#24 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x21852b0) at kernel/qcoreapplication.cpp:1570
#25 0x00007fcc11a98133 in sendPostedEvents () at kernel/qcoreapplication.h:236
#26 postEventSourceDispatch (s=0x224f300) at kernel/qeventdispatcher_glib.cpp:279
#27 0x00007fcc0d38f7d5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#28 0x00007fcc0d38fb08 in ?? () from /usr/lib64/libglib-2.0.so.0
#29 0x00007fcc0d38fbc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#30 0x00007fcc11a982c6 in QEventDispatcherGlib::processEvents (this=0x218b790, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#31 0x00007fcc10c97c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007fcc11a68adf in QEventLoop::processEvents (this=this@entry=0x7fff0132e010, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007fcc11a68d68 in QEventLoop::exec (this=0x7fff0132e010, flags=...) at kernel/qeventloop.cpp:204
#34 0x00007fcc11a6da08 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#35 0x00007fcbff86a097 in kdemain () from /usr/lib64/libkdeinit4_dolphin.so
#36 0x000000000040889a in _start ()

Possible duplicates by query: bug 317104.

Reported using DrKonqi
Comment 1 Frank Reininghaus 2013-06-29 06:15:41 UTC
Thanks for the bug report. The code for handling expanded folders had been greatly simplified and improved for KDE 4.11. Such a crash cannot happen any more in KDE 4.11 when it's out.

*** This bug has been marked as a duplicate of bug 317104 ***
Comment 2 gregorib 2020-09-21 14:32:39 UTC
Created attachment 131833 [details]
New crash information added by DrKonqi

dolphin (19.12.3) using Qt 5.12.8

- What I was doing when the application crashed:
Some folders where shown as childs of next folder on window. When closing folder to refresh display, dolphin chrashed.

- Custom settings of the application:

-- Backtrace (Reduced):
#6  0x00007f706f56c2e3 in KFileItemModel::expandedParentsCount(KFileItemModel::ItemData const*) () from /lib/x86_64-linux-gnu/libdolphinprivate.so.5
#7  0x00007f706f595b69 in KItemListView::hasSiblingSuccessor(int) const () from /lib/x86_64-linux-gnu/libdolphinprivate.so.5
#8  0x00007f706f5978ba in KItemListView::updateSiblingsInformation(int, int) () from /lib/x86_64-linux-gnu/libdolphinprivate.so.5
#9  0x00007f706f59e187 in KItemListView::slotItemsRemoved(KItemRangeList const&) () from /lib/x86_64-linux-gnu/libdolphinprivate.so.5
[...]
#11 0x00007f706f55c099 in KItemModelBase::itemsRemoved(KItemRangeList const&) () from /lib/x86_64-linux-gnu/libdolphinprivate.so.5
Comment 3 BEEDELL ROKE JULIAN LOCKHART 2022-09-03 20:46:36 UTC
Created attachment 151806 [details]
New crash information added by DrKonqi

dolphin (22.04.1) using Qt 5.15.5

I expanded a directory after renaming it. The consequently visible subdirectory appeared beneath the wrong directory.

-- Backtrace (Reduced):
#4  0x00007fdf0fe4a522 in KFileItemModel::expandedParentsCount(KFileItemModel::ItemData const*) () from /lib64/libdolphinprivate.so.5
#5  0x00007fdf0fe78b19 in KItemListView::hasSiblingSuccessor(int) const () from /lib64/libdolphinprivate.so.5
#6  0x00007fdf0fe79a0c in KItemListView::updateSiblingsInformation(int, int) () from /lib64/libdolphinprivate.so.5
#7  0x00007fdf0fe7e2fd in KItemListView::slotItemsRemoved(KItemRangeList const&) () from /lib64/libdolphinprivate.so.5
#8  0x00007fdf0df618b6 in void doActivate<false>(QObject*, int, void**) () from /lib64/libQt5Core.so.5