Bug 330221 - Crash on Ctrl+O while loading file.
Summary: Crash on Ctrl+O while loading file.
Status: RESOLVED WORKSFORME
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: 3.12.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords: drkonqi, triaged
Depends on:
Blocks:
 
Reported: 2014-01-20 23:11 UTC by Thiago Jung Bauermann
Modified: 2018-10-27 04:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thiago Jung Bauermann 2014-01-20 23:11:25 UTC
Application: kate (3.12.0)
KDE Platform Version: 4.12.0
Qt Version: 4.8.2
Operating System: Linux 3.2.0-58-generic-pae i686
Distribution: Ubuntu 12.04.4 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I started a Kate session containing remote files being accessed via the fish kio. As soon as Kate loaded, I pressed Ctrl+O while the current bufferwas displaying the message "The file foo is being loaded.". Kate crashed immediately. This happens everytime.

If I wait until the file is loaded. Kate doesn't crash.

The crash can be reproduced every time.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb77a6740 (LWP 17309))]

Thread 3 (Thread 0xb58adb40 (LWP 17310)):
#0  0xb77dc424 in __kernel_vsyscall ()
#1  0x4ce2096b in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:169
#2  0x4cd324bc in __pthread_cond_wait (cond=0x45c2c590, mutex=0x45c2c578) at forward.c:139
#3  0x45b27d29 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0x45b27d6f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0x4ce1cd4c in start_thread (arg=0xb58adb40) at pthread_create.c:308
#6  0x4cd24bae in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xb340db40 (LWP 17312)):
#0  0x4ce4edcd in __GI_clock_gettime (clock_id=1, tp=0xb340cfb8) at ../sysdeps/unix/clock_gettime.c:116
#1  0x430a5925 in do_gettime (frac=0xb340cfb0, sec=0xb340cfa8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x4318fc66 in QTimerInfoList::updateCurrentTime (this=0xb2b02074) at kernel/qeventdispatcher_unix.cpp:343
#4  0x4318ffba in QTimerInfoList::timerWait (this=0xb2b02074, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0x4318e863 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb340d0bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0x4318e8fd in timerSourcePrepare (source=0xb2b02040, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0x4d056832 in g_main_context_prepare (context=0xb2b004e0, priority=0xb340d118) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:2836
#8  0x4d056f6f in g_main_context_iterate (dispatch=1, block=1, context=0xb2b004e0, self=<optimized out>) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3126
#9  g_main_context_iterate (context=0xb2b004e0, block=1, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3083
#10 0x4d0571c1 in g_main_context_iteration (context=0xb2b004e0, may_block=1) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3207
#11 0x4318f327 in QEventDispatcherGlib::processEvents (this=0xb2b00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x4315abed in QEventLoop::processEvents (this=0xb340d240, flags=...) at kernel/qeventloop.cpp:149
#13 0x4315ae89 in QEventLoop::exec (this=0xb340d240, flags=...) at kernel/qeventloop.cpp:204
#14 0x43043f5c in QThread::exec (this=0x9a61800) at thread/qthread.cpp:501
#15 0x4313823d in QInotifyFileSystemWatcherEngine::run (this=0x9a61800) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x430473f0 in QThreadPrivate::start (arg=0x9a61800) at thread/qthread_unix.cpp:307
#17 0x4ce1cd4c in start_thread (arg=0xb340db40) at pthread_create.c:308
#18 0x4cd24bae in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb77a6740 (LWP 17309)):
[KCrash Handler]
#7  KateLineLayout::viewLineCount (this=0x0) at ../../part/render/katelinelayout.cpp:174
#8  0xb5c32a81 in viewLine (realCursor=..., this=0x9a7db30) at ../../part/render/katelayoutcache.cpp:395
#9  KateLayoutCache::viewLine (this=0x9a7db30, realCursor=...) at ../../part/render/katelayoutcache.cpp:389
#10 0xb5c32c36 in KateLayoutCache::textLayout (this=0x9a7db30, realCursor=...) at ../../part/render/katelayoutcache.cpp:344
#11 0xb5c8a463 in KateViewInternal::makeVisible (this=0x9a7d5f8, c=..., endCol=1, force=false, center=false, calledExternally=false) at ../../part/view/kateviewinternal.cpp:640
#12 0xb5c8be24 in KateViewInternal::updateCursor (this=0x9a7d5f8, newCursor=..., force=false, center=false, calledExternally=false) at ../../part/view/kateviewinternal.cpp:1867
#13 0xb5cb362e in KateViModeBase::updateCursor (this=0x9c45020, c=...) at ../../part/vimode/katevimodebase.cpp:939
#14 0xb5cbd866 in KateViNormalMode::commandGoToPrevJump (this=0x9c45020) at ../../part/vimode/katevinormalmode.cpp:1732
#15 0xb5cd616f in KateViCommand::execute (this=0x9c51840) at ../../part/vimode/katevicommand.cpp:38
#16 0xb5cd094e in KateViNormalMode::executeCommand (this=0x9c45020, cmd=0x9c51840) at ../../part/vimode/katevinormalmode.cpp:517
#17 0xb5cd1d0c in KateViNormalMode::handleKeypress (this=0x9c45020, e=0xbfe10950) at ../../part/vimode/katevinormalmode.cpp:433
#18 0xb5cab22b in KateViInputModeManager::handleKeypress (this=0x9c44f50, e=0xbfe10950) at ../../part/vimode/kateviinputmodemanager.cpp:157
#19 0xb5c92246 in keyPressEvent (e=0xbfe10950, this=0x9a7d5f8) at ../../part/view/kateviewinternal.cpp:2297
#20 KateViewInternal::keyPressEvent (this=0x9a7d5f8, e=0xbfe10950) at ../../part/view/kateviewinternal.cpp:2233
#21 0x4678b820 in QWidget::event (this=0x9a7d5f8, event=0xbfe10950) at kernel/qwidget.cpp:8406
#22 0x46731574 in notify_helper (e=0xbfe10950, receiver=0x9a7d5f8, this=0x9454cc8) at kernel/qapplication.cpp:4556
#23 QApplicationPrivate::notify_helper (this=0x9454cc8, receiver=0x9a7d5f8, e=0xbfe10950) at kernel/qapplication.cpp:4528
#24 0x46737438 in QApplication::notify (this=0xbfe10824, receiver=0x9a7d5f8, e=0xbfe10950) at kernel/qapplication.cpp:3997
#25 0x42c8a321 in KApplication::notify (this=0xbfe11b30, receiver=0x9a7d5f8, event=0xbfe10950) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x4315c34e in QCoreApplication::notifyInternal (this=0xbfe11b30, receiver=0x9a7d5f8, event=0xbfe10950) at kernel/qcoreapplication.cpp:915
#27 0xb5ca8f7a in sendEvent (event=0xbfe10950, receiver=<optimized out>) at /usr/include/qt4/QtCore/qcoreapplication.h:231
#28 KateViInputModeManager::feedKeyPresses (this=0x9c44f50, keyPresses=...) at ../../part/vimode/kateviinputmodemanager.cpp:257
#29 0xb5cfcdae in KateViKeyMapper::playBackRejectedKeys (this=0x9c58450) at ../../part/vimode/katevikeymapper.cpp:64
#30 0xb5cfd20f in KateViKeyMapper::handleKeypress (this=0x9c58450, key=...) at ../../part/vimode/katevikeymapper.cpp:123
#31 0xb5cab14e in KateViInputModeManager::handleKeypress (this=0x9c44f50, e=0xbfe11144) at ../../part/vimode/kateviinputmodemanager.cpp:135
#32 0xb5c92246 in keyPressEvent (e=0xbfe11144, this=0x9a7d5f8) at ../../part/view/kateviewinternal.cpp:2297
#33 KateViewInternal::keyPressEvent (this=0x9a7d5f8, e=0xbfe11144) at ../../part/view/kateviewinternal.cpp:2233
#34 0x4678b820 in QWidget::event (this=0x9a7d5f8, event=0xbfe11144) at kernel/qwidget.cpp:8406
#35 0x46731574 in notify_helper (e=0xbfe11144, receiver=0x9a7d5f8, this=0x9454cc8) at kernel/qapplication.cpp:4556
#36 QApplicationPrivate::notify_helper (this=0x9454cc8, receiver=0x9a7d5f8, e=0xbfe11144) at kernel/qapplication.cpp:4528
#37 0x46737438 in QApplication::notify (this=0xbfe10ff4, receiver=0x9a7d5f8, e=0xbfe11144) at kernel/qapplication.cpp:3997
#38 0x42c8a321 in KApplication::notify (this=0xbfe11b30, receiver=0x9a7d5f8, event=0xbfe11144) at ../../kdeui/kernel/kapplication.cpp:311
#39 0x4315c34e in QCoreApplication::notifyInternal (this=0xbfe11b30, receiver=0x9a7d5f8, event=0xbfe11144) at kernel/qcoreapplication.cpp:915
#40 0x4672f3bd in sendSpontaneousEvent (event=0xbfe11144, receiver=0x9a7d5f8) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#41 qt_sendSpontaneousEvent (receiver=0x9a7d5f8, event=0xbfe11144) at kernel/qapplication.cpp:5554
#42 0x467e5af1 in QKeyMapper::sendKeyEvent (keyWidget=0x9a7d5f8, grab=false, type=QEvent::KeyPress, code=79, modifiers=..., text=..., autorepeat=false, count=-1075769020, nativeScanCode=3051270348, nativeVirtualKey=3051270348, nativeModifiers=3051270348) at kernel/qkeymapper_x11.cpp:1866
#43 0x467e5f9b in QKeyMapperPrivate::translateKeyEvent (this=0x947dcc8, keyWidget=0x9a7d5f8, event=0xbfe1176c, grab=false) at kernel/qkeymapper_x11.cpp:1836
#44 0x467bce55 in QApplication::x11ProcessEvent (this=0xbfe11b30, event=0xbfe1176c) at kernel/qapplication_x11.cpp:3625
#45 0x467ea59c in x11EventSourceDispatch (s=0x9458240, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#46 0x4d056d46 in g_main_dispatch (context=0x9456290) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:2539
#47 g_main_context_dispatch (context=0x9456290) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3075
#48 0x4d0570e5 in g_main_context_iterate (dispatch=1, block=1292257808, context=0x9456290, self=<optimized out>) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3146
#49 g_main_context_iterate (context=0x9456290, block=1292257808, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3083
#50 0x4d0571c1 in g_main_context_iteration (context=0x9456290, may_block=1) at /build/buildd/glib2.0-2.32.4/./glib/gmain.c:3207
#51 0x4318f2c7 in QEventDispatcherGlib::processEvents (this=0x9420ef8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#52 0x467ea19a in QGuiEventDispatcherGlib::processEvents (this=0x9420ef8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0x4315abed in QEventLoop::processEvents (this=0xbfe11a64, flags=...) at kernel/qeventloop.cpp:149
#54 0x4315ae89 in QEventLoop::exec (this=0xbfe11a64, flags=...) at kernel/qeventloop.cpp:204
#55 0x4316088a in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#56 0x4672f144 in QApplication::exec () at kernel/qapplication.cpp:3817
#57 0xb77c7b85 in kdemain (argc=4, argv=0x9430c50) at ../../../kate/app/katemain.cpp:380
#58 0x0804f85c in launch (argc=<optimized out>, _name=0x9417db4 "kate", args=<optimized out>, cwd=0x0, envc=1, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x8052481 "0") at ../../kinit/kinit.cpp:738
#59 0x08050c3c in handle_launcher_request (sock=<optimized out>, who=<optimized out>) at ../../kinit/kinit.cpp:1230
#60 0x08051121 in handle_requests (waitForPid=<optimized out>) at ../../kinit/kinit.cpp:1423
#61 0x0804c238 in main (argc=0, argv=0x9d67520, envp=0x37221717) at ../../kinit/kinit.cpp:1911

Possible duplicates by query: bug 329965, bug 315683, bug 314245, bug 313628.

Reported using DrKonqi
Comment 1 Christoph Cullmann 2015-10-04 12:18:19 UTC
Its a ugly crash, unfortunately, I am never able to reproduce it. If there is some way to do so, please reopen. Perhaps retry with the KF5 based version, for sure has more fixes.
Comment 2 Andrew Crouthamel 2018-09-25 21:44:53 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Andrew Crouthamel 2018-10-27 04:09:36 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!