Bug 314245 - Kate Crash on Folding/unlolding code blocks
Summary: Kate Crash on Folding/unlolding code blocks
Status: RESOLVED DUPLICATE of bug 311866
Alias: None
Product: kate
Classification: Unclassified
Component: folding (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-01 11:31 UTC by Ovidiu-Florin BOGDAN
Modified: 2013-02-20 10:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ovidiu-Florin BOGDAN 2013-02-01 11:31:01 UTC
Application: kate (3.9.5)
KDE Platform Version: 4.9.5
Qt Version: 4.8.2
Operating System: Linux 3.2.0-36-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:

I had a C++ source file opened.
Folded all the code blocks starting with the level 4 to top Level using View -> Code Folding -> Fold Nodes in Level ...
After I've folded all of them, I tried to unfold the second level using: View -> Code Folding -> Unfold Nodes in Level 2.
The first time I did this Kate crashed. The second time I tried the exact same thing all the code in the text view area dissapeared.

The crash can be reproduced every time.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fa849c8a780 (LWP 9220))]

Thread 3 (Thread 0x7fa83519c700 (LWP 9221)):
#0  0x00007fa8467195c0 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fa8466ddc49 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fa8466de0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fa8466de164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fa8474a0906 in QEventDispatcherGlib::processEvents (this=0x7fa8300008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fa84746fe42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fa847470097 in QEventLoop::exec (this=0x7fa83519bdc0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fa84736f057 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007fa8474516f8 in QDnotifySignalThread::run (this=0xdb67b0) at io/qfilesystemwatcher_dnotify.cpp:179
#9  0x00007fa84737207b in QThreadPrivate::start (arg=0xdb67b0) at thread/qthread_unix.cpp:307
#10 0x00007fa846baae9a in start_thread (arg=0x7fa83519c700) at pthread_create.c:308
#11 0x00007fa8495cccbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa834949700 (LWP 9222)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fa8375a1222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fa8375a1259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fa846baae9a in start_thread (arg=0x7fa834949700) at pthread_create.c:308
#4  0x00007fa8495cccbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa849c8a780 (LWP 9220)):
[KCrash Handler]
#6  KateLineLayout::viewLineCount (this=0x0) at ../../part/render/katelinelayout.cpp:173
#7  0x00007fa837c2848e in KateLayoutCache::lastViewLine (this=<optimized out>, realLine=<optimized out>) at ../../part/render/katelayoutcache.cpp:461
#8  0x00007fa837c284d9 in KateLayoutCache::viewLineCount (this=<optimized out>, realLine=<optimized out>) at ../../part/render/katelayoutcache.cpp:466
#9  0x00007fa837c28ce8 in KateLayoutCache::displayViewLine (this=0x1efcbd0, virtualCursor=..., limitToVisible=false) at ../../part/render/katelayoutcache.cpp:437
#10 0x00007fa837c7bd6f in KateViewInternal::scrollPos (this=0x1daf3b0, c=..., force=<optimized out>, calledExternally=false) at ../../part/view/kateviewinternal.cpp:461
#11 0x00007fa837c7c1aa in KateViewInternal::slotRegionVisibilityChanged (this=0x1daf3b0) at ../../part/view/kateviewinternal.cpp:674
#12 0x00007fa847485761 in QMetaObject::activate (sender=0x1d17c90, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#13 0x00007fa837c5e029 in KateCodeFoldingTree::expandLevel (this=0x1d17c90, level=2, node=<optimized out>, nodeLevel=<optimized out>) at ../../part/syntax/katecodefolding.cpp:681
#14 0x00007fa837c5dfa8 in KateCodeFoldingTree::expandLevel (this=0x1d17c90, level=2, node=<optimized out>, nodeLevel=<optimized out>) at ../../part/syntax/katecodefolding.cpp:688
#15 0x00007fa837c5dfa8 in KateCodeFoldingTree::expandLevel (this=0x1d17c90, level=2, node=<optimized out>, nodeLevel=<optimized out>) at ../../part/syntax/katecodefolding.cpp:688
#16 0x00007fa837c64388 in expandLevel (level=2, this=<optimized out>) at ../../part/syntax/katecodefolding.h:405
#17 KateView::slotExpandLevel (this=0x1e5c9b0) at ../../part/view/kateview.cpp:1032
#18 0x00007fa847485761 in QMetaObject::activate (sender=0x1d1c5b0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff6e703960) at kernel/qobject.cpp:3547
#19 0x00007fa8489cf072 in QAction::triggered (this=<optimized out>, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#20 0x00007fa8489cf25f in QAction::activate (this=0x1d1c5b0, event=<optimized out>) at kernel/qaction.cpp:1257
#21 0x00007fa848e215e9 in QMenuPrivate::activateCausedStack (this=0x1e67920, causedStack=..., action=0x1d1c5b0, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1028
#22 0x00007fa848e27742 in QMenuPrivate::activateAction (this=0x1e67920, action=0x1d1c5b0, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1120
#23 0x00007fa847d3e5b0 in KMenu::mouseReleaseEvent (this=0x1da8470, e=0x7fff6e704530) at ../../kdeui/widgets/kmenu.cpp:464
#24 0x00007fa848a25fb4 in QWidget::event (this=0x1da8470, event=0x7fff6e704530) at kernel/qwidget.cpp:8371
#25 0x00007fa848e28cdb in QMenu::event (this=0x1da8470, e=0x7fff6e704530) at widgets/qmenu.cpp:2469
#26 0x00007fa8489d57b4 in notify_helper (e=0x7fff6e704530, receiver=0x1da8470, this=0x8aa720) at kernel/qapplication.cpp:4556
#27 QApplicationPrivate::notify_helper (this=0x8aa720, receiver=0x1da8470, e=0x7fff6e704530) at kernel/qapplication.cpp:4528
#28 0x00007fa8489daf2f in QApplication::notify (this=<optimized out>, receiver=0x1da8470, e=0x7fff6e704530) at kernel/qapplication.cpp:4099
#29 0x00007fa847c7d7a6 in KApplication::notify (this=0x7fff6e705260, receiver=0x1da8470, event=0x7fff6e704530) at ../../kdeui/kernel/kapplication.cpp:311
#30 0x00007fa84747130c in QCoreApplication::notifyInternal (this=0x7fff6e705260, receiver=0x1da8470, event=0x7fff6e704530) at kernel/qcoreapplication.cpp:915
#31 0x00007fa8489d6782 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#32 QApplicationPrivate::sendMouseEvent (receiver=0x1da8470, event=0x7fff6e704530, alienWidget=0x0, nativeWidget=0x1da8470, buttonDown=0x0, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3167
#33 0x00007fa848a561e1 in QETWidget::translateMouseEvent (this=0x1da8470, event=<optimized out>) at kernel/qapplication_x11.cpp:4551
#34 0x00007fa848a54ace in QApplication::x11ProcessEvent (this=0x7fff6e705260, event=0x7fff6e704e00) at kernel/qapplication_x11.cpp:3732
#35 0x00007fa848a7e052 in x11EventSourceDispatch (s=0x8ad370, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#36 0x00007fa8466ddd53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#37 0x00007fa8466de0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#38 0x00007fa8466de164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#39 0x00007fa8474a089f in QEventDispatcherGlib::processEvents (this=0x874b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#40 0x00007fa848a7dcde in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#41 0x00007fa84746fe42 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#42 0x00007fa847470097 in QEventLoop::exec (this=0x7fff6e7051a0, flags=...) at kernel/qeventloop.cpp:204
#43 0x00007fa8474753e7 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#44 0x00007fa84989e0d5 in kdemain (argc=<optimized out>, argv=<optimized out>) at ../../../kate/app/katemain.cpp:377
#45 0x00007fa8494fa76d in __libc_start_main (main=0x400630 <main(int, char**)>, argc=2, ubp_av=0x7fff6e706798, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff6e706788) at libc-start.c:226
#46 0x0000000000400661 in _start ()

Possible duplicates by query: bug 313628.

Reported using DrKonqi
Comment 1 Dominik Haumann 2013-02-20 10:57:49 UTC

*** This bug has been marked as a duplicate of bug 311866 ***