Bug 313628 - Pasting
Summary: Pasting
Status: RESOLVED DUPLICATE of bug 311866
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-21 15:39 UTC by Chris Alves
Modified: 2013-02-20 10:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Alves 2013-01-21 15:39:58 UTC
Application: kate (3.9.4)
KDE Platform Version: 4.9.4 (Compiled from sources)
Qt Version: 4.8.3
Operating System: Linux 3.5.0-21-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:
Several files open,  scrolling through an html file and pasting a form tag from the clipboard.

-- Backtrace:
Application: Kate (kate), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f2e2f730780 (LWP 11186))]

Thread 5 (Thread 0x7f2e1a626700 (LWP 11189)):
#0  0x00007f2e2f02a303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2e2c1a8d84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2e2c1a91e2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2e211924a6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f2e2c1cc645 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f2e2c677e9a in start_thread (arg=0x7f2e1a626700) at pthread_create.c:308
#6  0x00007f2e2f035cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f2e0a5be700 (LWP 11191)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f2e0b24bcd7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f2e0b24bd09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f2e2c677e9a in start_thread (arg=0x7f2e0a5be700) at pthread_create.c:308
#4  0x00007f2e2f035cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f2e08bfd700 (LWP 11192)):
#0  0x00007fff8e758827 in clock_gettime ()
#1  0x00007f2e280d215d in __GI_clock_gettime (clock_id=<optimized out>, tp=<optimized out>) at ../sysdeps/unix/clock_gettime.c:116
#2  0x00007f2e2ce9b9c4 in do_gettime (frac=0x7f2e08bfcb28, sec=0x7f2e08bfcb20) at tools/qelapsedtimer_unix.cpp:123
#3  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#4  0x00007f2e2cf7141d in QTimerInfoList::updateCurrentTime (this=this@entry=0x7f2e04002860) at kernel/qeventdispatcher_unix.cpp:343
#5  0x00007f2e2cf71763 in QTimerInfoList::timerWait (this=0x7f2e04002860, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#6  0x00007f2e2cf702cc in timerSourcePrepareHelper (src=<optimized out>, timeout=0x7f2e08bfcc14) at kernel/qeventdispatcher_glib.cpp:136
#7  0x00007f2e2cf70375 in timerSourcePrepare (source=<optimized out>, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#8  0x00007f2e2c1a8618 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#9  0x00007f2e2c1a8cab in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#10 0x00007f2e2c1a8ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#11 0x00007f2e2cf70c16 in QEventDispatcherGlib::processEvents (this=0x7f2e040008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#12 0x00007f2e2cf412bf in QEventLoop::processEvents (this=this@entry=0x7f2e08bfcdd0, flags=...) at kernel/qeventloop.cpp:149
#13 0x00007f2e2cf41548 in QEventLoop::exec (this=0x7f2e08bfcdd0, flags=...) at kernel/qeventloop.cpp:204
#14 0x00007f2e2ce42b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#15 0x00007f2e2cf219af in QInotifyFileSystemWatcherEngine::run (this=0x220dfe0) at io/qfilesystemwatcher_inotify.cpp:248
#16 0x00007f2e2ce45aec in QThreadPrivate::start (arg=0x220dfe0) at thread/qthread_unix.cpp:338
#17 0x00007f2e2c677e9a in start_thread (arg=0x7f2e08bfd700) at pthread_create.c:308
#18 0x00007f2e2f035cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#19 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f2e03d5a700 (LWP 11193)):
#0  0x00007f2e2f02a303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f2e2c1a8d84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2e2c1a8ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2e2cf70c16 in QEventDispatcherGlib::processEvents (this=0x7f2dfc0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f2e2cf412bf in QEventLoop::processEvents (this=this@entry=0x7f2e03d59dd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f2e2cf41548 in QEventLoop::exec (this=0x7f2e03d59dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f2e2ce42b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f2e2cf219af in QInotifyFileSystemWatcherEngine::run (this=0x253ee60) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f2e2ce45aec in QThreadPrivate::start (arg=0x253ee60) at thread/qthread_unix.cpp:338
#9  0x00007f2e2c677e9a in start_thread (arg=0x7f2e03d5a700) at pthread_create.c:308
#10 0x00007f2e2f035cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f2e2f730780 (LWP 11186)):
[KCrash Handler]
#6  KateLineLayout::viewLineCount (this=0x0) at ../../part/render/katelinelayout.cpp:173
#7  0x00007f2e0b8c6cfb in KateLayoutCache::lastViewLine (this=0x0, this@entry=0x532bc90, realLine=87211152) at ../../part/render/katelayoutcache.cpp:461
#8  0x00007f2e0b8c6d49 in KateLayoutCache::viewLineCount (this=this@entry=0x532bc90, realLine=<optimized out>) at ../../part/render/katelayoutcache.cpp:466
#9  0x00007f2e0b8c73e4 in KateLayoutCache::displayViewLine (this=0x532bc90, virtualCursor=..., limitToVisible=<optimized out>) at ../../part/render/katelayoutcache.cpp:429
#10 0x00007f2e0b91926f in KateViewInternal::pageUp (this=0x54a3bf0, sel=<optimized out>, half=<optimized out>) at ../../part/view/kateviewinternal.cpp:1530
#11 0x00007f2e2cf57f5f in QMetaObject::activate (sender=0x553dfb0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff8e6790a0) at kernel/qobject.cpp:3547
#12 0x00007f2e2e45ba32 in QAction::triggered (this=this@entry=0x553dfb0, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#13 0x00007f2e2e45bc20 in QAction::activate (this=0x553dfb0, event=event@entry=QAction::Trigger) at kernel/qaction.cpp:1257
#14 0x00007f2e2e45bd87 in QAction::event (this=<optimized out>, e=<optimized out>) at kernel/qaction.cpp:1183
#15 0x00007f2e2d664867 in KAction::event (this=<optimized out>, event=0x7fff8e679640) at ../../kdeui/actions/kaction.cpp:131
#16 0x00007f2e2e461e9c in QApplicationPrivate::notify_helper (this=this@entry=0x1a40a50, receiver=receiver@entry=0x553dfb0, e=e@entry=0x7fff8e679640) at kernel/qapplication.cpp:4562
#17 0x00007f2e2e46630a in QApplication::notify (this=0x7fff8e67ae80, receiver=0x553dfb0, e=0x7fff8e679640) at kernel/qapplication.cpp:4423
#18 0x00007f2e2d73e1d6 in KApplication::notify (this=0x7fff8e67ae80, receiver=0x553dfb0, event=0x7fff8e679640) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x00007f2e2cf4256e in QCoreApplication::notifyInternal (this=0x7fff8e67ae80, receiver=0x553dfb0, event=0x7fff8e679640) at kernel/qcoreapplication.cpp:915
#20 0x00007f2e2e492d74 in sendEvent (event=0x7fff8e679640, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#21 QShortcutMap::dispatchEvent (this=this@entry=0x1a40b70, e=e@entry=0x7fff8e679c10) at kernel/qshortcutmap.cpp:884
#22 0x00007f2e2e4943a3 in QShortcutMap::tryShortcutEvent (this=0x1a40b70, o=<optimized out>, e=0x7fff8e679c10) at kernel/qshortcutmap.cpp:364
#23 0x00007f2e2e467fe9 in QApplication::notify (this=0x7fff8e67ae80, receiver=0x54a3bf0, e=0x7fff8e679c10) at kernel/qapplication.cpp:3986
#24 0x00007f2e2d73e1d6 in KApplication::notify (this=0x7fff8e67ae80, receiver=0x54a3bf0, event=0x7fff8e679c10) at ../../kdeui/kernel/kapplication.cpp:311
#25 0x00007f2e2cf4256e in QCoreApplication::notifyInternal (this=0x7fff8e67ae80, receiver=0x54a3bf0, event=0x7fff8e679c10) at kernel/qcoreapplication.cpp:915
#26 0x00007f2e2e502e79 in QKeyMapper::sendKeyEvent (keyWidget=keyWidget@entry=0x54a3bf0, grab=grab@entry=false, type=QEvent::KeyPress, code=16777238, modifiers=..., text=..., autorepeat=autorepeat@entry=false, count=1, nativeScanCode=112, nativeVirtualKey=65365, nativeModifiers=0) at kernel/qkeymapper_x11.cpp:1866
#27 0x00007f2e2e5032b1 in QKeyMapperPrivate::translateKeyEvent (this=0x1a83670, keyWidget=0x54a3bf0, event=0x7fff8e67a640, grab=<optimized out>) at kernel/qkeymapper_x11.cpp:1836
#28 0x00007f2e2e4deed9 in QApplication::x11ProcessEvent (this=0x7fff8e67ae80, event=0x7fff8e67a640) at kernel/qapplication_x11.cpp:3630
#29 0x00007f2e2e506fa2 in x11EventSourceDispatch (s=0x1a43470, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#30 0x00007f2e2c1a8ab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f2e2c1a8de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f2e2c1a8ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007f2e2cf70bf6 in QEventDispatcherGlib::processEvents (this=0x1a06b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#34 0x00007f2e2e506c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007f2e2cf412bf in QEventLoop::processEvents (this=this@entry=0x7fff8e67aa10, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007f2e2cf41548 in QEventLoop::exec (this=0x7fff8e67aa10, flags=...) at kernel/qeventloop.cpp:204
#37 0x00007f2e2cf46708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#38 0x00007f2e2f3234bd in kdemain (argc=<optimized out>, argv=0x7fff8e67b000) at ../../../kate/app/katemain.cpp:377
#39 0x00007f2e2ef6376d in __libc_start_main (main=0x400690 <main(int, char**)>, argc=2, ubp_av=0x7fff8e67b008, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff8e67aff8) at libc-start.c:226
#40 0x00000000004006c1 in _start ()

Possible duplicates by query: bug 276930, bug 266427.

Reported using DrKonqi
Comment 1 Dominik Haumann 2013-02-20 10:57:40 UTC

*** This bug has been marked as a duplicate of bug 311866 ***