Bug 327224 - Regression: Dolphin doesn't accept URLs containing a kio-slave as parameter
Summary: Regression: Dolphin doesn't accept URLs containing a kio-slave as parameter
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 4.11.3
Platform: OpenSUSE Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
: 327479 328173 328378 328524 329114 329308 329566 330288 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-11-06 13:26 UTC by Wolfgang Bauer
Modified: 2014-01-22 14:49 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wolfgang Bauer 2013-11-06 13:26:04 UTC
When running dolphin with any URI containing a kio-slave as parameter it opens the user's home folder instead.

Specifying a folder works, i.e. running "dolphin ~/Desktop" shows the Desktop folder.

Reproducible: Always

Steps to Reproduce:
1. Run "dolphin trash:/" or click on the trash plasmoid f.e.

Actual Results:  
Dolphin runs and opens the user's home folder.

Expected Results:  
The trash folder should be opened.

It worked fine in 4.11.2.

This not only applies to "trash:/", but also f.e. "smb://HOST", "desktop:/", "audiocd:/" and any others I tried.

Clicking on the Trash icon in the places panel or entering the URL into the location bar does open the correct folder though.

It still works fine with Konqueror, i.e. running "konqueror trash:/" does open the trash folder.
Comment 1 Wolfgang Bauer 2013-11-06 14:14:14 UTC
This is caused by https://projects.kde.org/projects/kde/applications/kde-baseapps/repository/revisions/cd9e50ae4f3ded5a78d0cfb09a67684a9c15d726 .

Reverting that commit fixes the issue for me.
Comment 2 Frank Reininghaus 2013-11-06 15:15:26 UTC
Thanks for the bug report and for the investigation!

Unfortunately, I'm not sure when I'll be near my development machine again - maybe not today. If you have a KDE git account or if anyone else who reads this does, please feel free to do a "git revert cd9e50ae4f3ded5a78d0cfb09a67684a9c15d726" in the KDE/4.11 branch. We might then consider notifying the packagers, such that they can evaluate if they consider this important enough to re-do their packages.

Merging KDE/4.11 into KDE/4.12 then might also be nice (would prevent that this regression appears in 4.12 beta 1, which is scheduled to be tagged today at 23:59 UTC), but there might be a merge conflict that needs fixing because there was another commit that changed this code:

http://quickgit.kde.org/?p=kde-baseapps.git&a=commit&h=81c99da7e0043d433756d1f062bf30845db93c66
Comment 3 Wolfgang Bauer 2013-11-06 17:06:41 UTC
OK, I have reverted the commit in KDE/4.11 and merged to KDE/4.12.

I accidentally removed that other commit.
I have redone it with another commit, I hope that's ok.

Sorry, that was my first git merge...
Comment 4 Frank Reininghaus 2013-11-07 07:52:02 UTC
(In reply to comment #3)
> OK, I have reverted the commit in KDE/4.11 and merged to KDE/4.12.
> 
> I accidentally removed that other commit.
> I have redone it with another commit, I hope that's ok.

Sure! I don't think there was a cleaner way to handle this. Many thanks for your help!
Comment 5 Hrvoje Senjan 2013-11-15 00:12:24 UTC
*** Bug 327479 has been marked as a duplicate of this bug. ***
Comment 6 Christoph Feck 2013-11-28 19:39:06 UTC
*** Bug 328173 has been marked as a duplicate of this bug. ***
Comment 7 Frank Reininghaus 2013-12-03 14:20:05 UTC
*** Bug 328378 has been marked as a duplicate of this bug. ***
Comment 8 Cjacker 2013-12-04 07:51:17 UTC
As I remember in Konqueror of KDE 3.x  there is a "filterURL" function(something like that) to filter url(s) before handle it, for example, use different profile for different protocol. 

Maybe Dolphin also need to implement something like that?

Just a suggestion..
Comment 9 Janet 2013-12-06 20:49:49 UTC
Does this also fix the problem in the shelf widget? It also does not accept kio-slave URLs anymore... Bug 327035... Or is this a pure dolphin fix?
Comment 10 Wolfgang Bauer 2013-12-06 21:07:08 UTC
(In reply to comment #9)
> Does this also fix the problem in the shelf widget? It also does not accept
> kio-slave URLs anymore... Bug 327035... Or is this a pure dolphin fix?
This was a dolphin specific regression in 4.11.3 and just fixed in dolphin.

I have no idea about that shelf issue, but it is not related to this at all. That issue was even reported for 4.11.2 already...
Comment 11 Christoph Feck 2013-12-08 01:53:40 UTC
*** Bug 328524 has been marked as a duplicate of this bug. ***
Comment 12 Frank Reininghaus 2013-12-22 11:28:13 UTC
*** Bug 329114 has been marked as a duplicate of this bug. ***
Comment 13 Christoph Feck 2013-12-28 21:05:33 UTC
*** Bug 329308 has been marked as a duplicate of this bug. ***
Comment 14 Frank Reininghaus 2014-01-03 17:13:40 UTC
*** Bug 329566 has been marked as a duplicate of this bug. ***
Comment 15 Frank Reininghaus 2014-01-22 14:49:05 UTC
*** Bug 330288 has been marked as a duplicate of this bug. ***