Bug 325175 - kmail chrashes after entering pgp passphrase
Summary: kmail chrashes after entering pgp passphrase
Status: RESOLVED DUPLICATE of bug 279749
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.11.1
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-09-22 14:13 UTC by rhasti
Modified: 2013-09-22 14:43 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rhasti 2013-09-22 14:13:43 UTC
Application: kontact (4.11.1)
KDE Platform Version: 4.11.1
Qt Version: 4.8.5
Operating System: Linux 3.10.11-200.fc19.x86_64 x86_64
Distribution: "Fedora release 19 (Schrödinger’s Cat)"

-- Information about the crash:
- What I was doing when the application crashed:

kmail randomly crashes when entering pgp passphrase

Fedora 19 

kdepim-4.11.1-1.fc19.x86_64

- Custom settings of the application:


mail account configured for imap on gmail

The crash can be reproduced sometimes.

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f2cd6c688c0 (LWP 15972))]

Thread 4 (Thread 0x7f2cc9ad6700 (LWP 15975)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00000035546cd34d in WTF::TCMalloc_PageHeap::scavengerThread (this=<optimized out>) at /usr/src/debug/webkit-qtwebkit-23/Source/WTF/wtf/FastMalloc.cpp:2571
#2  0x00000035546cd389 in WTF::TCMalloc_PageHeap::runScavengerThread (context=<optimized out>) at /usr/src/debug/webkit-qtwebkit-23/Source/WTF/wtf/FastMalloc.cpp:1767
#3  0x0000003b59a07c53 in start_thread (arg=0x7f2cc9ad6700) at pthread_create.c:308
#4  0x0000003b592f5d3d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f2cc8fac700 (LWP 15976)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x000000355440dadd in JSC::BlockAllocator::blockFreeingThreadMain (this=0x7f2cc9230398) at /usr/src/debug/webkit-qtwebkit-23/Source/JavaScriptCore/heap/BlockAllocator.cpp:128
#2  0x00000035546fcba6 in WTF::wtfThreadEntryPoint (param=0x2439aa0) at /usr/src/debug/webkit-qtwebkit-23/Source/WTF/wtf/ThreadingPthreads.cpp:196
#3  0x0000003b59a07c53 in start_thread (arg=0x7f2cc8fac700) at pthread_create.c:308
#4  0x0000003b592f5d3d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f2c7b8f0700 (LWP 16008)):
#0  0x0000003b59a0aa6c in __pthread_mutex_unlock_usercnt (decr=1, mutex=0x7f2c70000a80) at pthread_mutex_unlock.c:52
#1  __GI___pthread_mutex_unlock (mutex=0x7f2c70000a80) at pthread_mutex_unlock.c:297
#2  0x0000003b5ba87281 in g_mutex_unlock (mutex=mutex@entry=0x7f2c700009c0) at gthread-posix.c:229
#3  0x0000003b5ba480e9 in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7f2c700013e0, timeout=9272, context=0x7f2c700009c0) at gmain.c:3994
#4  g_main_context_iterate (context=context@entry=0x7f2c700009c0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3696
#5  0x0000003b5ba481fc in g_main_context_iteration (context=0x7f2c700009c0, may_block=1) at gmain.c:3762
#6  0x00007f2cd8be7166 in QEventDispatcherGlib::processEvents (this=0x7f2c700008e0, flags=...) at kernel/qeventdispatcher_glib.cpp:427
#7  0x00007f2cd8bb8ecf in QEventLoop::processEvents (this=this@entry=0x7f2c7b8efd20, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007f2cd8bb91c5 in QEventLoop::exec (this=this@entry=0x7f2c7b8efd20, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007f2cd8ab866f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:536
#10 0x00007f2cd8abad0f in QThreadPrivate::start (arg=0x2455bb0) at thread/qthread_unix.cpp:338
#11 0x0000003b59a07c53 in start_thread (arg=0x7f2c7b8f0700) at pthread_create.c:308
#12 0x0000003b592f5d3d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f2cd6c688c0 (LWP 15972)):
[KCrash Handler]
#6  0x000000310bc43184 in KMime::Content::parent (this=this@entry=0x2d43dc0) at /usr/src/debug/kdepimlibs-4.11.1/kmime/kmime_content.cpp:953
#7  0x0000003a8a43aa27 in MessageCore::NodeHelper::nextSibling (node=node@entry=0x2d43dc0) at /usr/src/debug/kdepim-4.11.1/messagecore/helpers/nodehelper.cpp:32
#8  0x00007f2c8168a0ef in MessageViewer::ObjectTreeParser::parseObjectTreeInternal (this=this@entry=0x7fffd4293ef0, node=node@entry=0x2d43dc0) at /usr/src/debug/kdepim-4.11.1/messageviewer/viewer/objecttreeparser.cpp:296
#9  0x00007f2c8168bbd9 in MessageViewer::ObjectTreeParser::parseObjectTree (this=this@entry=0x7fffd4293ef0, node=node@entry=0x2d43dc0) at /usr/src/debug/kdepim-4.11.1/messageviewer/viewer/objecttreeparser.cpp:266
#10 0x00007f2c816b7e28 in MessageViewer::ViewerPrivate::parseContent (this=this@entry=0x2a779d0, content=0x2d43dc0) at /usr/src/debug/kdepim-4.11.1/messageviewer/viewer/viewer_p.cpp:1007
#11 0x00007f2c816b85d2 in MessageViewer::ViewerPrivate::displayMessage (this=this@entry=0x2a779d0) at /usr/src/debug/kdepim-4.11.1/messageviewer/viewer/viewer_p.cpp:879
#12 0x00007f2c816b921e in MessageViewer::ViewerPrivate::updateReaderWin (this=0x2a779d0) at /usr/src/debug/kdepim-4.11.1/messageviewer/viewer/viewer_p.cpp:2269
#13 0x00007f2c816c09fd in MessageViewer::ViewerPrivate::qt_static_metacall (_o=0x2a779d0, _c=4294967295, _id=1499178888, _a=0x0) at /usr/src/debug/kdepim-4.11.1/x86_64-redhat-linux-gnu/messageviewer/viewer_p.moc:254
#14 0x00007f2cd8bcdf78 in QMetaObject::activate (sender=0x2a77a60, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#15 0x00007f2cd8bd2141 in QObject::event (this=0x2a77a60, e=<optimized out>) at kernel/qobject.cpp:1156
#16 0x00007f2cd93414dc in QApplicationPrivate::notify_helper (this=this@entry=0x216bfa0, receiver=receiver@entry=0x2a77a60, e=e@entry=0x7fffd4294620) at kernel/qapplication.cpp:4562
#17 0x00007f2cd9347aa0 in QApplication::notify (this=this@entry=0x7fffd42949a0, receiver=receiver@entry=0x2a77a60, e=e@entry=0x7fffd4294620) at kernel/qapplication.cpp:4348
#18 0x0000003107e3fd2a in KApplication::notify (this=0x7fffd42949a0, receiver=0x2a77a60, event=0x7fffd4294620) at /usr/src/debug/kdelibs-4.11.1/kdeui/kernel/kapplication.cpp:311
#19 0x00007f2cd8bba26d in QCoreApplication::notifyInternal (this=0x7fffd42949a0, receiver=0x2a77a60, event=0x7fffd4294620) at kernel/qcoreapplication.cpp:949
#20 0x00007f2cd8be9c13 in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#21 QTimerInfoList::activateTimers (this=0x2178120) at kernel/qeventdispatcher_unix.cpp:621
#22 0x00007f2cd8be6f11 in timerSourceDispatch (source=source@entry=0x21780c0) at kernel/qeventdispatcher_glib.cpp:186
#23 0x0000003b5ba47e06 in g_main_dispatch (context=0x2173f00) at gmain.c:3054
#24 g_main_context_dispatch (context=context@entry=0x2173f00) at gmain.c:3630
#25 0x0000003b5ba48158 in g_main_context_iterate (context=context@entry=0x2173f00, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3701
#26 0x0000003b5ba481fc in g_main_context_iteration (context=0x2173f00, may_block=1) at gmain.c:3762
#27 0x00007f2cd8be7145 in QEventDispatcherGlib::processEvents (this=0x209cee0, flags=...) at kernel/qeventdispatcher_glib.cpp:425
#28 0x00007f2cd93ddfc6 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#29 0x00007f2cd8bb8ecf in QEventLoop::processEvents (this=this@entry=0x7fffd42948a0, flags=...) at kernel/qeventloop.cpp:149
#30 0x00007f2cd8bb91c5 in QEventLoop::exec (this=this@entry=0x7fffd42948a0, flags=...) at kernel/qeventloop.cpp:204
#31 0x00007f2cd8bbe45b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1221
#32 0x00007f2cd933fc9c in QApplication::exec () at kernel/qapplication.cpp:3823
#33 0x0000000000403760 in main (argc=1, argv=0x7fffd4294ae8) at /usr/src/debug/kdepim-4.11.1/kontact/src/main.cpp:219

Possible duplicates by query: bug 308420, bug 307425.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-09-22 14:43:02 UTC

*** This bug has been marked as a duplicate of bug 279749 ***