Bug 289052 - akonadi_imap_resource (KDE 4.7.4, Kubuntu 11.10, 64 bit) has crashed after resuming from "suspend to RAM"
Summary: akonadi_imap_resource (KDE 4.7.4, Kubuntu 11.10, 64 bit) has crashed after re...
Status: RESOLVED DUPLICATE of bug 288268
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-15 17:28 UTC by Thomas Dreibholz
Modified: 2011-12-17 12:52 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (12.89 KB, text/plain)
2011-12-16 15:10 UTC, Thomas Dreibholz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Dreibholz 2011-12-15 17:28:17 UTC
Application: akonadi_imap_resource (4.7)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-14-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
- What I was doing when the application crashed:

akonadi_imap_resource (KDE 4.7.4, Kubuntu 11.10, 64 bit) has crashed after resuming from "suspend to RAM".

-- Backtrace:
Application: Uni-DUE vom Typ IMAP-E-Mail-Server (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f57fe2d1780 (LWP 2149))]

Thread 5 (Thread 0x7f57e9c51700 (LWP 5801)):
#0  g_main_context_iteration (context=0xf312e0, may_block=1) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3152
#1  0x00007f57fd74af3e in QEventDispatcherGlib::processEvents (this=0x18bdaf0, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#2  0x00007f57fd71ecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#3  0x00007f57fd71eef7 in QEventLoop::exec (this=0x7f57e9c50de0, flags=...) at kernel/qeventloop.cpp:201
#4  0x00007f57fd63627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#5  0x00007f57fc35dc13 in KIMAP::SessionThread::run (this=0x18b0280) at ../../kimap/sessionthread.cpp:169
#6  0x00007f57fd638d05 in QThreadPrivate::start (arg=0x18b0280) at thread/qthread_unix.cpp:331
#7  0x00007f57f95baefc in start_thread (arg=0x7f57e9c51700) at pthread_create.c:304
#8  0x00007f57f9d0b89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f57e8827700 (LWP 16049)):
#0  g_main_context_iterate (context=0x1a7a380, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3095
#1  0x00007f57f8652429 in g_main_context_iteration (context=0x1a7a380, may_block=1) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3152
#2  0x00007f57fd74af3e in QEventDispatcherGlib::processEvents (this=0xe31c00, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#3  0x00007f57fd71ecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#4  0x00007f57fd71eef7 in QEventLoop::exec (this=0x7f57e8826de0, flags=...) at kernel/qeventloop.cpp:201
#5  0x00007f57fd63627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#6  0x00007f57fc35dc13 in KIMAP::SessionThread::run (this=0xe16e60) at ../../kimap/sessionthread.cpp:169
#7  0x00007f57fd638d05 in QThreadPrivate::start (arg=0xe16e60) at thread/qthread_unix.cpp:331
#8  0x00007f57f95baefc in start_thread (arg=0x7f57e8827700) at pthread_create.c:304
#9  0x00007f57f9d0b89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f57e922b700 (LWP 1097)):
#0  0xffffffffff60017b in ?? ()
#1  0x00007f57e922ab00 in ?? ()
#2  0x00007fff89bff7e7 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread 0x7f57ec62c700 (LWP 29201)):
#0  0x00007f57f95be1fd in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x116d1d8) at pthread_mutex_unlock.c:290
#2  0x00007f57f8651d79 in g_main_context_iterate (context=0x116d1d0, block=1, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3030
#3  0x00007f57f8652429 in g_main_context_iteration (context=0x116d1d0, may_block=1) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3152
#4  0x00007f57fd74af3e in QEventDispatcherGlib::processEvents (this=0x1446e50, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007f57fd71ecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f57fd71eef7 in QEventLoop::exec (this=0x7f57ec62bde0, flags=...) at kernel/qeventloop.cpp:201
#7  0x00007f57fd63627f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#8  0x00007f57fc35dc13 in KIMAP::SessionThread::run (this=0x100df20) at ../../kimap/sessionthread.cpp:169
#9  0x00007f57fd638d05 in QThreadPrivate::start (arg=0x100df20) at thread/qthread_unix.cpp:331
#10 0x00007f57f95baefc in start_thread (arg=0x7f57ec62c700) at pthread_create.c:304
#11 0x00007f57f9d0b89d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f57fe2d1780 (LWP 2149)):
[KCrash Handler]
#6  0x00007f57fb51ba30 in vtable for OrgKdeSolidNetworkingClientInterface () from /usr/lib/libsolid.so.4
#7  0x00007f57fd732714 in QObject::disconnect (sender=0xd50fb0, signal=0x1877569 "connectionLost()", receiver=0xd5a6e0, method=0x18775a9 "onEarlyConnectionLost()") at kernel/qobject.cpp:2728
#8  0x0000000000453921 in SessionPool::killSession (this=0xd5a6e0, session=0xd50fb0, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:177
#9  0x0000000000453ee5 in SessionPool::disconnect (this=0xd5a6e0, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:119
#10 0x00000000004168c3 in ImapResource::doSetOnline (this=0xc6ffc0, online=false) at ../../../resources/imap/imapresource.cpp:421
#11 0x00007f57fdd4aee8 in Akonadi::AgentBase::setOnline (this=0xc6ffc0, state=false) at ../../akonadi/agentbase.cpp:630
#12 0x00007f57fdd4c1d0 in Akonadi::AgentBase::qt_metacall (this=0xc6ffc0, _c=QMetaObject::InvokeMetaMethod, _id=18, _a=0x7fff89b8bf30) at ./agentbase.moc:127
#13 0x00007f57fde19185 in Akonadi::ResourceBase::qt_metacall (this=0xc6ffc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff89b8bf30) at ./moc_resourcebase.cpp:121
#14 0x000000000041a0a5 in ImapResource::qt_metacall (this=0xc6ffc0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff89b8bf30) at ./imapresource.moc:112
#15 0x00007f57fd732eba in QMetaObject::activate (sender=0xd53ac0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff89b8bf30) at kernel/qobject.cpp:3278
#16 0x00007f57fb27c82e in Solid::Networking::Notifier::statusChanged (this=<optimized out>, _t1=Solid::Networking::Unconnected) at ./networking.moc:90
#17 0x00007f57fb27cf52 in Solid::NetworkingPrivate::qt_metacall (this=0xd53ac0, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0x7fff89b8c040) at ./networking_p.moc:89
#18 0x00007f57fd732eba in QMetaObject::activate (sender=0xd78810, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fff89b8c040) at kernel/qobject.cpp:3278
#19 0x00007f57fb2deb9e in OrgKdeSolidNetworkingClientInterface::statusChanged (this=<optimized out>, _t1=1) at org_kde_solid_networking_client.moc:118
#20 0x00007f57fb2dec05 in OrgKdeSolidNetworkingClientInterface::qt_metacall (this=0xd78810, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff89b8c2c0) at org_kde_solid_networking_client.moc:81
#21 0x00007f57fda770e9 in QDBusConnectionPrivate::deliverCall (this=0xc46dd0, object=0xd78810, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:942
#22 0x00007f57fda8038f in QDBusCallDeliveryEvent::placeMetaCall (this=<optimized out>, object=<optimized out>) at qdbusintegrator_p.h:103
#23 0x00007f57fd736a5e in QObject::event (this=0xd78810, e=<optimized out>) at kernel/qobject.cpp:1217
#24 0x00007f57fcad0424 in notify_helper (e=0x116cc90, receiver=0xd78810, this=0xbddbc0) at kernel/qapplication.cpp:4486
#25 QApplicationPrivate::notify_helper (this=0xbddbc0, receiver=0xd78810, e=0x116cc90) at kernel/qapplication.cpp:4458
#26 0x00007f57fcad5291 in QApplication::notify (this=0x7fff89b8cb60, receiver=0xd78810, e=0x116cc90) at kernel/qapplication.cpp:4365
#27 0x00007f57fabe7466 in KApplication::notify (this=0x7fff89b8cb60, receiver=0xd78810, event=0x116cc90) at ../../kdeui/kernel/kapplication.cpp:311
#28 0x00007f57fd71fafc in QCoreApplication::notifyInternal (this=0x7fff89b8cb60, receiver=0xd78810, event=0x116cc90) at kernel/qcoreapplication.cpp:787
#29 0x00007f57fd72351f in sendEvent (event=0x116cc90, receiver=0xd78810) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xbb8800) at kernel/qcoreapplication.cpp:1428
#31 0x00007f57fd74aa73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#32 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#33 0x00007f57f8651a5d in g_main_dispatch (context=0xbe0400) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:2441
#34 g_main_context_dispatch (context=0xbe0400) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3011
#35 0x00007f57f8652258 in g_main_context_iterate (context=0xbe0400, block=<optimized out>, dispatch=1, self=<optimized out>) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3089
#36 0x00007f57f8652429 in g_main_context_iteration (context=0xbe0400, may_block=1) at /build/buildd/glib2.0-2.30.0/./glib/gmain.c:3152
#37 0x00007f57fd74aed6 in QEventDispatcherGlib::processEvents (this=0xbba210, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#38 0x00007f57fcb7807e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#39 0x00007f57fd71ecf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#40 0x00007f57fd71eef7 in QEventLoop::exec (this=0x7fff89b8cae0, flags=...) at kernel/qeventloop.cpp:201
#41 0x00007f57fd723789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#42 0x00007f57fde13fa6 in Akonadi::ResourceBase::init (r=0xc6ffc0) at ../../akonadi/resourcebase.cpp:393
#43 0x000000000041a726 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#44 0x00007f57f9c4b30d in __libc_start_main (main=0x415050 <main(int, char**)>, argc=3, ubp_av=0x7fff89b8cc78, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff89b8cc68) at libc-start.c:226
#45 0x0000000000415205 in _start ()

Reported using DrKonqi
Comment 1 Thomas Dreibholz 2011-12-16 15:10:54 UTC
Created attachment 66810 [details]
New crash information added by DrKonqi

akonadi_imap_resource (4.7) on KDE Platform 4.7.4 (4.7.4) using Qt 4.7.4

- What I was doing when the application crashed:

Crash happened again when resuming from "suspend to RAM".

-- Backtrace (Reduced):
#7  0x00007f8eb38dc714 in QObject::disconnect (sender=0x287e470, signal=0x26d57d9 "connectionLost()", receiver=0x24bb7e0, method=0x2868049 "onEarlyConnectionLost()") at kernel/qobject.cpp:2728
#8  0x0000000000453921 in SessionPool::killSession (this=0x24bb7e0, session=0x287e470, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:177
#9  0x0000000000453ee5 in SessionPool::disconnect (this=0x24bb7e0, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:119
#10 0x00000000004168c3 in ImapResource::doSetOnline (this=0x23b2630, online=false) at ../../../resources/imap/imapresource.cpp:421
#11 0x00007f8eb3ef4ee8 in Akonadi::AgentBase::setOnline (this=0x23b2630, state=false) at ../../akonadi/agentbase.cpp:630
Comment 2 Christophe Giboudeaux 2011-12-17 12:52:50 UTC

*** This bug has been marked as a duplicate of bug 288268 ***