Bug 294401 - Kontact crashed upon exit
Summary: Kontact crashed upon exit
Status: RESOLVED DUPLICATE of bug 288268
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: 4.7
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kevin Ottens
URL:
Keywords:
: 296519 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-02-19 01:41 UTC by Ekkehard Blanz
Modified: 2012-09-02 06:53 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ekkehard Blanz 2012-02-19 01:41:22 UTC
Application: akonadi_imap_resource (4.7)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-16-generic x86_64
Distribution: Ubuntu 11.10

-- Information about the crash:
I was trying to shut down Kontact because something was eating up all the CPU cycles on two of my six cores.  Top didn't show what it was, but Kontact (Kmail had been the culprit before).  When I tried to shut it down, it crashed,.

-- Backtrace:
Application: Google Mail of type IMAP E-Mail Server (akonadi_imap_resource), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f65884a7780 (LWP 2516))]

Thread 2 (Thread 0x7f6567fff700 (LWP 27631)):
#0  0x00007f6583ecd773 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f658281ff68 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f6582820429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6587919f3e in QEventDispatcherGlib::processEvents (this=0x178c250, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:424
#4  0x00007f65878edcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f65878edef7 in QEventLoop::exec (this=0x7f6567ffede0, flags=...) at kernel/qeventloop.cpp:201
#6  0x00007f658780527f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:498
#7  0x00007f658652bc13 in KIMAP::SessionThread::run (this=0x1781740) at ../../kimap/sessionthread.cpp:169
#8  0x00007f6587807d05 in QThreadPrivate::start (arg=0x1781740) at thread/qthread_unix.cpp:331
#9  0x00007f6583788efc in start_thread (arg=0x7f6567fff700) at pthread_create.c:304
#10 0x00007f6583ed989d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f65884a7780 (LWP 2516)):
[KCrash Handler]
#6  0x000000000067db00 in vtable for __cxxabiv1::__si_class_type_info ()
#7  0x00007f6587901714 in QObject::disconnect (sender=0x7f6568023f50, signal=0x171fef9 "connectionLost()", receiver=0x15d84c0, method=0x16446c9 "onEarlyConnectionLost()") at kernel/qobject.cpp:2728
#8  0x0000000000453931 in SessionPool::killSession (this=0x15d84c0, session=0x7f6568023f50, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:177
#9  0x0000000000453ef5 in SessionPool::disconnect (this=0x15d84c0, termination=SessionPool::LogoutSession) at ../../../resources/imap/sessionpool.cpp:119
#10 0x00000000004168c3 in ImapResource::doSetOnline (this=0x15c3ff0, online=false) at ../../../resources/imap/imapresource.cpp:421
#11 0x00007f6587f19ee8 in Akonadi::AgentBase::setOnline (this=0x15c3ff0, state=false) at ../../akonadi/agentbase.cpp:630
#12 0x00007f658804f9c0 in Akonadi__StatusAdaptor::qt_metacall (this=0x15aacf0, _c=QMetaObject::InvokeMetaMethod, _id=8, _a=0x7fffd4856950) at statusadaptor.moc:129
#13 0x00007f6587c460e9 in QDBusConnectionPrivate::deliverCall (this=0x1509760, object=0x15aacf0, msg=..., metaTypes=..., slotIdx=12) at qdbusintegrator.cpp:942
#14 0x00007f6587c4725c in QDBusConnectionPrivate::activateCall (this=0x1509760, object=0x15aacf0, flags=273, msg=...) at qdbusintegrator.cpp:852
#15 0x00007f6587c47b22 in QDBusConnectionPrivate::activateObject (this=0x1509760, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1410
#16 0x00007f6587c47bf8 in QDBusActivateObjectEvent::placeMetaCall (this=0x15ce280) at qdbusintegrator.cpp:1524
#17 0x00007f6587905a5e in QObject::event (this=0x15c3ff0, e=<optimized out>) at kernel/qobject.cpp:1217
#18 0x00007f6586c9e474 in notify_helper (e=0x15ce280, receiver=0x15c3ff0, this=0x143a450) at kernel/qapplication.cpp:4486
#19 QApplicationPrivate::notify_helper (this=0x143a450, receiver=0x15c3ff0, e=0x15ce280) at kernel/qapplication.cpp:4458
#20 0x00007f6586ca32e1 in QApplication::notify (this=0x7fffd4857430, receiver=0x15c3ff0, e=0x15ce280) at kernel/qapplication.cpp:4365
#21 0x00007f6584db5466 in KApplication::notify (this=0x7fffd4857430, receiver=0x15c3ff0, event=0x15ce280) at ../../kdeui/kernel/kapplication.cpp:311
#22 0x00007f65878eeafc in QCoreApplication::notifyInternal (this=0x7fffd4857430, receiver=0x15c3ff0, event=0x15ce280) at kernel/qcoreapplication.cpp:787
#23 0x00007f65878f251f in sendEvent (event=0x15ce280, receiver=0x15c3ff0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#24 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1410800) at kernel/qcoreapplication.cpp:1428
#25 0x00007f6587919a73 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#26 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:277
#27 0x00007f658281fa5d in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f6582820258 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f6582820429 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f6587919ed6 in QEventDispatcherGlib::processEvents (this=0x1412210, flags=<optimized out>) at kernel/qeventdispatcher_glib.cpp:422
#31 0x00007f6586d4610e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007f65878edcf2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#33 0x00007f65878edef7 in QEventLoop::exec (this=0x7fffd48573b0, flags=...) at kernel/qeventloop.cpp:201
#34 0x00007f65878f2789 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#35 0x00007f6587fe2fa6 in Akonadi::ResourceBase::init (r=0x15c3ff0) at ../../akonadi/resourcebase.cpp:393
#36 0x000000000041a726 in Akonadi::ResourceBase::init<ImapResource> (argc=<optimized out>, argv=<optimized out>) at /usr/include/akonadi/resourcebase.h:188
#37 0x00007f6583e1930d in __libc_start_main (main=0x415050 <main(int, char**)>, argc=3, ubp_av=0x7fffd4857548, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffd4857538) at libc-start.c:226
#38 0x0000000000415205 in _start ()

Reported using DrKonqi
Comment 1 Christophe Giboudeaux 2012-03-31 13:43:39 UTC
*** Bug 296519 has been marked as a duplicate of this bug. ***
Comment 2 Myriam Schweingruber 2012-09-02 06:51:11 UTC
More information already in bug 295001

*** This bug has been marked as a duplicate of bug 295001 ***
Comment 3 Myriam Schweingruber 2012-09-02 06:53:03 UTC
Oops, my bad, seems that bug 288268 is the master bug for this, sorry for the noise.

*** This bug has been marked as a duplicate of bug 288268 ***