Bug 324350 - Segmentation Fault when starting.
Summary: Segmentation Fault when starting.
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Scan (show other bugs)
Version: 3.3.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2013-09-01 11:32 UTC by Ralph DeWitt
Modified: 2021-08-26 16:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph DeWitt 2013-09-01 11:32:57 UTC
Application: digikam (3.3.0)
KDE Platform Version: 4.11.00
Qt Version: 4.8.4
Operating System: Linux 3.8.0-23-generic x86_64
Distribution: Netrunner 5 Enigma (13.06)

-- Information about the crash:
- What I was doing when the application crashed:
I had just completed a install of NetrunnerOS 13.06, upgraded KDE to 4.11 and reinstalled my data from backup. I did not restore any .kde apps or cofig datat. Upon first start and every start this is whaat happens.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7fcc26084a40 (LWP 26290))]

Thread 3 (Thread 0x7fcbfd7ff700 (LWP 26291)):
[KCrash Handler]
#6  QReadWriteLock::lockForWrite (this=0x8) at thread/qreadwritelock.cpp:277
#7  0x00007fcc231f1194 in relock (this=0x7fcbfd7fd450) at /usr/include/qt4/QtCore/qreadwritelock.h:155
#8  QWriteLocker (areadWriteLock=<optimized out>, this=0x7fcbfd7fd450) at /usr/include/qt4/QtCore/qreadwritelock.h:175
#9  Digikam::CollectionScanner::scanFileNormal (this=this@entry=0x7fcbfd7fe2a0, fi=..., scanInfo=...) at /build/buildd/digikam-3.3.0/core/libs/database/collectionscanner.cpp:1102
#10 0x00007fcc231f4c69 in Digikam::CollectionScanner::scanAlbum (this=this@entry=0x7fcbfd7fe2a0, location=..., album=...) at /build/buildd/digikam-3.3.0/core/libs/database/collectionscanner.cpp:1032
#11 0x00007fcc231f4b62 in Digikam::CollectionScanner::scanAlbum (this=this@entry=0x7fcbfd7fe2a0, location=..., album=...) at /build/buildd/digikam-3.3.0/core/libs/database/collectionscanner.cpp:1066
#12 0x00007fcc231f4b62 in Digikam::CollectionScanner::scanAlbum (this=this@entry=0x7fcbfd7fe2a0, location=..., album=...) at /build/buildd/digikam-3.3.0/core/libs/database/collectionscanner.cpp:1066
#13 0x00007fcc231f567b in Digikam::CollectionScanner::scanAlbumRoot (this=this@entry=0x7fcbfd7fe2a0, location=...) at /build/buildd/digikam-3.3.0/core/libs/database/collectionscanner.cpp:785
#14 0x00007fcc231f5f75 in Digikam::CollectionScanner::completeScan (this=this@entry=0x7fcbfd7fe2a0) at /build/buildd/digikam-3.3.0/core/libs/database/collectionscanner.cpp:452
#15 0x00007fcc23262c99 in Digikam::SchemaUpdater::updateV4toV6 (this=this@entry=0x7fcbfd7fe8e0) at /build/buildd/digikam-3.3.0/core/libs/database/schemaupdater.cpp:1108
#16 0x00007fcc23264eea in Digikam::SchemaUpdater::makeUpdates (this=this@entry=0x7fcbfd7fe8e0) at /build/buildd/digikam-3.3.0/core/libs/database/schemaupdater.cpp:438
#17 0x00007fcc23266240 in Digikam::SchemaUpdater::startUpdates (this=this@entry=0x7fcbfd7fe8e0) at /build/buildd/digikam-3.3.0/core/libs/database/schemaupdater.cpp:295
#18 0x00007fcc23266a98 in Digikam::SchemaUpdater::update (this=this@entry=0x7fcbfd7fe8e0) at /build/buildd/digikam-3.3.0/core/libs/database/schemaupdater.cpp:143
#19 0x00007fcc2320cfc0 in Digikam::DatabaseBackend::initSchema (this=<optimized out>, updater=updater@entry=0x7fcbfd7fe8e0) at /build/buildd/digikam-3.3.0/core/libs/database/databasebackend.cpp:79
#20 0x00007fcc23207e12 in Digikam::DatabaseAccess::checkReadyForUse (observer=observer@entry=0x1b71350) at /build/buildd/digikam-3.3.0/core/libs/database/databaseaccess.cpp:303
#21 0x00000000005d2816 in Digikam::ScanController::run (this=0x1b71340) at /build/buildd/digikam-3.3.0/core/digikam/database/scancontroller.cpp:734
#22 0x00007fcc207d3bec in QThreadPrivate::start (arg=0x1b71340) at thread/qthread_unix.cpp:338
#23 0x00007fcc1ad27f8e in start_thread (arg=0x7fcbfd7ff700) at pthread_create.c:311
#24 0x00007fcc1f9e1e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7fcbfcffe700 (LWP 26292)):
#0  0x00007fcc18338359 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fcc183385e9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcc182f91d1 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcc182f9304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fcc208ff036 in QEventDispatcherGlib::processEvents (this=0x7fcbf00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fcc208cf38f in QEventLoop::processEvents (this=this@entry=0x7fcbfcffdb10, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fcc208cf618 in QEventLoop::exec (this=this@entry=0x7fcbfcffdb10, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fcc207d1410 in QThread::exec (this=this@entry=0x1ba7400) at thread/qthread.cpp:542
#8  0x00007fcc208b0edf in QInotifyFileSystemWatcherEngine::run (this=0x1ba7400) at io/qfilesystemwatcher_inotify.cpp:256
#9  0x00007fcc207d3bec in QThreadPrivate::start (arg=0x1ba7400) at thread/qthread_unix.cpp:338
#10 0x00007fcc1ad27f8e in start_thread (arg=0x7fcbfcffe700) at pthread_create.c:311
#11 0x00007fcc1f9e1e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fcc26084a40 (LWP 26290)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007fcc207d414b in wait (time=18446744073709551615, this=0x1b71470) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x1b71420, mutex=0x1b713f8, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fcc207d37bc in QThread::wait (this=this@entry=0x1b71340, time=time@entry=18446744073709551615) at thread/qthread_unix.cpp:691
#4  0x00000000005ce505 in Digikam::ScanController::shutDown (this=this@entry=0x1b71340) at /build/buildd/digikam-3.3.0/core/digikam/database/scancontroller.cpp:361
#5  0x00000000005d1c9b in Digikam::ScanController::~ScanController (this=0x1b71340, __in_chrg=<optimized out>) at /build/buildd/digikam-3.3.0/core/digikam/database/scancontroller.cpp:337
#6  0x00000000005d1e47 in ~ScanControllerCreator (this=0x1b71340, __in_chrg=<optimized out>) at /build/buildd/digikam-3.3.0/core/digikam/database/scancontroller.cpp:277
#7  destroy () at /build/buildd/digikam-3.3.0/core/digikam/database/scancontroller.cpp:284
#8  0x00007fcc1f924121 in __run_exit_handlers (status=1, listp=0x7fcc1fca96a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
#9  0x00007fcc1f9241a5 in __GI_exit (status=<optimized out>) at exit.c:99
#10 0x00007fcc213252d8 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:782
#11 0x00007fcc21fc46a8 in KApplication::xioErrhandler (this=0x7fff57941de0, dpy=0x1991b80) at ../../kdeui/kernel/kapplication.cpp:419
#12 0x00007fcc1debd5be in _XIOError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#13 0x00007fcc1debb08d in _XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#14 0x00007fcc1deac65b in XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#15 0x00007fcc21360bc7 in x11EventSourcePrepare (s=0x199e3e0, timeout=<optimized out>) at kernel/qguieventdispatcher_glib.cpp:77
#16 0x00007fcc182f8900 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#17 0x00007fcc182f90fe in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#18 0x00007fcc182f9304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#19 0x00007fcc208ff016 in QEventDispatcherGlib::processEvents (this=0x18f4a60, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#20 0x00007fcc2136113e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#21 0x00007fcc208cf38f in QEventLoop::processEvents (this=this@entry=0x1ad76a0, flags=...) at kernel/qeventloop.cpp:149
#22 0x00007fcc208cf618 in QEventLoop::exec (this=0x1ad76a0, flags=...) at kernel/qeventloop.cpp:204
#23 0x00000000005d0ccb in Digikam::ScanController::databaseInitialization (this=0x1b71340) at /build/buildd/digikam-3.3.0/core/digikam/database/scancontroller.cpp:425
#24 0x00000000005aab9e in Digikam::AlbumManager::setDatabase (this=0x1b8fd50, params=..., priority=priority@entry=false, suggestedAlbumRoot=...) at /build/buildd/digikam-3.3.0/core/digikam/album/albummanager.cpp:717
#25 0x00000000004924ef in main (argc=5, argv=0x7fff57942018) at /build/buildd/digikam-3.3.0/core/digikam/main/main.cpp:186

Possible duplicates by query: bug 322556, bug 321403.

Reported using DrKonqi
Comment 1 caulier.gilles 2013-09-01 11:56:12 UTC

*** This bug has been marked as a duplicate of bug 321403 ***
Comment 2 caulier.gilles 2021-08-26 16:55:28 UTC
Fixed with #321403