Bug 321403 - Digikam Crashes When Trying to Start
Summary: Digikam Crashes When Trying to Start
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Scan (show other bugs)
Version: 3.2.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-19 19:17 UTC by Clifton Hodges
Modified: 2017-07-25 13:19 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.0.0


Attachments
New crash information added by DrKonqi (6.26 KB, text/plain)
2013-09-27 15:37 UTC, Kay Muras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clifton Hodges 2013-06-19 19:17:02 UTC
Application: digikam (3.2.0)
KDE Platform Version: 4.10.3 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.11-desktop i686
Distribution: "openSUSE 12.3 (i586)"

-- Information about the crash:
This has occurred since the openSUSE 12.3.9 (2013-05-28) update:

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xaf845780 (LWP 7564))]

Thread 3 (Thread 0xae99fb40 (LWP 7565)):
[KCrash Handler]
#6  QReadWriteLock::lockForWrite (this=0x4) at thread/qreadwritelock.cpp:277
#7  0xb6612e29 in relock (this=0xae99e8f8) at /usr/include/QtCore/qreadwritelock.h:155
#8  QWriteLocker (areadWriteLock=<optimized out>, this=0xae99e8f8) at /usr/include/QtCore/qreadwritelock.h:175
#9  Digikam::CollectionScanner::scanFileNormal (this=this@entry=0xae99edb0, fi=..., scanInfo=...) at /usr/src/debug/digikam-3.2.0/core/libs/database/collectionscanner.cpp:1102
#10 0xb66159a6 in Digikam::CollectionScanner::scanAlbum (this=this@entry=0xae99edb0, location=..., album=...) at /usr/src/debug/digikam-3.2.0/core/libs/database/collectionscanner.cpp:1032
#11 0xb66158c0 in Digikam::CollectionScanner::scanAlbum (this=this@entry=0xae99edb0, location=..., album=...) at /usr/src/debug/digikam-3.2.0/core/libs/database/collectionscanner.cpp:1066
#12 0xb661643a in Digikam::CollectionScanner::scanAlbumRoot (this=0xae99edb0, location=...) at /usr/src/debug/digikam-3.2.0/core/libs/database/collectionscanner.cpp:785
#13 0xb66166a8 in Digikam::CollectionScanner::completeScan (this=0xae99edb0) at /usr/src/debug/digikam-3.2.0/core/libs/database/collectionscanner.cpp:452
#14 0xb6690d3f in Digikam::SchemaUpdater::updateV4toV6 (this=0xae99f138) at /usr/src/debug/digikam-3.2.0/core/libs/database/schemaupdater.cpp:1108
#15 0xb6692203 in Digikam::SchemaUpdater::makeUpdates (this=0xae99f138) at /usr/src/debug/digikam-3.2.0/core/libs/database/schemaupdater.cpp:438
#16 0xb6692f00 in Digikam::SchemaUpdater::startUpdates (this=this@entry=0xae99f138) at /usr/src/debug/digikam-3.2.0/core/libs/database/schemaupdater.cpp:295
#17 0xb66937ce in Digikam::SchemaUpdater::update (this=0xae99f138) at /usr/src/debug/digikam-3.2.0/core/libs/database/schemaupdater.cpp:143
#18 0xb6630d14 in Digikam::DatabaseBackend::initSchema (this=0x9f77608, updater=0xae99f138) at /usr/src/debug/digikam-3.2.0/core/libs/database/databasebackend.cpp:79
#19 0xb662ab22 in Digikam::DatabaseAccess::checkReadyForUse (observer=0xa005710) at /usr/src/debug/digikam-3.2.0/core/libs/database/databaseaccess.cpp:303
#20 0x082160d2 in Digikam::ScanController::run (this=0xa005708) at /usr/src/debug/digikam-3.2.0/core/digikam/database/scancontroller.cpp:722
#21 0xb586df78 in QThreadPrivate::start (arg=0xa005708) at thread/qthread_unix.cpp:338
#22 0xb4434b5e in start_thread () from /lib/libpthread.so.0
#23 0xb4ab316e in clone () from /lib/libc.so.6

Thread 2 (Thread 0xadfffb40 (LWP 7566)):
#0  0xb4aa8401 in poll () from /lib/libc.so.6
#1  0xb2e8c64b in g_poll () from /usr/lib/libglib-2.0.so.0
#2  0xb2e7dbd0 in ?? () from /usr/lib/libglib-2.0.so.0
#3  0xb2e7dd31 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#4  0xb59b28af in QEventDispatcherGlib::processEvents (this=0xad600468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0xb597f39c in QEventLoop::processEvents (this=this@entry=0xadfff1e8, flags=...) at kernel/qeventloop.cpp:149
#6  0xb597f691 in QEventLoop::exec (this=0xadfff1e8, flags=...) at kernel/qeventloop.cpp:204
#7  0xb586ab6c in QThread::exec (this=0x9f81db8) at thread/qthread.cpp:542
#8  0xb595d99d in QInotifyFileSystemWatcherEngine::run (this=0x9f81db8) at io/qfilesystemwatcher_inotify.cpp:256
#9  0xb586df78 in QThreadPrivate::start (arg=0x9f81db8) at thread/qthread_unix.cpp:338
#10 0xb4434b5e in start_thread () from /lib/libpthread.so.0
#11 0xb4ab316e in clone () from /lib/libc.so.6

Thread 1 (Thread 0xaf845780 (LWP 7564)):
#0  0xb4438792 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0xb4ac085c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#2  0xb586e550 in wait (time=4294967295, this=0x9f7f910) at thread/qwaitcondition_unix.cpp:86
#3  QWaitCondition::wait (this=0x9f7f8d8, mutex=0x9f7f8bc, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#4  0xb586dac5 in QThread::wait (this=0xa005708, time=4294967295) at thread/qthread_unix.cpp:691
#5  0x08212b99 in Digikam::ScanController::shutDown (this=this@entry=0xa005708) at /usr/src/debug/digikam-3.2.0/core/digikam/database/scancontroller.cpp:361
#6  0x0821505f in Digikam::ScanController::~ScanController (this=0xa005708, __in_chrg=<optimized out>) at /usr/src/debug/digikam-3.2.0/core/digikam/database/scancontroller.cpp:337
#7  0x08215217 in ~ScanControllerCreator (this=0xa005708, __in_chrg=<optimized out>) at /usr/src/debug/digikam-3.2.0/core/digikam/database/scancontroller.cpp:277
#8  destroy () at /usr/src/debug/digikam-3.2.0/core/digikam/database/scancontroller.cpp:284
#9  0xb4a06211 in __run_exit_handlers () from /lib/libc.so.6
#10 0xb4a0629d in exit () from /lib/libc.so.6
#11 0xb4e5ff38 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:772
#12 0xb5fb9f29 in KApplication::xioErrhandler (this=0xbfa7a0c8, dpy=dpy@entry=0x9f22e90) at /usr/src/debug/kdelibs-4.10.3/kdeui/kernel/kapplication.cpp:419
#13 0xb5fb9f64 in kde_xio_errhandler (dpy=0x9f22e90) at /usr/src/debug/kdelibs-4.10.3/kdeui/kernel/kapplication.cpp:126
#14 0xb45c7474 in _XIOError () from /usr/lib/libX11.so.6
#15 0xb45c4ccf in _XEventsQueued () from /usr/lib/libX11.so.6
#16 0xb45b55e0 in XEventsQueued () from /usr/lib/libX11.so.6
#17 0xb4e9b318 in x11EventSourcePrepare (s=0x9ef8090, timeout=0xbfa79adc) at kernel/qguieventdispatcher_glib.cpp:77
#18 0xb2e7d3fa in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#19 0xb2e7dacf in ?? () from /usr/lib/libglib-2.0.so.0
#20 0xb2e7dd31 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#21 0xb59b2891 in QEventDispatcherGlib::processEvents (this=0x9ea8d90, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0xb4e9b4aa in QGuiEventDispatcherGlib::processEvents (this=0x9ea8d90, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#23 0xb597f39c in QEventLoop::processEvents (this=this@entry=0xa007080, flags=...) at kernel/qeventloop.cpp:149
#24 0xb597f691 in QEventLoop::exec (this=0xa007080, flags=...) at kernel/qeventloop.cpp:204
#25 0x08214079 in Digikam::ScanController::databaseInitialization (this=0xa005708) at /usr/src/debug/digikam-3.2.0/core/digikam/database/scancontroller.cpp:425
#26 0x081ea1a9 in Digikam::AlbumManager::setDatabase (this=0x9fe1cc0, params=..., priority=false, suggestedAlbumRoot=...) at /usr/src/debug/digikam-3.2.0/core/digikam/album/albummanager.cpp:717
#27 0x080c4ec9 in main (argc=1, argv=0xbfa7a224) at /usr/src/debug/digikam-3.2.0/core/digikam/main/main.cpp:186

Reported using DrKonqi
Comment 1 caulier.gilles 2013-07-19 08:17:45 UTC
*** Bug 322556 has been marked as a duplicate of this bug. ***
Comment 2 caulier.gilles 2013-08-28 20:51:34 UTC
*** Bug 324183 has been marked as a duplicate of this bug. ***
Comment 3 caulier.gilles 2013-09-01 11:56:12 UTC
*** Bug 324350 has been marked as a duplicate of this bug. ***
Comment 4 Ralph DeWitt 2013-09-13 15:27:28 UTC
The seg fault that I have experienced in bug 324350 was on a fresh NetrunnerOS version 13.06 install (hard drive totally reformatted and data only recovered from backup, no .kde files were restored) my digikam database was verified uncorrupt using sqlite version 3.  My digikam database is at version 4. The installed version of Digikam is 3.3.0, KDE is version 4.11.1 all installed from official repositories. Digikam 3.3.0 is at database version 6. My photo's go back to the 1960's and the tagging is unrecoverable due to poor memory. I desperately need a upgrade solution to my problem.
Comment 5 Kay Muras 2013-09-27 15:37:40 UTC
Created attachment 82515 [details]
New crash information added by DrKonqi

digikam (3.2.0) on KDE Platform 4.10.5 "release 1" using Qt 4.8.4

- What I was doing when the application crashed:I launched digikam, no other application was running

-- Backtrace (Reduced):
#5  0x00007f2e33e17109 in QReadWriteLock::lockForWrite() () from /usr/lib64/libQtCore.so.4
#6  0x00007f2e35b9f154 in Digikam::CollectionScanner::scanFileNormal(QFileInfo const&, Digikam::ItemScanInfo const&) () from /usr/lib64/libdigikamdatabase.so.3
#7  0x00007f2e35ba1b29 in Digikam::CollectionScanner::scanAlbum(Digikam::CollectionLocation const&, QString const&) () from /usr/lib64/libdigikamdatabase.so.3
#8  0x00007f2e35ba1a22 in Digikam::CollectionScanner::scanAlbum(Digikam::CollectionLocation const&, QString const&) () from /usr/lib64/libdigikamdatabase.so.3
#9  0x00007f2e35ba253b in Digikam::CollectionScanner::scanAlbumRoot(Digikam::CollectionLocation const&) () from /usr/lib64/libdigikamdatabase.so.3
Comment 6 caulier.gilles 2013-10-31 07:52:21 UTC
digiKam 3.5.0 is out.

Can you give a fresh feedback about your report ? Crash still reproducible ?

Thanks in advance

Gilles Caulier
Comment 7 Matthias 2013-11-16 19:03:05 UTC
Hello Gilles,
it seems that version 3.5.0 does work, at least it did not mcrash and
the tags of saved in digikam3.db were converted to digikam4.db correctly
as far as I could see.

Thank you,
 Matthias




Am Donnerstag, den 31.10.2013, 07:52 +0000 schrieb Gilles Caulier:
> https://bugs.kde.org/show_bug.cgi?id=321403
> 
> --- Comment #6 from Gilles Caulier <caulier.gilles@gmail.com> ---
> digiKam 3.5.0 is out.
> 
> Can you give a fresh feedback about your report ? Crash still reproducible ?
> 
> Thanks in advance
> 
> Gilles Caulier
>
Comment 8 Jekyll Wu 2014-05-05 01:12:57 UTC
*** Bug 334337 has been marked as a duplicate of this bug. ***