Bug 322556 - Digikam Crash with open Suse 12.3
Summary: Digikam Crash with open Suse 12.3
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Scan (show other bugs)
Version: 3.2.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-19 08:04 UTC by Richard
Modified: 2021-08-26 16:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard 2013-07-19 08:04:06 UTC
Application: digikam (3.2.0)
KDE Platform Version: 4.10.5 "release 1"
Qt Version: 4.8.4
Operating System: Linux 3.7.10-1.16-desktop x86_64
Distribution: "openSUSE 12.3 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Das Programm stürtz ab nach dem Aufruf egal wann ich es starte ob direct nch dem Hochfahren des Systems oder später.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9bdc444800 (LWP 3790))]

Thread 3 (Thread 0x7f9bbd4ec700 (LWP 3791)):
[KCrash Handler]
#5  QReadWriteLock::lockForWrite (this=0x8) at thread/qreadwritelock.cpp:277
#6  0x00007f9bd93f2154 in relock (this=0x7f9bbd4ea8a0) at /usr/include/QtCore/qreadwritelock.h:155
#7  QWriteLocker (areadWriteLock=<optimized out>, this=0x7f9bbd4ea8a0) at /usr/include/QtCore/qreadwritelock.h:175
#8  Digikam::CollectionScanner::scanFileNormal (this=this@entry=0x7f9bbd4eb4e0, fi=..., scanInfo=...) at /usr/src/debug/digikam-3.2.0/core/libs/database/collectionscanner.cpp:1102
#9  0x00007f9bd93f4b29 in Digikam::CollectionScanner::scanAlbum (this=this@entry=0x7f9bbd4eb4e0, location=..., album=...) at /usr/src/debug/digikam-3.2.0/core/libs/database/collectionscanner.cpp:1032
#10 0x00007f9bd93f4a22 in Digikam::CollectionScanner::scanAlbum (this=this@entry=0x7f9bbd4eb4e0, location=..., album=...) at /usr/src/debug/digikam-3.2.0/core/libs/database/collectionscanner.cpp:1066
#11 0x00007f9bd93f553b in Digikam::CollectionScanner::scanAlbumRoot (this=this@entry=0x7f9bbd4eb4e0, location=...) at /usr/src/debug/digikam-3.2.0/core/libs/database/collectionscanner.cpp:785
#12 0x00007f9bd93f57a5 in Digikam::CollectionScanner::completeScan (this=0x7f9bbd4eb4e0) at /usr/src/debug/digikam-3.2.0/core/libs/database/collectionscanner.cpp:452
#13 0x00007f9bd9464a58 in Digikam::SchemaUpdater::updateV4toV6 (this=this@entry=0x7f9bbd4ebb20) at /usr/src/debug/digikam-3.2.0/core/libs/database/schemaupdater.cpp:1108
#14 0x00007f9bd9465c98 in Digikam::SchemaUpdater::makeUpdates (this=this@entry=0x7f9bbd4ebb20) at /usr/src/debug/digikam-3.2.0/core/libs/database/schemaupdater.cpp:438
#15 0x00007f9bd9466a40 in Digikam::SchemaUpdater::startUpdates (this=this@entry=0x7f9bbd4ebb20) at /usr/src/debug/digikam-3.2.0/core/libs/database/schemaupdater.cpp:295
#16 0x00007f9bd9467298 in Digikam::SchemaUpdater::update (this=0x7f9bbd4ebb20) at /usr/src/debug/digikam-3.2.0/core/libs/database/schemaupdater.cpp:143
#17 0x00007f9bd940d8d0 in Digikam::DatabaseBackend::initSchema (this=<optimized out>, updater=<optimized out>) at /usr/src/debug/digikam-3.2.0/core/libs/database/databasebackend.cpp:79
#18 0x00007f9bd94086c2 in Digikam::DatabaseAccess::checkReadyForUse (observer=0x1fdf040) at /usr/src/debug/digikam-3.2.0/core/libs/database/databaseaccess.cpp:303
#19 0x00000000005d8cb1 in Digikam::ScanController::run (this=0x1fdf030) at /usr/src/debug/digikam-3.2.0/core/digikam/database/scancontroller.cpp:722
#20 0x00007f9bd766f0cc in QThreadPrivate::start (arg=0x1fdf030) at thread/qthread_unix.cpp:338
#21 0x00007f9bd3b52e0f in start_thread () from /lib64/libpthread.so.0
#22 0x00007f9bd5bd97dd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f9bbcceb700 (LWP 3792)):
#0  0x00007f9bd5bd0869 in poll () from /lib64/libc.so.6
#1  0x00007f9bcd857aa4 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9bcd857bc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9bd77992e6 in QEventDispatcherGlib::processEvents (this=0x7f9bb00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f9bd7769adf in QEventLoop::processEvents (this=this@entry=0x7f9bbccead50, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f9bd7769d68 in QEventLoop::exec (this=0x7f9bbccead50, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f9bd766c0f0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007f9bd774a29f in QInotifyFileSystemWatcherEngine::run (this=0x1fe26a0) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f9bd766f0cc in QThreadPrivate::start (arg=0x1fe26a0) at thread/qthread_unix.cpp:338
#9  0x00007f9bd3b52e0f in start_thread () from /lib64/libpthread.so.0
#10 0x00007f9bd5bd97dd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f9bdc444800 (LWP 3790)):
#0  0x00007f9bd3b56964 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9bd766f62b in wait (time=18446744073709551615, this=0x1fdf160) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1fdf0e8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9bd766ec9c in QThread::wait (this=<optimized out>, time=18446744073709551615) at thread/qthread_unix.cpp:691
#4  0x00000000005d5915 in Digikam::ScanController::shutDown (this=this@entry=0x1fdf030) at /usr/src/debug/digikam-3.2.0/core/digikam/database/scancontroller.cpp:361
#5  0x00000000005d7d3b in Digikam::ScanController::~ScanController (this=0x1fdf030, __in_chrg=<optimized out>) at /usr/src/debug/digikam-3.2.0/core/digikam/database/scancontroller.cpp:337
#6  0x00000000005d7ee7 in ~ScanControllerCreator (this=0x1fdf030, __in_chrg=<optimized out>) at /usr/src/debug/digikam-3.2.0/core/digikam/database/scancontroller.cpp:277
#7  destroy () at /usr/src/debug/digikam-3.2.0/core/digikam/database/scancontroller.cpp:284
#8  0x00007f9bd5b28f61 in __run_exit_handlers () from /lib64/libc.so.6
#9  0x00007f9bd5b28fe5 in exit () from /lib64/libc.so.6
#10 0x00007f9bd69015b8 in ?? () from /usr/lib64/libQtGui.so.4
#11 0x00007f9bd81ce5d8 in KApplication::xioErrhandler(_XDisplay*) () from /usr/lib64/libkdeui.so.5
#12 0x00007f9bd40e9bce in _XIOError () from /usr/lib64/libX11.so.6
#13 0x00007f9bd40e7bac in _XReply () from /usr/lib64/libX11.so.6
#14 0x00007f9bd40d2524 in XInternAtom () from /usr/lib64/libX11.so.6
#15 0x00007f9bd40e27c2 in XSetWMProtocols () from /usr/lib64/libX11.so.6
#16 0x00007f9bd692c272 in QWidgetPrivate::create_sys(unsigned long, bool, bool) () from /usr/lib64/libQtGui.so.4
#17 0x00007f9bd68df7b1 in QWidget::create(unsigned long, bool, bool) () from /usr/lib64/libQtGui.so.4
#18 0x00007f9bd68dff72 in QWidgetPrivate::createWinId(unsigned long) () from /usr/lib64/libQtGui.so.4
#19 0x00007f9bd68e807b in QWidget::winId() const () from /usr/lib64/libQtGui.so.4
#20 0x00007f9bd824421b in KXMessages::broadcastMessage(char const*, QString const&, int, bool) () from /usr/lib64/libkdeui.so.5
#21 0x00007f9bd81e99df in KStartupInfo::sendFinish(KStartupInfoId const&) () from /usr/lib64/libkdeui.so.5
#22 0x00007f9bd81e9aba in KStartupInfo::appStarted(QByteArray const&) () from /usr/lib64/libkdeui.so.5
#23 0x00007f9bd81e9b56 in KStartupInfo::appStarted() () from /usr/lib64/libkdeui.so.5
#24 0x00007f9bd778029f in QMetaObject::activate (sender=0x2011ff0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3548
#25 0x00007f9bd777f5ac in QObject::event (this=0x2011ff0, e=<optimized out>) at kernel/qobject.cpp:1165
#26 0x00007f9bd689786c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#27 0x00007f9bd689bceb in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/libQtGui.so.4
#28 0x00007f9bd81cf7f6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#29 0x00007f9bd776ad8e in QCoreApplication::notifyInternal (this=0x7fff3c9fc2a0, receiver=0x2011ff0, event=0x7fff3c9fb460) at kernel/qcoreapplication.cpp:946
#30 0x00007f9bd779bb61 in sendEvent (event=0x7fff3c9fb460, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#31 QTimerInfoList::activateTimers (this=0x1e2d6a0) at kernel/qeventdispatcher_unix.cpp:637
#32 0x00007f9bd7798c54 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#33 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#34 0x00007f9bcd8577d5 in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#35 0x00007f9bcd857b08 in ?? () from /usr/lib64/libglib-2.0.so.0
#36 0x00007f9bcd857bc4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#37 0x00007f9bd77992c6 in QEventDispatcherGlib::processEvents (this=0x1e2b070, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#38 0x00007f9bd6937c1e in ?? () from /usr/lib64/libQtGui.so.4
#39 0x00007f9bd7769adf in QEventLoop::processEvents (this=this@entry=0x1fccd80, flags=...) at kernel/qeventloop.cpp:149
#40 0x00007f9bd7769d68 in QEventLoop::exec (this=0x1fccd80, flags=...) at kernel/qeventloop.cpp:204
#41 0x00000000005d6d6b in Digikam::ScanController::databaseInitialization (this=0x1fdf030) at /usr/src/debug/digikam-3.2.0/core/digikam/database/scancontroller.cpp:425
#42 0x00000000005ae88e in Digikam::AlbumManager::setDatabase (this=0x1fb5eb0, params=..., priority=<optimized out>, suggestedAlbumRoot=...) at /usr/src/debug/digikam-3.2.0/core/digikam/album/albummanager.cpp:717
#43 0x000000000049ac0f in main (argc=5, argv=0x7fff3c9fc4d8) at /usr/src/debug/digikam-3.2.0/core/digikam/main/main.cpp:186

This bug may be a duplicate of or related to bug 321403.

Possible duplicates by query: bug 321403.

Reported using DrKonqi
Comment 1 caulier.gilles 2013-07-19 08:17:45 UTC

*** This bug has been marked as a duplicate of bug 321403 ***
Comment 2 caulier.gilles 2021-08-26 16:55:27 UTC
Fixed with #321403