Bug 322346 - missing attachment flags
Summary: missing attachment flags
Status: RESOLVED DUPLICATE of bug 291332
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: IMAP resource (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Christian Mollekopf
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-07-14 12:57 UTC by Samuele Carcagno
Modified: 2013-11-20 10:58 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuele Carcagno 2013-07-14 12:57:49 UTC
I'm opening here a bug that was originally opened on kmail2 (Bug 292399).

https://bugs.kde.org/show_bug.cgi?id=292399

Kmail 2 almost never shows attachment icons on IMAP accounts. Not clear whether the problem lies in kmail2 or the IMAP backend (see bug 292399 discussion). Many people would like to see this solved as it represents a major usability issue (it is impossible to filter emails according to whether they have an attachment or not). 

Reproducible: Always
Comment 1 Ivan S. J. 2013-07-18 12:21:24 UTC
I can reproduce the bug, or at least an interesting variant of it:
If I receive an email with multipart/mixed, containing text/plain and a image/png on an IMAP server (MS exhange if that matters), then before it is automatically retrieved do a manual refresh (ctrl-L) to see the new message in the list, then the paperclip appears on the new email. If I do a refresh (ctrl-L) again the paperclip disappears. It never reappears.
Comment 2 Wolfgang Bauer 2013-07-18 14:09:31 UTC
I think this has the same cause as https://bugs.kde.org/show_bug.cgi?id=318108 and https://bugs.kde.org/show_bug.cgi?id=281853

I.e. your IMAP server doesn't support akonadi's $ATTACHMENT flag and therefore doesn't store it. So after a resynchronization it disappears.
Comment 3 Kevin Ottens 2013-11-16 07:30:57 UTC
The IMAP resource has a new maintainer, reassigning to him.
Comment 4 Christian Mollekopf 2013-11-20 10:58:41 UTC

*** This bug has been marked as a duplicate of bug 291332 ***