Bug 281853 - Kmail2: Sent Emails are not forwarded to the server side
Summary: Kmail2: Sent Emails are not forwarded to the server side
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 4.8.3
Platform: Ubuntu Linux
: NOR major with 60 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-09-12 08:10 UTC by Hatem Masmoudi
Modified: 2014-01-17 23:02 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.3


Attachments
BAD Protocol (35.19 KB, image/png)
2011-12-12 17:54 UTC, Hatem Masmoudi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hatem Masmoudi 2011-09-12 08:10:43 UTC
Version:           unspecified (using KDE 4.7.1) 
OS:                Linux

KMAL2 : Sent Emails are not forwarded to the server side even if sent email are defined to be in registred Imap Folder

Reproducible: Didn't try

Steps to Reproduce:
- Define in personel information, in advanced option, that the sent email will be in the server side : IMAP/Sent Email - IMAP/éléments Envoyés
- Send emails
- Check locally in the folder : emails are there
- check in the server side, emails are not formwarded to the server side : the IMAP/Sent Email or IMAP/éléments Envoyés doesn't contains the new sent emails !!

Actual Results:  
emails are present only locally

Expected Results:  
Emails must be forwarded also on the server side.
Comment 1 Hatem Masmoudi 2011-09-20 07:31:17 UTC
- I try to create another folder in the server side named "Sent"
- I copied all messages from my "Sent Email" to that folder
- The Emails that are not forwarded to the server (described in commented up) are always present locally only and not copied to the server on the New Sent folder!!
Comment 2 Hatem Masmoudi 2011-09-20 07:31:54 UTC
Reproducible: Always
Comment 3 Danilo V 2011-10-04 08:34:33 UTC
I have exactly the same problem since the first early versions of Kmail2.

- If I move an email manually to the IMAP/sent folder, it shows up correctly on the server.
- If I set under Identity->Advanced to use IMAP/Sent for sent emails, I can see them only locally, but NOT on the server.
Comment 4 Rigo Wenning 2011-12-06 17:01:03 UTC
Please also see https://bugs.kde.org/show_bug.cgi?id=284310 It may be that the email is on the server but that kmail2/akonadi isn't showing it. I have the same setup and commented in the other bug.
Comment 5 Hatem Masmoudi 2011-12-12 17:45:04 UTC
Comment #4
After sending an email I checked directly on server side (Using WebMail) and I can't found sent emails. The emails are showed only locally (Sent folder on imap account) on kmail : sent from kmail and sent using webmail.
Comment 6 Hatem Masmoudi 2011-12-12 17:54:18 UTC
Created attachment 66669 [details]
BAD Protocol

May be the problem comes form the following error.
Comment 7 Hatem Masmoudi 2011-12-12 18:01:52 UTC
Some behavious of https://bugs.kde.org/show_bug.cgi?id=278082

But I have A011833 BAD Protocol Error.Specified set of flag is not valid.
Comment 8 Hatem Masmoudi 2012-01-23 14:25:42 UTC
Still present in version (4.8 RC2 (4.7.97)
Comment 9 Rigo Wenning 2012-01-23 15:48:14 UTC
I installed a fresh OpenSuse 12.1 with KDE 4.7.4 (4.7.4) "release 11" and I don't have that issue anymore. So this is possibly a bug in the config files in .kde4 

Best, 

Rigo
Comment 10 Hatem Masmoudi 2012-01-23 16:05:49 UTC
I checked using the following distributions:
- Kubuntu 11.10
- Fedora 16 Kde Descktop
- Opensuse 12.1
- Kubuntu 12.04 LTS (Dev)

I'm connecting to MS exchange server 2003.
I checked that I correctly set the defaul sent email to the write exchange folder but I get some time error like (BAD Protocol...)

are there any file taht I can join to the issue ?
Comment 11 Hatem Masmoudi 2012-01-23 16:16:38 UTC
After sending I get the following error:
"Append Failed, server replied: A000056 Protocol Error: Specified set of flags is not valid."
Comment 12 jammer 2012-06-26 01:39:17 UTC
Confirming this is still an issue on:

1) OpenSUSE 12.1 - KDE 4.8.3
2) Chakra Archimedes 2012.05.10 - KDE 4.8.3

Also connecting to an MS Exchange server 2003
Is anyone looking into this problem ? 
This was working prior to updating to v4.8.X
Comment 13 Hatem Masmoudi 2012-09-14 20:28:26 UTC
Any progress on this annoying issue? this issue is still present on version kde 4.9.1.
Comment 14 Laurent Montel 2012-09-15 10:50:22 UTC
Will look at soon.
Comment 15 Vasek Smidl 2012-10-24 09:28:46 UTC
I have a similar issue with axigen server.

After some googling I found a similar problem with possible explanation due to number of allowed IMAP connections:
http://www.axigen.com/forum/showthread.php?t=9454

The solution there worked for the reporter. I can not test it here, can anyone increase the number of allowed connection in their setup?

Is it possible that KMail tries to open anothe IMAP connection when moving files to the sent folder?
Comment 16 Wolfgang Bauer 2013-05-27 22:13:04 UTC
*** This bug has been confirmed by popular vote. ***
Comment 17 Carlo Alberto Sanjust 2013-09-04 11:45:55 UTC
Probably related to: https://bugs.kde.org/show_bug.cgi?id=291332
Comment 18 Wolfgang Bauer 2013-10-03 10:08:07 UTC
I had this problem with one of my IMAP accounts (sent emails were not forwarded to the server because of the $SENT flag akonadi sets), but this commit fixes it for me:
https://projects.kde.org/projects/kde/kdepim-runtime/repository/revisions/c561149538336804f212f5a12ea6cf3d1a3a19f5

So this should work in 4.11.3...
Comment 19 Allen Winter 2013-10-03 17:17:41 UTC
then let's resolve as fixed in 4.11.3