Bug 319762 - Starting up crashes
Summary: Starting up crashes
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Scan (show other bugs)
Version: 3.1.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-13 04:18 UTC by Axel Krebs
Modified: 2021-08-26 09:27 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Krebs 2013-05-13 04:18:20 UTC
Application: digikam (3.1.0)
KDE Platform Version: 4.10.3
Qt Version: 4.8.4
Operating System: Linux 3.8.0-20-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:

digiKam repatedly crashes just before opening the first appearance

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Floating point exception
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f53b5a4ca40 (LWP 4059))]

Thread 4 (Thread 0x7f538d7f5700 (LWP 4060)):
[KCrash Handler]
#6  0x00007f53b0e7f288 in read_dib_body (s=..., bi=..., offset=138, startpos=0, image=...) at image/qbmphandler.cpp:322
#7  0x00007f53b0e8077c in QBmpHandler::read (this=0x7f538808a690, image=0x7f538d7f3de0) at image/qbmphandler.cpp:770
#8  0x00007f53b0e57f0d in QImageReader::read (this=this@entry=0x7f538d7f3e40, image=image@entry=0x7f538d7f3de0) at image/qimagereader.cpp:1205
#9  0x00007f53b0e5845f in QImageReader::read (this=this@entry=0x7f538d7f3e40) at image/qimagereader.cpp:1155
#10 0x00007f53b0e4c9d1 in QImage::load (this=this@entry=0x7f538d7f3f80, fileName=..., format=format@entry=0x0) at image/qimage.cpp:5094
#11 0x00007f53b0e4cb95 in QImage::QImage (this=0x7f538d7f3f80, fileName=..., format=0x0) at image/qimage.cpp:995
#12 0x00007f53b31491d9 in Digikam::QImageLoader::load (this=this@entry=0x7f538d7f4290, filePath=..., observer=observer@entry=0x0) at /build/buildd/digikam-3.1.0/core/libs/dimg/loaders/qimageloader.cpp:55
#13 0x00007f53b311cf9c in Digikam::DImg::load (this=this@entry=0x7f53882a3fe0, filePath=..., loadFlagsInt=loadFlagsInt@entry=1, observer=observer@entry=0x0, rawDecodingSettings=...) at /build/buildd/digikam-3.1.0/core/libs/dimg/dimg.cpp:558
#14 0x00007f53b311e6c5 in Digikam::DImg::loadImageInfo (this=this@entry=0x7f53882a3fe0, filePath=..., loadMetadata=loadMetadata@entry=false, loadICCData=loadICCData@entry=false, loadUniqueHash=loadUniqueHash@entry=false, loadImageHistory=loadImageHistory@entry=false) at /build/buildd/digikam-3.1.0/core/libs/dimg/dimg.cpp:370
#15 0x00007f53b2cfff29 in Digikam::ImageScanner::loadFromDisk (this=this@entry=0x7f538d7f4650) at /build/buildd/digikam-3.1.0/core/libs/database/imagescanner.cpp:1460
#16 0x00007f53b2d000e8 in Digikam::ImageScanner::newFile (this=this@entry=0x7f538d7f4650, albumId=albumId@entry=2672) at /build/buildd/digikam-3.1.0/core/libs/database/imagescanner.cpp:260
#17 0x00007f53b2ca5d10 in Digikam::CollectionScanner::scanNewFile (this=this@entry=0x7f538d7f4ad0, info=..., albumId=2672) at /build/buildd/digikam-3.1.0/core/libs/database/collectionscanner.cpp:1059
#18 0x00007f53b2ca91e1 in Digikam::CollectionScanner::scanAlbum (this=this@entry=0x7f538d7f4ad0, location=..., album=...) at /build/buildd/digikam-3.1.0/core/libs/database/collectionscanner.cpp:905
#19 0x00007f53b2ca9bab in Digikam::CollectionScanner::scanAlbumRoot (this=this@entry=0x7f538d7f4ad0, location=...) at /build/buildd/digikam-3.1.0/core/libs/database/collectionscanner.cpp:660
#20 0x00007f53b2caa470 in Digikam::CollectionScanner::finishCompleteScan (this=this@entry=0x7f538d7f4ad0, albumPaths=...) at /build/buildd/digikam-3.1.0/core/libs/database/collectionscanner.cpp:407
#21 0x00000000005cc727 in Digikam::ScanController::run (this=0x107b630) at /build/buildd/digikam-3.1.0/core/digikam/database/scancontroller.cpp:770
#22 0x00007f53b02a9bec in QThreadPrivate::start (arg=0x107b630) at thread/qthread_unix.cpp:338
#23 0x00007f53aa7d6f8e in start_thread (arg=0x7f538d7f5700) at pthread_create.c:311
#24 0x00007f53af4c6e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f538cff4700 (LWP 4061)):
#0  0x00007f53af4ba3cd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f53a80361dc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f53a8036304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f53b03d5036 in QEventDispatcherGlib::processEvents (this=0x7f53800008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f53b03a538f in QEventLoop::processEvents (this=this@entry=0x7f538cff3b10, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f53b03a5618 in QEventLoop::exec (this=this@entry=0x7f538cff3b10, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f53b02a7410 in QThread::exec (this=this@entry=0x103cb70) at thread/qthread.cpp:542
#7  0x00007f53b0386edf in QInotifyFileSystemWatcherEngine::run (this=0x103cb70) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f53b02a9bec in QThreadPrivate::start (arg=0x103cb70) at thread/qthread_unix.cpp:338
#9  0x00007f53aa7d6f8e in start_thread (arg=0x7f538cff4700) at pthread_create.c:311
#10 0x00007f53af4c6e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f537aa44700 (LWP 4066)):
#0  0x00007f53af4ba3cd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f53a80361dc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f53a8036304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f53b03d5036 in QEventDispatcherGlib::processEvents (this=0x7f53740008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f53b03a538f in QEventLoop::processEvents (this=this@entry=0x7f537aa43b10, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f53b03a5618 in QEventLoop::exec (this=this@entry=0x7f537aa43b10, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f53b02a7410 in QThread::exec (this=this@entry=0x178ef70) at thread/qthread.cpp:542
#7  0x00007f53b0386edf in QInotifyFileSystemWatcherEngine::run (this=0x178ef70) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f53b02a9bec in QThreadPrivate::start (arg=0x178ef70) at thread/qthread_unix.cpp:338
#9  0x00007f53aa7d6f8e in start_thread (arg=0x7f537aa44700) at pthread_create.c:311
#10 0x00007f53af4c6e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f53b5a4ca40 (LWP 4059)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f53b02aa14b in wait (time=18446744073709551615, this=0x106e8d0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x106e880, mutex=0x106e858, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f53b02a97bc in QThread::wait (this=this@entry=0x107b630, time=time@entry=18446744073709551615) at thread/qthread_unix.cpp:691
#4  0x00000000005c8165 in Digikam::ScanController::shutDown (this=this@entry=0x107b630) at /build/buildd/digikam-3.1.0/core/digikam/database/scancontroller.cpp:351
#5  0x00000000005cbe9b in Digikam::ScanController::~ScanController (this=0x107b630, __in_chrg=<optimized out>) at /build/buildd/digikam-3.1.0/core/digikam/database/scancontroller.cpp:328
#6  0x00000000005cc087 in ~ScanControllerCreator (this=0x107b630, __in_chrg=<optimized out>) at /build/buildd/digikam-3.1.0/core/digikam/database/scancontroller.cpp:268
#7  destroy () at /build/buildd/digikam-3.1.0/core/digikam/database/scancontroller.cpp:275
#8  0x00007f53af409121 in __run_exit_handlers (status=1, listp=0x7f53af78e6a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
#9  0x00007f53af4091a5 in __GI_exit (status=<optimized out>) at exit.c:99
#10 0x00007f53b0df9348 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:782
#11 0x00007f53b1a98888 in KApplication::xioErrhandler (this=0x7fffb8151c30, dpy=0xf5d480) at ../../kdeui/kernel/kapplication.cpp:419
#12 0x00007f53ad9da6de in _XIOError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#13 0x00007f53ad9d816d in _XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#14 0x00007f53ad9b96ea in XFlush () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#15 0x00007f53b0dd86e0 in QWidget::unsetCursor (this=0x17f0650) at kernel/qwidget.cpp:5137
#16 0x00007f53b4a18695 in KHTMLView::clear (this=0x17f3de0) at ../../khtml/khtmlview.cpp:627
#17 0x00007f53b4a3d4ad in KHTMLPart::clear (this=this@entry=0x17a4030) at ../../khtml/khtml_part.cpp:1535
#18 0x00007f53b4a48740 in KHTMLPart::begin (this=0x17a4030, url=..., xOffset=0, yOffset=0) at ../../khtml/khtml_part.cpp:2014
#19 0x000000000065ca2e in Digikam::WelcomePageView::slotThemeChanged (this=0x17a4030) at /build/buildd/digikam-3.1.0/core/digikam/views/welcomepageview.cpp:242
#20 0x00007f53b03c05be in QObject::event (this=0x17a4030, e=<optimized out>) at kernel/qobject.cpp:1194
#21 0x00007f53b0d8f8ec in QApplicationPrivate::notify_helper (this=this@entry=0xf25e30, receiver=receiver@entry=0x17a4030, e=e@entry=0xe464a80) at kernel/qapplication.cpp:4567
#22 0x00007f53b0d9225b in QApplication::notify (this=this@entry=0x7fffb8151c30, receiver=receiver@entry=0x17a4030, e=e@entry=0xe464a80) at kernel/qapplication.cpp:4428
#23 0x00007f53b1a9caf6 in KApplication::notify (this=0x7fffb8151c30, receiver=0x17a4030, event=0xe464a80) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f53b03a663e in QCoreApplication::notifyInternal (this=0x7fffb8151c30, receiver=receiver@entry=0x17a4030, event=event@entry=0xe464a80) at kernel/qcoreapplication.cpp:946
#25 0x00007f53b03aa171 in sendEvent (event=0xe464a80, receiver=0x17a4030) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0, data=0xeaebc0) at kernel/qcoreapplication.cpp:1570
#27 0x00007f53b03aa4a3 in QCoreApplication::sendPostedEvents (receiver=receiver@entry=0x0, event_type=event_type@entry=0) at kernel/qcoreapplication.cpp:1463
#28 0x00007f53b03d4e83 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#29 postEventSourceDispatch (s=0xf35140) at kernel/qeventdispatcher_glib.cpp:279
#30 0x00007f53a8035f05 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f53a8036248 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f53a8036304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007f53b03d5016 in QEventDispatcherGlib::processEvents (this=0xeb00b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#34 0x00007f53b0e351ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007f53b03a538f in QEventLoop::processEvents (this=this@entry=0x7fffb8151620, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007f53b03a5618 in QEventLoop::exec (this=this@entry=0x7fffb8151620, flags=...) at kernel/qeventloop.cpp:204
#37 0x00007f53b03aacf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#38 0x00007f53b0d8dffc in QApplication::exec () at kernel/qapplication.cpp:3828
#39 0x000000000048f9ab in main (argc=1, argv=0x7fffb8151e68) at /build/buildd/digikam-3.1.0/core/digikam/main/main.cpp:235

Possible duplicates by query: bug 319655, bug 319605, bug 319415, bug 310798.

Reported using DrKonqi
Comment 1 caulier.gilles 2013-05-13 04:39:31 UTC

*** This bug has been marked as a duplicate of bug 310798 ***
Comment 2 caulier.gilles 2021-08-26 09:27:55 UTC
Fixed with #310798