Bug 319605 - crashes while starting up
Summary: crashes while starting up
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Scan (show other bugs)
Version: 3.1.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-10 06:41 UTC by Axel Krebs
Modified: 2021-08-26 09:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.4.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Krebs 2013-05-10 06:41:54 UTC
Application: digikam (3.1.0)
KDE Platform Version: 4.10.2
Qt Version: 4.8.4
Operating System: Linux 3.8.0-20-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:

Starting up digiKam
after a while, digiKam crashes in background- without interfering causes

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Floating point exception
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
[Current thread is 1 (Thread 0x7f11d0da6a40 (LWP 9144))]

Thread 4 (Thread 0x7f11a8b4f700 (LWP 9207)):
[KCrash Handler]
#6  0x00007f11cc1d9288 in read_dib_body (s=..., bi=..., offset=138, startpos=0, image=...) at image/qbmphandler.cpp:322
#7  0x00007f11cc1da77c in QBmpHandler::read (this=0x7f11a41179e0, image=0x7f11a8b4dde0) at image/qbmphandler.cpp:770
#8  0x00007f11cc1b1f0d in QImageReader::read (this=this@entry=0x7f11a8b4de40, image=image@entry=0x7f11a8b4dde0) at image/qimagereader.cpp:1205
#9  0x00007f11cc1b245f in QImageReader::read (this=this@entry=0x7f11a8b4de40) at image/qimagereader.cpp:1155
#10 0x00007f11cc1a69d1 in QImage::load (this=this@entry=0x7f11a8b4df80, fileName=..., format=format@entry=0x0) at image/qimage.cpp:5094
#11 0x00007f11cc1a6b95 in QImage::QImage (this=0x7f11a8b4df80, fileName=..., format=0x0) at image/qimage.cpp:995
#12 0x00007f11ce4a31d9 in Digikam::QImageLoader::load (this=this@entry=0x7f11a8b4e290, filePath=..., observer=observer@entry=0x0) at /build/buildd/digikam-3.1.0/core/libs/dimg/loaders/qimageloader.cpp:55
#13 0x00007f11ce476f9c in Digikam::DImg::load (this=this@entry=0x7f11a4279990, filePath=..., loadFlagsInt=loadFlagsInt@entry=1, observer=observer@entry=0x0, rawDecodingSettings=...) at /build/buildd/digikam-3.1.0/core/libs/dimg/dimg.cpp:558
#14 0x00007f11ce4786c5 in Digikam::DImg::loadImageInfo (this=this@entry=0x7f11a4279990, filePath=..., loadMetadata=loadMetadata@entry=false, loadICCData=loadICCData@entry=false, loadUniqueHash=loadUniqueHash@entry=false, loadImageHistory=loadImageHistory@entry=false) at /build/buildd/digikam-3.1.0/core/libs/dimg/dimg.cpp:370
#15 0x00007f11ce059f29 in Digikam::ImageScanner::loadFromDisk (this=this@entry=0x7f11a8b4e650) at /build/buildd/digikam-3.1.0/core/libs/database/imagescanner.cpp:1460
#16 0x00007f11ce05a0e8 in Digikam::ImageScanner::newFile (this=this@entry=0x7f11a8b4e650, albumId=albumId@entry=2672) at /build/buildd/digikam-3.1.0/core/libs/database/imagescanner.cpp:260
#17 0x00007f11cdfffd10 in Digikam::CollectionScanner::scanNewFile (this=this@entry=0x7f11a8b4ead0, info=..., albumId=2672) at /build/buildd/digikam-3.1.0/core/libs/database/collectionscanner.cpp:1059
#18 0x00007f11ce0031e1 in Digikam::CollectionScanner::scanAlbum (this=this@entry=0x7f11a8b4ead0, location=..., album=...) at /build/buildd/digikam-3.1.0/core/libs/database/collectionscanner.cpp:905
#19 0x00007f11ce003bab in Digikam::CollectionScanner::scanAlbumRoot (this=this@entry=0x7f11a8b4ead0, location=...) at /build/buildd/digikam-3.1.0/core/libs/database/collectionscanner.cpp:660
#20 0x00007f11ce004470 in Digikam::CollectionScanner::finishCompleteScan (this=this@entry=0x7f11a8b4ead0, albumPaths=...) at /build/buildd/digikam-3.1.0/core/libs/database/collectionscanner.cpp:407
#21 0x00000000005cc727 in Digikam::ScanController::run (this=0x281b700) at /build/buildd/digikam-3.1.0/core/digikam/database/scancontroller.cpp:770
#22 0x00007f11cb603bec in QThreadPrivate::start (arg=0x281b700) at thread/qthread_unix.cpp:338
#23 0x00007f11c5b30f8e in start_thread (arg=0x7f11a8b4f700) at pthread_create.c:311
#24 0x00007f11ca820e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f11a3fff700 (LWP 9208)):
#0  0x00007f11ca812b0d in read () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f11c33ce6cf in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f11c338fd3c in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f11c3390175 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f11c3390304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f11cb72f036 in QEventDispatcherGlib::processEvents (this=0x7f119c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f11cb6ff38f in QEventLoop::processEvents (this=this@entry=0x7f11a3ffeb10, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f11cb6ff618 in QEventLoop::exec (this=this@entry=0x7f11a3ffeb10, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f11cb601410 in QThread::exec (this=this@entry=0x2805fe0) at thread/qthread.cpp:542
#9  0x00007f11cb6e0edf in QInotifyFileSystemWatcherEngine::run (this=0x2805fe0) at io/qfilesystemwatcher_inotify.cpp:256
#10 0x00007f11cb603bec in QThreadPrivate::start (arg=0x2805fe0) at thread/qthread_unix.cpp:338
#11 0x00007f11c5b30f8e in start_thread (arg=0x7f11a3fff700) at pthread_create.c:311
#12 0x00007f11ca820e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f1199e0d700 (LWP 11848)):
#0  0x00007f11ca8143cd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f11c33901dc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f11c3390304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f11cb72f036 in QEventDispatcherGlib::processEvents (this=0x7f11900008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f11cb6ff38f in QEventLoop::processEvents (this=this@entry=0x7f1199e0cb10, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f11cb6ff618 in QEventLoop::exec (this=this@entry=0x7f1199e0cb10, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f11cb601410 in QThread::exec (this=this@entry=0x31c2ca0) at thread/qthread.cpp:542
#7  0x00007f11cb6e0edf in QInotifyFileSystemWatcherEngine::run (this=0x31c2ca0) at io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f11cb603bec in QThreadPrivate::start (arg=0x31c2ca0) at thread/qthread_unix.cpp:338
#9  0x00007f11c5b30f8e in start_thread (arg=0x7f1199e0d700) at pthread_create.c:311
#10 0x00007f11ca820e1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f11d0da6a40 (LWP 9144)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:185
#1  0x00007f11cb60414b in wait (time=18446744073709551615, this=0x28163c0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=this@entry=0x281c210, mutex=0x281c1e8, time=time@entry=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f11cb6037bc in QThread::wait (this=this@entry=0x281b700, time=time@entry=18446744073709551615) at thread/qthread_unix.cpp:691
#4  0x00000000005c8165 in Digikam::ScanController::shutDown (this=this@entry=0x281b700) at /build/buildd/digikam-3.1.0/core/digikam/database/scancontroller.cpp:351
#5  0x00000000005cbe9b in Digikam::ScanController::~ScanController (this=0x281b700, __in_chrg=<optimized out>) at /build/buildd/digikam-3.1.0/core/digikam/database/scancontroller.cpp:328
#6  0x00000000005cc087 in ~ScanControllerCreator (this=0x281b700, __in_chrg=<optimized out>) at /build/buildd/digikam-3.1.0/core/digikam/database/scancontroller.cpp:268
#7  destroy () at /build/buildd/digikam-3.1.0/core/digikam/database/scancontroller.cpp:275
#8  0x00007f11ca763121 in __run_exit_handlers (status=1, listp=0x7f11caae86a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
#9  0x00007f11ca7631a5 in __GI_exit (status=<optimized out>) at exit.c:99
#10 0x00007f11cc153348 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:782
#11 0x00007f11ccdf2888 in KApplication::xioErrhandler (this=0x7fff0f195240, dpy=0x27257f0) at ../../kdeui/kernel/kapplication.cpp:419
#12 0x00007f11c8d346de in _XIOError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#13 0x00007f11c8d326ac in _XReply () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#14 0x00007f11c8d28279 in XQueryPointer () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#15 0x00007f11cc16f5bf in QCursor::pos () at kernel/qcursor_x11.cpp:162
#16 0x00000000005feaa8 in Digikam::ImageCategorizedView::slotDelayedEnter (this=0x31d41f0) at /build/buildd/digikam-3.1.0/core/digikam/items/imagecategorizedview.cpp:580
#17 0x00000000005ffc7d in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at /build/buildd/digikam-3.1.0/obj-x86_64-linux-gnu/core/digikam/imagecategorizedview.moc:95
#18 Digikam::ImageCategorizedView::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at /build/buildd/digikam-3.1.0/obj-x86_64-linux-gnu/core/digikam/imagecategorizedview.moc:74
#19 0x00007f11cb7150ef in QMetaObject::activate (sender=0x31d9fa0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#20 0x00007f11cb71a3ec in QObject::event (this=0x31d9fa0, e=<optimized out>) at kernel/qobject.cpp:1156
#21 0x00007f11cc0e98ec in QApplicationPrivate::notify_helper (this=this@entry=0x26ea4e0, receiver=receiver@entry=0x31d9fa0, e=e@entry=0x7fff0f1949c0) at kernel/qapplication.cpp:4567
#22 0x00007f11cc0ec25b in QApplication::notify (this=this@entry=0x7fff0f195240, receiver=receiver@entry=0x31d9fa0, e=e@entry=0x7fff0f1949c0) at kernel/qapplication.cpp:4428
#23 0x00007f11ccdf6af6 in KApplication::notify (this=0x7fff0f195240, receiver=0x31d9fa0, event=0x7fff0f1949c0) at ../../kdeui/kernel/kapplication.cpp:311
#24 0x00007f11cb70063e in QCoreApplication::notifyInternal (this=0x7fff0f195240, receiver=0x31d9fa0, event=event@entry=0x7fff0f1949c0) at kernel/qcoreapplication.cpp:946
#25 0x00007f11cb731b72 in sendEvent (event=0x7fff0f1949c0, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#26 QTimerInfoList::activateTimers (this=0x26fdaa0) at kernel/qeventdispatcher_unix.cpp:622
#27 0x00007f11cb72e9a4 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:186
#28 timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:180
#29 0x00007f11c338ff05 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#30 0x00007f11c3390248 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#31 0x00007f11c3390304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007f11cb72f016 in QEventDispatcherGlib::processEvents (this=0x26780b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#33 0x00007f11cc18f1ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f11cb6ff38f in QEventLoop::processEvents (this=this@entry=0x7fff0f194c30, flags=...) at kernel/qeventloop.cpp:149
#35 0x00007f11cb6ff618 in QEventLoop::exec (this=this@entry=0x7fff0f194c30, flags=...) at kernel/qeventloop.cpp:204
#36 0x00007f11cb704cf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#37 0x00007f11cc0e7ffc in QApplication::exec () at kernel/qapplication.cpp:3828
#38 0x000000000048f9ab in main (argc=5, argv=0x7fff0f195478) at /build/buildd/digikam-3.1.0/core/digikam/main/main.cpp:235

Possible duplicates by query: bug 319415, bug 310798.

Reported using DrKonqi
Comment 1 caulier.gilles 2013-05-10 07:17:45 UTC

*** This bug has been marked as a duplicate of bug 310798 ***
Comment 2 caulier.gilles 2021-08-26 09:22:13 UTC
Fixed with #310798