Bug 318921 - Excessive widget size limits - LCD Weather
Summary: Excessive widget size limits - LCD Weather
Status: RESOLVED UNMAINTAINED
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-weather (show other bugs)
Version: 4.10.2
Platform: Other Linux
: NOR minor
Target Milestone: ---
Assignee: Plasma Bugs List
URL: http://i44.tinypic.com/16jqx4.jpg
Keywords:
: 316799 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-04-26 12:17 UTC by Mircea Kitsune
Modified: 2018-06-08 19:49 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mircea Kitsune 2013-04-26 12:17:17 UTC
I recently posted my belief that several plasma widget have size limits which are too big, making them difficult or impossible to use due to the space they take on the desktop. http://forum.kde.org/viewtopic.php?f=73&t=110386 As advised, I'm making a ticket for each plasmoid which I believe to have excessive size limits which should be lowered.

This one is for the LCD Weather widget. Although its minimal size was good in KDE 4.9.5, it's been pushed to higher amounts starting from KDE 4.10.0 (which caused me to have to remove it from my desktop). I'm not sure why the old size limit was considered too much, but I believe something at least halfway between the old and new limit should be used. At a resolution of 1680 x 1050, the widget takes nearly 1 / 3 of the screen vertically, which is a huge amount.

Here is a screenshot showing the widget at its minimum allowed size: http://i44.tinypic.com/16jqx4.jpg

Reproducible: Always
Comment 1 Mircea Kitsune 2013-04-26 12:19:36 UTC
*** Bug 316799 has been marked as a duplicate of this bug. ***
Comment 2 Mircea Kitsune 2013-04-26 12:36:59 UTC
Here is a list of all widgets reported in this set, in case anyone's interested in related issues:

Excessive widget size limits - System Monitor: https://bugs.kde.org/show_bug.cgi?id=318919

Excessive widget size limits - Weather Forecast: https://bugs.kde.org/show_bug.cgi?id=318920

Excessive widget size limits - LCD Weather: https://bugs.kde.org/show_bug.cgi?id=318921

Excessive widget size limits - Shelf: https://bugs.kde.org/show_bug.cgi?id=318922

Excessive widget size limits - Calendar: https://bugs.kde.org/show_bug.cgi?id=318923
Comment 3 Nate Graham 2018-06-08 19:49:17 UTC
Hello!

This bug report was filed for KDE Plasma 4, which reached end-of-support status in August 2015. KDE Plasma 5's desktop shell has been almost completely rewritten for better performance and usability, so it is likely that this bug is already resolved in Plasma 5.

Accordingly, we hope you understand why we must close this bug report. If the issue described  here is still present in KDE Plasma 5.12 or later, please feel free to open a new ticket in the "plasmashell" product after reading https://community.kde.org/Get_Involved/Bug_Reporting

If you would like to get involved in KDE's bug triaging effort so that future mass bug closes like this are less likely, please read https://community.kde.org/Get_Involved#Bug_Triaging

Thanks for your understanding!

Nate Graham