Bug 318922 - Excessive widget size limits - Shelf
Summary: Excessive widget size limits - Shelf
Status: RESOLVED INTENTIONAL
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-shelf (show other bugs)
Version: 4.10.2
Platform: Other Linux
: NOR minor
Target Milestone: ---
Assignee: Ivan Čukić
URL: http://i42.tinypic.com/2hzmpae.jpg
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-26 12:24 UTC by Mircea Kitsune
Modified: 2014-05-22 22:10 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mircea Kitsune 2013-04-26 12:24:38 UTC
I recently posted my belief that several plasma widget have size limits which are too big, making them difficult or impossible to use due to the space they take on the desktop. http://forum.kde.org/viewtopic.php?f=73&t=110386 As advised, I'm making a ticket for each plasmoid which I believe to have excessive size limits which should be lowered.

This one is for the Shelf widget. While in its case the size limit is pretty sane and ok, I believe it could be made a bit smaller horizontally. Here is a screenshot showing its minimal size... you can see there's wasted space to the right and overall it could get tinier without breaking anything: http://i42.tinypic.com/2hzmpae.jpg

Reproducible: Always
Comment 1 Mircea Kitsune 2013-04-26 12:37:04 UTC
Here is a list of all widgets reported in this set, in case anyone's interested in related issues:

Excessive widget size limits - System Monitor: https://bugs.kde.org/show_bug.cgi?id=318919

Excessive widget size limits - Weather Forecast: https://bugs.kde.org/show_bug.cgi?id=318920

Excessive widget size limits - LCD Weather: https://bugs.kde.org/show_bug.cgi?id=318921

Excessive widget size limits - Shelf: https://bugs.kde.org/show_bug.cgi?id=318922

Excessive widget size limits - Calendar: https://bugs.kde.org/show_bug.cgi?id=318923
Comment 2 Mircea Kitsune 2014-05-22 22:10:08 UTC
I'd like a comment as to why this was set as "RESOLVED WONTFIX". The widget still has a rather restrictive horizontal size limit, despite the text just reaching half of the widget and the other half remaining empty.