Bug 310421 - plantage du à un jeu
Summary: plantage du à un jeu
Status: RESOLVED DUPLICATE of bug 309824
Alias: None
Product: kpat
Classification: Unclassified
Component: general (show other bugs)
Version: 3.6
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-20 20:16 UTC by yannick.dissart
Modified: 2013-02-02 00:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yannick.dissart 2012-11-20 20:16:51 UTC
Application: kpat (3.6)
KDE Platform Version: 4.8.5 (4.8.5) (Compiled from sources)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-33-generic x86_64
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
play with réussite - Golf
+ activation Me TV
+ activation google chrome

-- Backtrace:
Application: KPatience (kpat), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f285f4b5780 (LWP 5836))]

Thread 2 (Thread 0x7f2849014700 (LWP 5837)):
#0  0x00007f2857e8a5a1 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f2857e4e1df in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f2857e4ef04 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f2857e4f164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f285d5a5426 in QEventDispatcherGlib::processEvents (this=0x7f28400008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f285d574c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f285d574ed7 in QEventLoop::exec (this=0x7f2849013dd0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f285d473fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f285d5549ff in QInotifyFileSystemWatcherEngine::run (this=0x1032810) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f285d476fcb in QThreadPrivate::start (arg=0x1032810) at thread/qthread_unix.cpp:298
#10 0x00007f2858713e9a in start_thread (arg=0x7f2849014700) at pthread_create.c:308
#11 0x00007f285be65cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f285f4b5780 (LWP 5836)):
[KCrash Handler]
#6  lock (this=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1232
#7  KSharedDataCache::Private::CacheLocker::cautiousLock (this=0x7ffffd2a4bc0) at ../../kdecore/util/kshareddatacache.cpp:1255
#8  0x00007f285db0b8e0 in KSharedDataCache::Private::CacheLocker::CacheLocker (this=0x7ffffd2a4bc0, _d=<optimized out>) at ../../kdecore/util/kshareddatacache.cpp:1278
#9  0x00007f285db04ee6 in KSharedDataCache::find (this=0x207ea20, key=..., destination=0x7ffffd2a4c30) at ../../kdecore/util/kshareddatacache.cpp:1630
#10 0x00007f285e0408af in KImageCache::findPixmap (this=0x207ea20, key=..., destination=0x7ffffd2a4cc0) at ../../kdeui/util/kimagecache.cpp:150
#11 0x00007f285f0b28fb in KAbstractCardDeckPrivate::submitRendering (this=0x154fb40, elementId=..., image=...) at ../../../kpat/libkcardgame/kabstractcarddeck.cpp:247
#12 0x00007f285d58f446 in QObject::event (this=0x154fb40, e=<optimized out>) at kernel/qobject.cpp:1195
#13 0x00007f285c8f8894 in notify_helper (e=0x7f283a57fca0, receiver=0x154fb40, this=0xc85960) at kernel/qapplication.cpp:4559
#14 QApplicationPrivate::notify_helper (this=0xc85960, receiver=0x154fb40, e=0x7f283a57fca0) at kernel/qapplication.cpp:4531
#15 0x00007f285c8fd713 in QApplication::notify (this=0x7ffffd2a5750, receiver=0x154fb40, e=0x7f283a57fca0) at kernel/qapplication.cpp:4420
#16 0x00007f285dfdb3f6 in KApplication::notify (this=0x7ffffd2a5750, receiver=0x154fb40, event=0x7f283a57fca0) at ../../kdeui/kernel/kapplication.cpp:311
#17 0x00007f285d575e9c in QCoreApplication::notifyInternal (this=0x7ffffd2a5750, receiver=0x154fb40, event=0x7f283a57fca0) at kernel/qcoreapplication.cpp:876
#18 0x00007f285d579c6a in sendEvent (event=0x7f283a57fca0, receiver=0x154fb40) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#19 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xc3fff0) at kernel/qcoreapplication.cpp:1500
#20 0x00007f285d5a4f93 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#21 postEventSourceDispatch (s=<optimized out>) at kernel/qeventdispatcher_glib.cpp:279
#22 0x00007f2857e4ed53 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f2857e4f0a0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f2857e4f164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f285d5a53bf in QEventDispatcherGlib::processEvents (this=0xc414b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#26 0x00007f285c9a0d5e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f285d574c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007f285d574ed7 in QEventLoop::exec (this=0x7ffffd2a5640, flags=...) at kernel/qeventloop.cpp:204
#29 0x00007f285d579f67 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#30 0x00000000004189ea in main (argc=3, argv=0x7ffffd2a62d8) at ../../kpat/main.cpp:325

Possible duplicates by query: bug 310111, bug 309824, bug 309692, bug 308099, bug 307328.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-02-02 00:17:19 UTC

*** This bug has been marked as a duplicate of bug 309824 ***