Bug 312562 - KMail crash on save message as template
Summary: KMail crash on save message as template
Status: RESOLVED DUPLICATE of bug 298831
Alias: None
Product: kmail2
Classification: Unclassified
Component: general (show other bugs)
Version: 4.8.5
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 315748 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-03 19:55 UTC by richard virden
Modified: 2013-02-26 05:22 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description richard virden 2013-01-03 19:55:01 UTC
Application: kmail (4.8.5)
KDE Platform Version: 4.8.5 (4.8.5) "release 2"
Qt Version: 4.8.1
Operating System: Linux 3.4.11-2.16-default i686
Distribution: "openSUSE 12.2 (i586)"

-- Information about the crash:
- What I was doing when the application crashed: saving new message as template; message containing three recipient addresses ('To'), with text in subject field but no message text. Crashed on clicking the save as template menu item.
The KAddressBook was the only active window.

-- Backtrace:
Application: KMail (kmail), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1898740 (LWP 3780))]

Thread 3 (Thread 0xb01e5b40 (LWP 3783)):
#0  0xb776c430 in __kernel_vsyscall ()
#1  0xb587ba4c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2  0xb5ea211c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libc.so.6
#3  0xb386b54d in ?? () from /usr/lib/libQtWebKit.so.4
#4  0xb386b57f in ?? () from /usr/lib/libQtWebKit.so.4
#5  0xb5877e32 in start_thread () from /lib/libpthread.so.0
#6  0xb5e947ee in clone () from /lib/libc.so.6

Thread 2 (Thread 0xaf8bcb40 (LWP 3784)):
#0  0xb587ae24 in __pthread_mutex_unlock_usercnt () from /lib/libpthread.so.0
#1  0xb5ea2374 in pthread_mutex_unlock () from /lib/libc.so.6
#2  0xb4557980 in g_mutex_unlock () from /usr/lib/libglib-2.0.so.0
#3  0xb4517295 in g_main_context_prepare () from /usr/lib/libglib-2.0.so.0
#4  0xb45179ef in ?? () from /usr/lib/libglib-2.0.so.0
#5  0xb4517c51 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#6  0xb6209a9f in QEventDispatcherGlib::processEvents (this=0xaef00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb61d6a3c in QEventLoop::processEvents (this=this@entry=0xaf8bc278, flags=...) at kernel/qeventloop.cpp:149
#8  0xb61d6d31 in QEventLoop::exec (this=0xaf8bc278, flags=...) at kernel/qeventloop.cpp:204
#9  0xb60c493c in QThread::exec (this=this@entry=0x8fe9070) at thread/qthread.cpp:501
#10 0xb60c4a9b in QThread::run (this=0x8fe9070) at thread/qthread.cpp:568
#11 0xb60c7d00 in QThreadPrivate::start (arg=0x8fe9070) at thread/qthread_unix.cpp:298
#12 0xb5877e32 in start_thread () from /lib/libpthread.so.0
#13 0xb5e947ee in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb1898740 (LWP 3780)):
[KCrash Handler]
#7  QSharedDataPointer (o=..., this=0xbfdbc29c) at /usr/include/QtCore/qshareddata.h:93
#8  assignEntityPrivate (one=..., other=...) at /usr/src/debug/kdepimlibs-4.8.5/akonadi/entity.cpp:49
#9  0xb52f1617 in Akonadi::Entity::operator= (this=0xbfdbc2f0, other=...) at /usr/src/debug/kdepimlibs-4.8.5/akonadi/entity.cpp:116
#10 0xb5175752 in operator= (this=<optimized out>) at /usr/include/akonadi/collection.h:75
#11 Message::ComposerViewBase::slotSaveMessage (this=0x9410d18, job=0x9a92d38) at /usr/src/debug/kdepim-4.8.5/messagecomposer/composerviewbase.cpp:947
#12 0xb5175c41 in qt_static_metacall (_a=0xbfdbc438, _id=13, _o=0x9410d18, _c=<optimized out>) at /usr/src/debug/kdepim-4.8.5/build/messagecomposer/composerviewbase.moc:89
#13 Message::ComposerViewBase::qt_static_metacall (_o=_o@entry=0x9410d18, _c=_c@entry=QMetaObject::InvokeMetaMethod, _id=_id@entry=13, _a=0xbfdbc438) at /usr/src/debug/kdepim-4.8.5/build/messagecomposer/composerviewbase.moc:70
#14 0xb61efef2 in QMetaObject::activate (sender=0x9a92d38, m=0xb73064ac <KJob::staticMetaObject>, local_signal_index=3, argv=0xbfdbc438) at kernel/qobject.cpp:3556
#15 0xb7150585 in KJob::result (this=this@entry=0x9a92d38, _t1=_t1@entry=0x9a92d38) at /usr/src/debug/kdelibs-4.8.5/build/kdecore/kjob.moc:208
#16 0xb71505d8 in KJob::emitResult (this=0x9a92d38) at /usr/src/debug/kdelibs-4.8.5/kdecore/jobs/kjob.cpp:318
#17 0xb52e67de in Akonadi::JobPrivate::delayedEmitResult (this=0x95f6560) at /usr/src/debug/kdepimlibs-4.8.5/akonadi/job.cpp:144
#18 0xb61e997a in QMetaCallEvent::placeMetaCall (this=0x9a959b8, object=0x9a92d38) at kernel/qobject.cpp:525
#19 0xb61ededb in QObject::event (this=0x9a92d38, e=0x9a959b8) at kernel/qobject.cpp:1204
#20 0xb648caec in QApplicationPrivate::notify_helper (this=0x8cf3660, receiver=0x9a92d38, e=0x9a959b8) at kernel/qapplication.cpp:4554
#21 0xb64915af in QApplication::notify (this=0x9a959b8, receiver=0x9a92d38, e=0x9a959b8) at kernel/qapplication.cpp:3936
#22 0xb7500d01 in KApplication::notify (this=0xbfdbccfc, receiver=0x9a92d38, event=0x9a959b8) at /usr/src/debug/kdelibs-4.8.5/kdeui/kernel/kapplication.cpp:311
#23 0xb61d7c7e in QCoreApplication::notifyInternal (this=0xbfdbccfc, receiver=0x9a92d38, event=0x9a959b8) at kernel/qcoreapplication.cpp:876
#24 0xb61db9bd in sendEvent (event=<optimized out>, receiver=<optimized out>) at kernel/qcoreapplication.h:231
#25 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x8cbf130) at kernel/qcoreapplication.cpp:1500
#26 0xb61dbc3c in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1393
#27 0xb6209904 in sendPostedEvents () at kernel/qcoreapplication.h:236
#28 postEventSourceDispatch (s=0x8cf3740) at kernel/qeventdispatcher_glib.cpp:279
#29 0xb45177d3 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0xb4517b70 in ?? () from /usr/lib/libglib-2.0.so.0
#31 0xb4517c51 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#32 0xb6209a81 in QEventDispatcherGlib::processEvents (this=0x8cc2998, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#33 0xb653e1da in QGuiEventDispatcherGlib::processEvents (this=0x8cc2998, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#34 0xb61d6a3c in QEventLoop::processEvents (this=this@entry=0xbfdbcbc8, flags=...) at kernel/qeventloop.cpp:149
#35 0xb61d6d31 in QEventLoop::exec (this=0xbfdbcbc8, flags=...) at kernel/qeventloop.cpp:204
#36 0xb61dbcea in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#37 0xb648a934 in QApplication::exec () at kernel/qapplication.cpp:3815
#38 0x0804a59d in ?? ()
#39 0xb5dc33d5 in __libc_start_main () from /lib/libc.so.6
#40 0x0804aa89 in _start ()

Possible duplicates by query: bug 308740, bug 306555, bug 298831, bug 294453, bug 293820.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-02-26 05:22:37 UTC
See https://bugs.kde.org/show_bug.cgi?id=298831#c14

*** This bug has been marked as a duplicate of bug 298831 ***
Comment 2 Jekyll Wu 2013-02-26 05:22:56 UTC
*** Bug 315748 has been marked as a duplicate of this bug. ***