Bug 310027 - Kwin segfaults after alt-tabbing with unredirection on on i915
Summary: Kwin segfaults after alt-tabbing with unredirection on on i915
Status: RESOLVED DUPLICATE of bug 252817
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-13 13:55 UTC by Hello71
Modified: 2012-11-13 16:36 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hello71 2012-11-13 13:55:14 UTC
Application: kwin (4.8.5 (4.8.5))
KDE Platform Version: 4.8.5 (4.8.5) (Compiled from sources)
Qt Version: 4.8.2
Operating System: Linux 3.7.0-rc5 x86_64
Distribution: "Gentoo Base System release 2.1"

-- Information about the crash:
- What I was doing when the application crashed:
Repeatedly alt-tabbing into and out of a fullscreen window.
- Unusual behavior I noticed:
Kwin segfaults, window decorations are gone.
- Custom settings of the application:
OpenGL 2 desktop effects on
unredirection for fullscreen windows on
Using i915 drivers from latest git tree

The crash can be reproduced some of the time.

-- Backtrace:
Application: KWin (kwin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f1c5b56c780 (LWP 1354))]

Thread 2 (Thread 0x7f1c3f3ae700 (LWP 1374)):
#0  0x00007f1c5615edcc in pthread_cond_wait () from /lib64/libpthread.so.0
#1  0x00007f1c577cbd94 in QTWTF::TCMalloc_PageHeap::scavengerThread() () from /usr/lib64/qt4/libQtScript.so.4
#2  0x00007f1c577cbdc9 in QTWTF::TCMalloc_PageHeap::runScavengerThread(void*) () from /usr/lib64/qt4/libQtScript.so.4
#3  0x00007f1c5615aec6 in start_thread () from /lib64/libpthread.so.0
#4  0x00007f1c5ad796ed in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f1c5b56c780 (LWP 1354)):
[KCrash Handler]
#6  0x00007f1c45c18e57 in brw_update_renderbuffer_surface (brw=0x13d1760, rb=0x13c9990, unit=0) at brw_wm_surface_state.c:959
#7  0x00007f1c45c18994 in brw_update_renderbuffer_surfaces (brw=0x13d1760) at brw_wm_surface_state.c:1052
#8  0x00007f1c45c041a6 in brw_upload_state (brw=0x13d1760) at brw_state_upload.c:503
#9  0x00007f1c45bf1f64 in brw_try_draw_prims (max_index=<optimized out>, min_index=<optimized out>, ib=0x0, nr_prims=1, prim=0x7fffcd209e10, arrays=0x1443758, ctx=0x13d1760) at brw_draw.c:482
#10 brw_draw_prims (ctx=0x13d1760, arrays=0x1443758, prim=0x7fffcd209e10, nr_prims=1, ib=0x0, index_bounds_valid=<optimized out>, min_index=0, max_index=3, tfb_vertcount=0x0) at brw_draw.c:566
#11 0x00007f1c45cf54c3 in vbo_draw_arrays (ctx=0x13d1760, mode=6, start=0, count=<optimized out>, numInstances=1) at vbo/vbo_exec_array.c:600
#12 0x00007f1c45cf5569 in vbo_exec_DrawArrays (mode=6, start=0, count=4) at vbo/vbo_exec_array.c:632
#13 0x00007f1c45cf56cb in _mesa_DrawArrays (mode=<optimized out>, first=<optimized out>, count=<optimized out>) at vbo/vbo_exec_array.c:1299
#14 0x00007f1c45d7413c in _mesa_meta_glsl_Clear (ctx=0x13d1760, buffers=2) at drivers/common/meta.c:1973
#15 0x00007f1c45bd234b in intelClear (ctx=0x13d1760, mask=<optimized out>) at intel_clear.c:192
#16 0x00007f1c45dda723 in _mesa_Clear (mask=16384) at main/clear.c:242
#17 0x00007f1c5b0fdccb in KWin::SceneOpenGL::paintBackground(QRegion) () from /usr/lib64/libkdeinit4_kwin.so
#18 0x00007f1c5b0eb72b in KWin::Scene::paintGenericScreen(int, KWin::ScreenPaintData) () from /usr/lib64/libkdeinit4_kwin.so
#19 0x00007f1c5b0f968b in KWin::SceneOpenGL::paintGenericScreen(int, KWin::ScreenPaintData) () from /usr/lib64/libkdeinit4_kwin.so
#20 0x00007f1c5b0e8582 in KWin::Scene::finalPaintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/libkdeinit4_kwin.so
#21 0x00007f1c5b10cb57 in KWin::EffectsHandlerImpl::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/libkdeinit4_kwin.so
#22 0x00007f1c3fd5a826 in KWin::OutlineEffect::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/kde4/kwin4_effect_builtins.so
#23 0x00007f1c5b10cafb in KWin::EffectsHandlerImpl::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/libkdeinit4_kwin.so
#24 0x00007f1c58e72a68 in KWin::Effect::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/libkwineffects.so.1
#25 0x00007f1c5b10cafb in KWin::EffectsHandlerImpl::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/libkdeinit4_kwin.so
#26 0x00007f1c58e72a68 in KWin::Effect::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/libkwineffects.so.1
#27 0x00007f1c5b10cafb in KWin::EffectsHandlerImpl::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/libkdeinit4_kwin.so
#28 0x00007f1c58e72a68 in KWin::Effect::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/libkwineffects.so.1
#29 0x00007f1c5b10cafb in KWin::EffectsHandlerImpl::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/libkdeinit4_kwin.so
#30 0x00007f1c58e72a68 in KWin::Effect::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/libkwineffects.so.1
#31 0x00007f1c5b10cafb in KWin::EffectsHandlerImpl::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/libkdeinit4_kwin.so
#32 0x00007f1c58e72a68 in KWin::Effect::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/libkwineffects.so.1
#33 0x00007f1c5b10cafb in KWin::EffectsHandlerImpl::paintScreen(int, QRegion, KWin::ScreenPaintData&) () from /usr/lib64/libkdeinit4_kwin.so
#34 0x00007f1c5b0eac65 in KWin::Scene::paintScreen(int*, QRegion*) () from /usr/lib64/libkdeinit4_kwin.so
#35 0x00007f1c5b101f8d in KWin::SceneOpenGL::paint(QRegion, QList<KWin::Toplevel*>) () from /usr/lib64/libkdeinit4_kwin.so
#36 0x00007f1c5b0e5100 in KWin::Workspace::performCompositing() () from /usr/lib64/libkdeinit4_kwin.so
#37 0x00007f1c56504e99 in QObject::event(QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#38 0x00007f1c5565bd24 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#39 0x00007f1c5566082d in QApplication::notify(QObject*, QEvent*) () from /usr/lib64/qt4/libQtGui.so.4
#40 0x00007f1c5a855416 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
#41 0x00007f1c564f045c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib64/qt4/libQtCore.so.4
#42 0x00007f1c56522352 in QTimerInfoList::activateTimers() () from /usr/lib64/qt4/libQtCore.so.4
#43 0x00007f1c565224a0 in QEventDispatcherUNIX::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#44 0x00007f1c55702a3a in QEventDispatcherX11::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtGui.so.4
#45 0x00007f1c564ef1b2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#46 0x00007f1c564ef46d in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/qt4/libQtCore.so.4
#47 0x00007f1c564f3eeb in QCoreApplication::exec() () from /usr/lib64/qt4/libQtCore.so.4
#48 0x00007f1c5b09a496 in kdemain () from /usr/lib64/libkdeinit4_kwin.so
#49 0x00007f1c5acb360d in __libc_start_main () from /lib64/libc.so.6
#50 0x0000000000400781 in _start ()

Possible duplicates by query: bug 309415, bug 307027, bug 306927, bug 306254, bug 304464.

Reported using DrKonqi
Comment 1 Thomas Lübking 2012-11-13 16:36:19 UTC
> unredirection for fullscreen windows on
As you apparently already figured: that's relevant. Turn it off, the intel driver has caused trouble with it ever so far (why it's not activated by default)
If you want to increase performace of (certain) fullscreen applications (games, video players, etc.) please use the special window settings (or run "kcmshell4 kwinrules" to make the block the compositor (last tab)) or toggle compositing via dbus (qdbus org.kde.kwin /KWin toggleCompositing) or shortcut (Shift+Alt+F12)

*** This bug has been marked as a duplicate of bug 252817 ***