Bug 306698 - Crashes after update to KDE
Summary: Crashes after update to KDE
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Setup-ConfigFiles (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 307187 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-12 19:11 UTC by Thomas Arend
Modified: 2018-02-04 09:09 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.0


Attachments
New crash information added by DrKonqi (5.01 KB, text/plain)
2013-10-26 09:32 UTC, Unknown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Arend 2012-09-12 19:11:19 UTC
Application: digikam (2.9.0)
KDE Platform Version: 4.9.1 "release 561"
Qt Version: 4.8.2
Operating System: Linux 3.1.10-1.16-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Update to digikam 4.9.1
Start digiklam form console

- Unusual behavior I noticed:

Nothing. When you delete the config files the crash is postponed until the config wizard ends.

- Custom settings of the application:

Proposed default config settings of the config wizard.

openSUSE 12.1 with KDE repositories 4.9.1

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ffca320d800 (LWP 2941))]

Thread 5 (Thread 0x7ffc849e8700 (LWP 2944)):
#0  0x00007ffc9a652e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ffc9e309b2b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00000000005dfb70 in ?? ()
#3  0x00007ffc9e30961b in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007ffc91ed4734 in ?? () from /usr/X11R6/lib64/libGL.so.1
#5  0x00007ffc9a64ef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007ffc9c90210d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7ffc7ffff700 (LWP 2945)):
#0  0x00007ffc9c8f8ff3 in poll () from /lib64/libc.so.6
#1  0x00007ffc94b3cae8 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007ffc94b3cfa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007ffc9e436e36 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007ffc9e406842 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007ffc9e406a97 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007ffc9e3065f7 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007ffc9e3e662f in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007ffc9e30961b in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007ffc91ed4734 in ?? () from /usr/X11R6/lib64/libGL.so.1
#10 0x00007ffc9a64ef05 in start_thread () from /lib64/libpthread.so.0
#11 0x00007ffc9c90210d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7ffc7f7fe700 (LWP 2966)):
#0  0x00007ffc9a652e6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ffc9e309b2b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007ffca0aa3da1 in ?? () from /usr/lib64/libdigikamcore.so.2
#3  0x00007ffc9e30961b in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007ffc91ed4734 in ?? () from /usr/X11R6/lib64/libGL.so.1
#5  0x00007ffc9a64ef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007ffc9c90210d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7ffc67370700 (LWP 2984)):
#0  0x00007ffc9a6531eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007ffc9e309a8f in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007ffc9e2fce9f in ?? () from /usr/lib64/libQtCore.so.4
#3  0x00007ffc9e30961b in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007ffc91ed4734 in ?? () from /usr/X11R6/lib64/libGL.so.1
#5  0x00007ffc9a64ef05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007ffc9c90210d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7ffca320d800 (LWP 2941)):
[KCrash Handler]
#6  0x00007ffc9e353ccd in QString::operator=(QString const&) () from /usr/lib64/libQtCore.so.4
#7  0x00007ffc6b530589 in KIPI::Plugin::setUiBaseName (this=0x3b3a9b0, name=<optimized out>) at /usr/src/debug/digikam-software-compilation/extra/libkipi/libkipi/plugin.cpp:311
#8  0x00007ffc6b9c4589 in KIPIIpodExportPlugin::Plugin_iPodExport::Plugin_iPodExport (this=0x3b3a9b0, parent=0x34ad430) at /usr/src/debug/digikam-software-compilation/extra/kipi-plugins/ipodexport/plugin_ipodexport.cpp:66
#9  0x00007ffc6b9c4a97 in KPluginFactory::createInstance<KIPIIpodExportPlugin::Plugin_iPodExport, QObject> (parentWidget=<optimized out>, parent=<optimized out>, args=...) at /usr/include/kpluginfactory.h:477
#10 0x00007ffc9e987ff1 in KPluginFactory::create(char const*, QWidget*, QObject*, QList<QVariant> const&, QString const&) () from /usr/lib64/libkdecore.so.5
#11 0x00007ffca143c5c7 in create<KIPI::Plugin> (parent=0x34ad430, this=0x2ba3250, args=..., keyword=..., parentWidget=0x0) at /usr/include/kpluginfactory.h:531
#12 createInstance<KIPI::Plugin> (error=0x7fff3d0f24d0, args=..., parent=0x34ad430, parentWidget=0x0, this=0x2ba7940) at /usr/include/kservice.h:565
#13 createInstance<KIPI::Plugin> (error=0x7fff3d0f24d0, args=..., parent=0x34ad430, this=0x2ba7940) at /usr/include/kservice.h:542
#14 KIPI::PluginLoader::Info::plugin (this=0x345ff70) at /usr/src/debug/libkipi-4.9.1/libkipi/pluginloader.cpp:133
#15 0x000000000052b8bd in ?? ()
#16 0x00007ffc9e41bc41 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#17 0x000000000052ab88 in ?? ()
#18 0x000000000052ae5c in ?? ()
#19 0x000000000058a22c in ?? ()
#20 0x00000000005a0f59 in ?? ()
#21 0x0000000000498384 in ?? ()
#22 0x00007ffc9c84823d in __libc_start_main () from /lib64/libc.so.6
#23 0x0000000000499df5 in _start ()

Reported using DrKonqi
Comment 1 S. Burmeister 2012-09-12 19:15:54 UTC
Why do you post duplicate bugs?
Comment 2 Thomas Arend 2012-09-12 19:36:55 UTC
Am Mittwoch, 12. September 2012, 19:15:54 schrieben Sie:
> https://bugs.kde.org/show_bug.cgi?id=306698
> 
> S. Burmeister <sven.burmeister@gmx.net> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
> CC|                            |sven.burmeister@gmx.net
> 
> --- Comment #1 from S. Burmeister <sven.burmeister@gmx.net> ---
> Why do you post duplicate bugs?

Because the reporting wizard didn't work.


Thomas
Comment 3 caulier.gilles 2012-09-12 20:51:46 UTC
Following comment :

https://bugs.kde.org/show_bug.cgi?id=306693#c8

...from Sven, i mark this file as invalid.

Gilles Caulier
Comment 4 Jekyll Wu 2012-09-22 09:29:38 UTC
*** Bug 307187 has been marked as a duplicate of this bug. ***
Comment 5 Unknown 2013-10-26 09:32:27 UTC
Created attachment 83126 [details]
New crash information added by DrKonqi

gwenview (2.8.5) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed:
use Gwenview --> Try to open Modules Menu in Menu bar

-- Backtrace (Reduced):
#6  QString::operator= (this=0x72006500730097, other=...) at tools/qstring.cpp:1411
#7  0x00007f1a4ad0742e in KIPI::Plugin::setUiBaseName (this=0x15813d0, name=<optimized out>) at ../../libkipi/plugin.cpp:310
#8  0x00007f1a4b198b49 in KIPIIpodExportPlugin::Plugin_iPodExport::Plugin_iPodExport (this=0x15813d0, parent=0x12f2ac0) at /build/buildd/digikam-3.0.0/extra/kipi-plugins/ipodexport/plugin_ipodexport.cpp:66
#9  0x00007f1a4b199057 in KPluginFactory::createInstance<KIPIIpodExportPlugin::Plugin_iPodExport, QObject> (parentWidget=<optimized out>, parent=<optimized out>, args=...) at /usr/include/kpluginfactory.h:477
#10 0x00007f1a83fbc611 in KPluginFactory::create (this=0x3de97a0, iface=0x7f1a85899440 "KIPI::Plugin", parentWidget=0x0, parent=0x12f2ac0, args=..., keyword=...) at ../../kdecore/util/kpluginfactory.cpp:203
Comment 6 caulier.gilles 2013-10-26 09:40:28 UTC
You have a problem with libkipi... update it...

Gilles Caulier
Comment 7 caulier.gilles 2018-02-04 09:09:04 UTC
Problem fixed in 6.0.0 where all tools are now in digiKam core