Bug 306693 - after update to KDE host application crashes on startup
Summary: after update to KDE host application crashes on startup
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Portability (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 307114 314658 316203 322208 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-09-12 17:41 UTC by Thomas Arend
Modified: 2018-02-04 10:48 UTC (History)
12 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Arend 2012-09-12 17:41:30 UTC
thomas@x1:~> digikam
QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.
KCrash: Application 'digikam' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
sock_file=/home/thomas/.kde4/socket-x1/kdeinit4__0

[1]+  Angehalten              digikam
thomas@x1:~> QSocketNotifier: Invalid socket 14 and type 'Read', disabling...

After update digikam crashes at startup with above messages


Reproducible: Always

Steps to Reproduce:
1. Open terminal
2. type in "digikam<enter>"
Actual Results:  
digikam crashes all times.

Expected Results:  
I would prefer that a programs starts after it is loaded. 
I have no need for crashes after easy and save to use bugfix updates. (See release notes)
Comment 1 Thomas Arend 2012-09-12 18:16:34 UTC
After removing

./share/apps/digikam/digikamui.rc
./share/config/digikamrc

The configuration dialog starts and the crashed is postponed until the end of the configuration dialog. Although after installing the debug libraries the info is regarded as useless.

-----

Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f8c0c369800 (LWP 20353))]

Thread 5 (Thread 0x7f8bed75b700 (LWP 20492)):
#0  0x00007f8c037aee6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f8c07465b2b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00000000005dfb70 in ?? ()
#3  0x00007f8c0746561b in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f8bfb030734 in ?? () from /usr/X11R6/lib64/libGL.so.1
#5  0x00007f8c037aaf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f8c05a5e10d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f8becf5a700 (LWP 20493)):
#0  0x00007f8c037ae11f in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f8bfdc97b64 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f8bfdc9897d in ?? () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f8bfdc98fa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f8c07592e36 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f8c07562842 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f8c07562a97 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#7  0x00007f8c074625f7 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#8  0x00007f8c0754262f in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f8c0746561b in ?? () from /usr/lib64/libQtCore.so.4
#10 0x00007f8bfb030734 in ?? () from /usr/X11R6/lib64/libGL.so.1
#11 0x00007f8c037aaf05 in start_thread () from /lib64/libpthread.so.0
#12 0x00007f8c05a5e10d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f8be7fff700 (LWP 20514)):
#0  0x00007f8c037aee6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f8c07465b2b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f8c09bffda1 in ?? () from /usr/lib64/libdigikamcore.so.2
#3  0x00007f8c0746561b in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f8bfb030734 in ?? () from /usr/X11R6/lib64/libGL.so.1
#5  0x00007f8c037aaf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f8c05a5e10d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f8bd7ffe700 (LWP 20531)):
#0  0x00007f8c037af1eb in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f8c07465a8f in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f8c07458e9f in ?? () from /usr/lib64/libQtCore.so.4
#3  0x00007f8c0746561b in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f8bfb030734 in ?? () from /usr/X11R6/lib64/libGL.so.1
#5  0x00007f8c037aaf05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f8c05a5e10d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f8c0c369800 (LWP 20353)):
[KCrash Handler]
#6  0x00007f8c074afccd in QString::operator=(QString const&) () from /usr/lib64/libQtCore.so.4
#7  0x00007f8bd6af0589 in KIPI::Plugin::setUiBaseName (this=0x24c5420, name=<optimized out>) at /usr/src/debug/digikam-software-compilation/extra/libkipi/libkipi/plugin.cpp:311
#8  0x00007f8bd6f84589 in KIPIIpodExportPlugin::Plugin_iPodExport::Plugin_iPodExport (this=0x24c5420, parent=0x387e690) at /usr/src/debug/digikam-software-compilation/extra/kipi-plugins/ipodexport/plugin_ipodexport.cpp:66
#9  0x00007f8bd6f84a97 in KPluginFactory::createInstance<KIPIIpodExportPlugin::Plugin_iPodExport, QObject> (parentWidget=<optimized out>, parent=<optimized out>, args=...) at /usr/include/kpluginfactory.h:477
#10 0x00007f8c07ae3ff1 in KPluginFactory::create(char const*, QWidget*, QObject*, QList<QVariant> const&, QString const&) () from /usr/lib64/libkdecore.so.5
#11 0x00007f8c0a5985c7 in create<KIPI::Plugin> (parent=0x387e690, this=0x38f02b0, args=..., keyword=..., parentWidget=0x0) at /usr/include/kpluginfactory.h:531
#12 createInstance<KIPI::Plugin> (error=0x7fff29aad0f0, args=..., parent=0x387e690, parentWidget=0x0, this=0x399fd90) at /usr/include/kservice.h:565
#13 createInstance<KIPI::Plugin> (error=0x7fff29aad0f0, args=..., parent=0x387e690, this=0x399fd90) at /usr/include/kservice.h:542
#14 KIPI::PluginLoader::Info::plugin (this=0x3833ec0) at /usr/src/debug/libkipi-4.9.1/libkipi/pluginloader.cpp:133
#15 0x000000000052b8bd in ?? ()
#16 0x00007f8c07577c41 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib64/libQtCore.so.4
#17 0x000000000052ab88 in ?? ()
#18 0x000000000052ae5c in ?? ()
#19 0x000000000058a22c in ?? ()
#20 0x00000000005a0f59 in ?? ()
#21 0x0000000000498384 in ?? ()
#22 0x00007f8c059a423d in __libc_start_main () from /lib64/libc.so.6
#23 0x0000000000499df5 in _start ()
Comment 2 Victor Dodon 2012-09-12 19:05:48 UTC
please update libkipi to version 2.0.0 [1] and kipi-plugins to 3.0.0 [2], you can find both in the master.

[1] https://projects.kde.org/projects/kde/kdegraphics/libs/libkipi/repository
[2] https://projects.kde.org/projects/extragear/graphics/kipi-plugins/repository

Victor Dodon
Comment 3 S. Burmeister 2012-09-12 19:10:02 UTC
Is he using digikam 3 alpha? If so the packages can be found in openSUSE's Playground repo where he got digikam 3 alpha as well.
Comment 4 S. Burmeister 2012-09-12 19:20:04 UTC
Duplicate bug 306698 states he is using 2.9, hence libkipi 2.0 and kipi-plugins 3.0 should not be necessary, should they?
Comment 5 Thomas Arend 2012-09-12 19:26:18 UTC
digikam states that it is 2.9.

thomas@x1:~> digikam --version
Qt: 4.8.2
KDE: 4.9.1 "release 561"
digiKam: 2.9.0

rpm -qa | grep digikam
digikam-debuginfo-2.9.0+git20120909-2.1.x86_64
digikam-doc-2.2.0-3.3.1.noarch
digikam-lang-2.9.0-147.3.noarch
digikam-debugsource-2.9.0+git20120909-2.1.x86_64
digikam-2.9.0-147.3.x86_64
Comment 6 S. Burmeister 2012-09-12 19:33:23 UTC
rpm -qa | grep kipi

And versions of libkdcraw, libkexiv2, libkface, libkgeomap.
Comment 7 Thomas Arend 2012-09-12 19:46:25 UTC
rpm -qa | ( for LIB in kipi libkdcraw libkexiv2 libkface libkgeomap ; do grep $LIB ; done )
libkipi9-debuginfo-4.9.1-44.2.x86_64
libkipi10-4.9.50-2.1.x86_64
kipi-plugins-debuginfo-2.9.0+git20120909-2.1.x86_64
kipi-plugins-2.9.0+git20120909-2.1.x86_64
kipi-plugins-acquireimage-2.9.0+git20120909-2.1.x86_64
kipi-plugins-geolocation-2.9.0+git20120909-2.1.x86_64
libkipi9-4.9.1-44.2.x86_64
libkipi10-debuginfo-4.9.50-2.1.x86_64
libkipi8-4.8.5-42.1.x86_64
kipi-plugins-lang-2.9.0+git20120909-2.1.noarch
Comment 8 S. Burmeister 2012-09-12 20:19:55 UTC
You are mixing packages from different repos and digikam versions. Either you use all digikam+kipi+libs from Playground or from KR49 or whatever KDE repo you use.

Mixing 2.9 from KR49 with git snapshots from Playground will not work.

The crash is not digikam's fault and this report invalid, as is bug 306698.

Next time you should skip comments such as:
"Expected Results:  
I would prefer that a programs starts after it is loaded. 
I have no need for crashes after easy and save to use bugfix updates. (See release notes)". It does not add any relevant info and is hence useless for bug reports. Not mentioning the embarrassment if the fault is yours in the end and not digikam's.
Comment 9 caulier.gilles 2012-09-12 20:50:52 UTC
Following comment #8 from Sven, i mark this file as invalid.

Gilles Caulier
Comment 10 Jekyll Wu 2012-09-20 18:12:46 UTC
*** Bug 307114 has been marked as a duplicate of this bug. ***
Comment 11 caulier.gilles 2013-01-26 08:31:27 UTC
*** Bug 313890 has been marked as a duplicate of this bug. ***
Comment 12 caulier.gilles 2013-01-26 10:21:46 UTC
*** Bug 313356 has been marked as a duplicate of this bug. ***
Comment 13 Leo 2013-01-27 09:02:26 UTC
z-lmutt@Server:~$ dpkg -l | ( for LIB in kipi libkdcraw libkexiv2 libkface libkgeomap ; do grep $LIB ; done )
ii  kipi-plugins                          4:3.0.0~beta3-0ubuntu2~ubuntu12.10~ppa1          amd64        image manipulation/handling plugins for KIPI aware programs
ii  kipi-plugins-common                   4:3.0.0~beta3-0ubuntu2~ubuntu12.10~ppa1          all          kipi-plugins architecture-independent data
ii  libkipi-data                          4:4.9.98-0ubuntu1~ubuntu12.10~ppa1               all          data files for kipi libraries
ii  libkipi-dbg                           4:4.9.98-0ubuntu1~ubuntu12.10~ppa1               amd64        debugging symbols for the kipi library
ii  libkipi-dev                           4:4.9.98-0ubuntu1~ubuntu12.10~ppa1               amd64        library for apps that want to use kipi-plugins (development version)
ii  libkipi10                             4:4.9.98-0ubuntu1~ubuntu12.10~ppa1               amd64        library for apps that want to use kipi-plugins (runtime version)
ii  libkipi9                              4:4.9.3-0ubuntu0.1                               amd64        library for apps that want to use kipi-plugins (runtime version)
z-lmutt@Server:~$ dpkg -l digikam
Voluto=U (non noto)/I (installato)/R (rimosso)/P (rimosso totale)/H (in attesa)
| Stato=Non/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(nessuno)/R (reinstallazione richiesta) (Stato,Err: maiuscolo=grave)
||/ Nome                               Versione               Architettura           Descrizione
+++-==================================-======================-======================-=========================================================================
ii  digikam                            4:3.0.0~beta3-0ubuntu2 amd64                  digital photo management application for KDE
z-lmutt@Server:~$ dpkg -l kipi-plugins
Voluto=U (non noto)/I (installato)/R (rimosso)/P (rimosso totale)/H (in attesa)
| Stato=Non/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(nessuno)/R (reinstallazione richiesta) (Stato,Err: maiuscolo=grave)
||/ Nome                               Versione               Architettura           Descrizione
+++-==================================-======================-======================-=========================================================================
ii  kipi-plugins                       4:3.0.0~beta3-0ubuntu2 amd64                  image manipulation/handling plugins for KIPI aware programs
z-lmutt@Server:~$ digikam --version 
Qt: 4.8.3
Piattaforma di sviluppo KDE: 4.9.98
digiKam: 3.0.0-beta3




If it could be of any use...

SKAL
Comment 14 Victor Dodon 2013-01-27 09:48:01 UTC
You have two versions of libkipi installed: libkipi9 and libkipi10. You must uninstall libkipi9 and to use only libkipi10.

Victor.
Comment 15 Leo 2013-01-27 10:23:39 UTC
(In reply to comment #14)
> You have two versions of libkipi installed: libkipi9 and libkipi10. You must
> uninstall libkipi9 and to use only libkipi10.
> 
> Victor.

Thank you Victor for the reply... 

The problem is that 9 is related to kamoso ksnapshot kubuntu-desktop packages, and 10 is for digikam 3 :(

Anyway now I know why I have this problem :)

thanks a lot
SKAL
Comment 16 Victor Dodon 2013-01-27 11:06:45 UTC
You can try http://askubuntu.com/questions/17745/how-to-remove-a-deb-without-removing-its-dependencies#answer-17758 to remove the libkipi9 package.

Victor.
Comment 17 Christoph Feck 2013-02-08 10:42:54 UTC
*** Bug 314658 has been marked as a duplicate of this bug. ***
Comment 18 caulier.gilles 2013-02-20 06:02:19 UTC
*** Bug 315487 has been marked as a duplicate of this bug. ***
Comment 19 caulier.gilles 2013-02-20 22:28:44 UTC
*** Bug 313186 has been marked as a duplicate of this bug. ***
Comment 20 caulier.gilles 2013-02-28 16:19:22 UTC
*** Bug 315914 has been marked as a duplicate of this bug. ***
Comment 21 Jekyll Wu 2013-03-06 02:41:01 UTC
*** Bug 316203 has been marked as a duplicate of this bug. ***
Comment 22 Jekyll Wu 2013-07-10 18:04:49 UTC
*** Bug 322208 has been marked as a duplicate of this bug. ***
Comment 23 Please Delete 2013-07-11 21:15:42 UTC
I have the same problem. I removed libkipi9 using dpkg and --force-dependancies so that KSnapshot and Kamoso would not uninstall as I need those. Then when I tried to run those two they would not even run. They depend on libkipi9 to even run. So I had no choice to reinstall libkipi9.

I assume I'll have to wait for an update of KSnapshot and Kamoso and they are working on it?
Comment 24 caulier.gilles 2018-02-04 10:48:07 UTC
Problem fixed in 6.0.0 where all tools are now in digiKam core