Bug 307187 - Gwenview crashes when trying to open the "Modules" menu
Summary: Gwenview crashes when trying to open the "Modules" menu
Status: RESOLVED DUPLICATE of bug 306698
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 2.8.5
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-22 08:25 UTC by Torbjörn K.
Modified: 2013-06-24 18:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (4.03 KB, text/plain)
2013-06-24 18:11 UTC, Unknown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Torbjörn K. 2012-09-22 08:25:36 UTC
Application: gwenview (2.8.5)
KDE Platform Version: 4.8.5 (4.8.5) "release 521"
Qt Version: 4.8.3
Operating System: Linux 3.4.6-2-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:

Started Gwenview and tryed opening the "Modules" menu. The crash happened immediately and is reproducable each time.

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f05274d8760 (LWP 10160))]

Thread 2 (Thread 0x7f0513fdb700 (LWP 10162)):
#0  0x00007f0523e7dff3 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f05202a2ae8 in g_main_context_poll (n_fds=1, fds=0x7f050c002400, timeout=-1, context=0x7f050c0009a0, priority=<optimized out>) at gmain.c:3386
#2  g_main_context_iterate (context=0x7f050c0009a0, block=<optimized out>, dispatch=1, self=<optimized out>) at gmain.c:3068
#3  0x00007f05202a2fa9 in g_main_context_iteration (context=0x7f050c0009a0, may_block=1) at gmain.c:3136
#4  0x00007f0526328666 in QEventDispatcherGlib::processEvents (this=0x7f050c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f05262f8162 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f05262f83b7 in QEventLoop::exec (this=0x7f0513fdadd0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f05261f6687 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007f05262d7c0f in QInotifyFileSystemWatcherEngine::run (this=0x1438f40) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00007f05261f96ec in QThreadPrivate::start (arg=0x1438f40) at thread/qthread_unix.cpp:338
#10 0x00007f0522600f05 in start_thread (arg=0x7f0513fdb700) at pthread_create.c:301
#11 0x00007f0523e8710d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7f05274d8760 (LWP 10160)):
[KCrash Handler]
#6  QString::operator= (this=0x72006500730097, other=...) at tools/qstring.cpp:1411
#7  0x00007f0511e7c5b9 in KIPI::Plugin::setUiBaseName (this=0x136e230, name=<optimized out>) at /usr/src/debug/digikam-software-compilation/extra/libkipi/libkipi/plugin.cpp:309
#8  0x00007f0512346589 in KIPIIpodExportPlugin::Plugin_iPodExport::Plugin_iPodExport (this=0x136e230, parent=0x1709c30) at /usr/src/debug/digikam-software-compilation/extra/kipi-plugins/ipodexport/plugin_ipodexport.cpp:66
#9  0x00007f0512346a97 in KPluginFactory::createInstance<KIPIIpodExportPlugin::Plugin_iPodExport, QObject> (parentWidget=<optimized out>, parent=<optimized out>, args=...) at /usr/include/kpluginfactory.h:477
#10 0x00007f0525347f61 in KPluginFactory::create (this=0x13d2870, iface=0x7f0525f72160 <qt_meta_stringdata_KIPI__Plugin> "KIPI::Plugin", parentWidget=0x0, parent=0x1709c30, args=..., keyword=...) at /usr/src/debug/kdelibs-4.8.5/kdecore/util/kpluginfactory.cpp:203
#11 0x00007f0525f6a4a7 in create<KIPI::Plugin> (parent=0x1709c30, this=0x13d2870, args=..., keyword=..., parentWidget=0x0) at /usr/include/kpluginfactory.h:531
#12 createInstance<KIPI::Plugin> (error=0x7fff20c22fd0, args=..., parent=0x1709c30, parentWidget=0x0, this=0x1947d90) at /usr/include/kservice.h:565
#13 createInstance<KIPI::Plugin> (error=0x7fff20c22fd0, args=..., parent=0x1709c30, this=0x1947d90) at /usr/include/kservice.h:542
#14 KIPI::PluginLoader::Info::plugin (this=0x1a7ed90) at /usr/src/debug/libkipi-4.8.5/libkipi/pluginloader.cpp:207
#15 0x00000000004669f0 in _start ()

Possible duplicates by query: bug 306698.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-09-22 09:29:38 UTC

*** This bug has been marked as a duplicate of bug 306698 ***
Comment 2 Unknown 2013-06-24 18:11:14 UTC
Created attachment 80752 [details]
New crash information added by DrKonqi

gwenview (2.8.5) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed:
Click "Modules" in Menu Bar. Reproducible every time. On Kubuntu 12.04LTS

-- Backtrace (Reduced):
#6  QString::operator= (this=0x72006500730097, other=...) at tools/qstring.cpp:1411
#7  0x00007f714596d42e in KIPI::Plugin::setUiBaseName (this=0x1229d10, name=<optimized out>) at ../../libkipi/plugin.cpp:310
#8  0x00007f7145dfeb49 in KIPIIpodExportPlugin::Plugin_iPodExport::Plugin_iPodExport (this=0x1229d10, parent=0x101b060) at /build/buildd/digikam-3.0.0/extra/kipi-plugins/ipodexport/plugin_ipodexport.cpp:66
#9  0x00007f7145dff057 in KPluginFactory::createInstance<KIPIIpodExportPlugin::Plugin_iPodExport, QObject> (parentWidget=<optimized out>, parent=<optimized out>, args=...) at /usr/include/kpluginfactory.h:477
#10 0x00007f715ac73611 in KPluginFactory::create (this=0x12234b0, iface=0x7f715c550440 "KIPI::Plugin", parentWidget=0x0, parent=0x101b060, args=..., keyword=...) at ../../kdecore/util/kpluginfactory.cpp:203