Bug 307114 - print screen crash
Summary: print screen crash
Status: RESOLVED DUPLICATE of bug 306693
Alias: None
Product: ksnapshot
Classification: Unclassified
Component: general (show other bugs)
Version: 0.8.2
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Richard Moore
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-09-20 18:04 UTC by Otter
Modified: 2012-09-20 18:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Otter 2012-09-20 18:04:39 UTC
Application: ksnapshot (0.8.2)
KDE Platform Version: 4.9.1 "release 561"
Qt Version: 4.8.3
Operating System: Linux 3.1.10-1.16-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
trying to do a print screen.  on send-to to try and print received this crash.

The crash can be reproduced every time.

-- Backtrace:
Application: KSnapshot (ksnapshot), signal: Segmentation fault
[KCrash Handler]
#6  QString::operator= (this=0x72006500730097, other=...) at tools/qstring.cpp:1411
#7  0x00007f250fe855f9 in KIPI::Plugin::setUiBaseName (this=0x9c0020, name=<optimized out>) at /usr/src/debug/digikam-software-compilation/extra/libkipi/libkipi/plugin.cpp:311
#8  0x00007f2510319589 in KIPIIpodExportPlugin::Plugin_iPodExport::Plugin_iPodExport (this=0x9c0020, parent=0x91bd50) at /usr/src/debug/digikam-software-compilation/extra/kipi-plugins/ipodexport/plugin_ipodexport.cpp:66
#9  0x00007f2510319a97 in KPluginFactory::createInstance<KIPIIpodExportPlugin::Plugin_iPodExport, QObject> (parentWidget=<optimized out>, parent=<optimized out>, args=...) at /usr/include/kpluginfactory.h:477
#10 0x00007f251dcacff1 in KPluginFactory::create (this=0x9c3c60, iface=0x7f251e6006e0 "KIPI::Plugin", parentWidget=0x0, parent=0x91bd50, args=..., keyword=<optimized out>) at /usr/src/debug/kdelibs-4.9.1/kdecore/util/kpluginfactory.cpp:203
#11 0x00007f251e5f45c7 in create<KIPI::Plugin> (parent=0x91bd50, this=0x9c3c60, args=..., keyword=..., parentWidget=0x0) at /usr/include/kpluginfactory.h:531
#12 createInstance<KIPI::Plugin> (error=0x7ffffc8090a0, args=..., parent=0x91bd50, parentWidget=0x0, this=0x961a20) at /usr/include/kservice.h:565
#13 createInstance<KIPI::Plugin> (error=0x7ffffc8090a0, args=..., parent=0x91bd50, this=0x961a20) at /usr/include/kservice.h:542
#14 KIPI::PluginLoader::Info::plugin (this=0x951830) at /usr/src/debug/libkipi-4.9.1/libkipi/pluginloader.cpp:133
#15 0x00000000004192f8 in _start ()

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-09-20 18:12:46 UTC

*** This bug has been marked as a duplicate of bug 306693 ***