Bug 305787 - Crash after deleting an account
Summary: Crash after deleting an account
Status: RESOLVED DUPLICATE of bug 309105
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: 4.6.1
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-25 21:53 UTC by jvs.wise
Modified: 2012-11-27 12:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jvs.wise 2012-08-25 21:53:35 UTC
Application: kmymoney (4.6.1)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-29-generic-pae i686
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
I was deleting a 2nd level account and KMyMoney crashed. Re-attempted account deletion on a different 2nd level account, and it crashed again.

The crash can be reproduced every time.

-- Backtrace:
Application: KMyMoney (kmymoney), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb3d16740 (LWP 4516))]

Thread 2 (Thread 0xb0893b40 (LWP 4517)):
#0  0xb4787dcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb6067315 in do_gettime (frac=0xb0892fb0, sec=0xb0892fa8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb6151226 in QTimerInfoList::updateCurrentTime (this=0xaff02074) at kernel/qeventdispatcher_unix.cpp:343
#4  0xb615157a in QTimerInfoList::timerWait (this=0xaff02074, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0xb614fe23 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xb08930bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb614febd in timerSourcePrepare (source=0xaff02040, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb46d1872 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb46d1faf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb46d2201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb61508e7 in QEventDispatcherGlib::processEvents (this=0xaff00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0xb611c50d in QEventLoop::processEvents (this=0xb0893240, flags=...) at kernel/qeventloop.cpp:149
#12 0xb611c7a9 in QEventLoop::exec (this=0xb0893240, flags=...) at kernel/qeventloop.cpp:204
#13 0xb600594c in QThread::exec (this=0xa24ae78) at thread/qthread.cpp:501
#14 0xb60f9b5d in QInotifyFileSystemWatcherEngine::run (this=0xa24ae78) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb6008de0 in QThreadPrivate::start (arg=0xa24ae78) at thread/qthread_unix.cpp:298
#16 0xb6880d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb5262ace in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb3d16740 (LWP 4516)):
[KCrash Handler]
#7  InstitutionsModel::slotObjectModified (this=0xa0df918, objType=0, obj=0xaaecf48) at /build/buildd/kmymoney-4.6.1/kmymoney/models/accountsmodel.cpp:909
#8  0xb61346b1 in QMetaObject::activate (sender=0xb778e620, m=0xb778dbf8, local_signal_index=3, argv=0xbff2aa14) at kernel/qobject.cpp:3547
#9  0xb771d4cd in MyMoneyFile::objectModified (this=0xb778e620, _t1=MyMoneyFile::notifyAccount, _t2=0xaaecf48) at /build/buildd/kmymoney-4.6.1/obj-i686-linux-gnu/kmymoney/mymoney/mymoneyfile.moc:134
#10 0xb7726e50 in MyMoneyFile::commitTransaction (this=0xb778e620) at /build/buildd/kmymoney-4.6.1/kmymoney/mymoney/mymoneyfile.cpp:392
#11 0xb77272ad in MyMoneyFileTransaction::commit (this=0xbff2aede) at /build/buildd/kmymoney-4.6.1/kmymoney/mymoney/mymoneyfile.cpp:2786
#12 0x080c7d9d in KMyMoneyApp::slotAccountDelete (this=0x9ebbcc0) at /build/buildd/kmymoney-4.6.1/kmymoney/kmymoney.cpp:3455
#13 0x080d2d8d in KMyMoneyApp::qt_static_metacall (_o=0x9ebbcc0, _c=QMetaObject::InvokeMetaMethod, _id=135, _a=0xbff2b248) at /build/buildd/kmymoney-4.6.1/obj-i686-linux-gnu/kmymoney/kmymoney.moc:519
#14 0xb61346b1 in QMetaObject::activate (sender=0x9eeb848, m=0xb5eff3f8, local_signal_index=1, argv=0xbff2b248) at kernel/qobject.cpp:3547
#15 0xb55809bd in QAction::triggered (this=0x9eeb848, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#16 0xb5580c5b in QAction::activate (this=0x9eeb848, event=QAction::Trigger) at kernel/qaction.cpp:1257
#17 0xb5a42453 in QMenuPrivate::activateCausedStack (this=0x9e27618, causedStack=..., action=0x9eeb848, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1028
#18 0xb5a4932f in QMenuPrivate::activateAction (this=0x9e27618, action=0x9eeb848, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1120
#19 0xb5a4c015 in QMenu::mouseReleaseEvent (this=0x9e275b8, e=0xbff2ba84) at widgets/qmenu.cpp:2360
#20 0xb6d3470c in KMenu::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libkdeui.so.5
#21 0xb55e21ac in QWidget::event (this=0x9e275b8, event=0xbff2ba84) at kernel/qwidget.cpp:8362
#22 0xb5a4aa9c in QMenu::event (this=0x9e275b8, e=0xbff2ba84) at widgets/qmenu.cpp:2469
#23 0xb5587ed4 in notify_helper (e=0xbff2ba84, receiver=0x9e275b8, this=0x9c92f28) at kernel/qapplication.cpp:4559
#24 QApplicationPrivate::notify_helper (this=0x9c92f28, receiver=0x9e275b8, e=0xbff2ba84) at kernel/qapplication.cpp:4531
#25 0xb558e024 in QApplication::notify (this=0x9c92f28, receiver=0x9e275b8, e=0xbff2ba84) at kernel/qapplication.cpp:4102
#26 0xb6c56401 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#27 0xb611d97e in QCoreApplication::notifyInternal (this=0x9c8c3a8, receiver=0x9e275b8, event=0xbff2ba84) at kernel/qcoreapplication.cpp:876
#28 0xb5588e95 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#29 QApplicationPrivate::sendMouseEvent (receiver=0x9e275b8, event=0xbff2ba84, alienWidget=0x0, nativeWidget=0x9e275b8, buttonDown=0xb5f1ccf4, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#30 0xb56157d2 in QETWidget::translateMouseEvent (this=0x9e275b8, event=0xbff2bf3c) at kernel/qapplication_x11.cpp:4551
#31 0xb5613c0d in QApplication::x11ProcessEvent (this=0x9c8c3a8, event=0xbff2bf3c) at kernel/qapplication_x11.cpp:3732
#32 0xb5640eac in x11EventSourceDispatch (s=0x9c94868, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#33 0xb46d1d86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0xb46d2125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0xb46d2201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0xb6150887 in QEventDispatcherGlib::processEvents (this=0x9c6cea0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#37 0xb5640aaa in QGuiEventDispatcherGlib::processEvents (this=0x9c6cea0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#38 0xb611c50d in QEventLoop::processEvents (this=0xbff2c230, flags=...) at kernel/qeventloop.cpp:149
#39 0xb611c7a9 in QEventLoop::exec (this=0xbff2c230, flags=...) at kernel/qeventloop.cpp:204
#40 0xb5a46b87 in QMenu::exec (this=0x9e275b8, p=..., action=0x0) at widgets/qmenu.cpp:2113
#41 0x0809945e in KMyMoneyApp::showContextMenu (this=0xbff2c270, containerName=...) at /build/buildd/kmymoney-4.6.1/kmymoney/kmymoney.cpp:5739
#42 0x080998ca in KMyMoneyApp::slotShowAccountContextMenu (this=0x9ebbcc0, obj=...) at /build/buildd/kmymoney-4.6.1/kmymoney/kmymoney.cpp:5778
#43 0x080d2e4d in KMyMoneyApp::qt_static_metacall (_o=0x9ebbcc0, _c=QMetaObject::InvokeMetaMethod, _id=144, _a=0xbff2c618) at /build/buildd/kmymoney-4.6.1/obj-i686-linux-gnu/kmymoney/kmymoney.moc:528
#44 0xb61346b1 in QMetaObject::activate (sender=0xa088eb8, m=0x861f63c, local_signal_index=1, argv=0xbff2c618) at kernel/qobject.cpp:3547
#45 0x08177875 in KInstitutionsView::openContextMenu (this=0xa088eb8, _t1=...) at /build/buildd/kmymoney-4.6.1/obj-i686-linux-gnu/kmymoney/views/kinstitutionsview.moc:125
#46 0xb61346b1 in QMetaObject::activate (sender=0xa0791f0, m=0x86203e4, local_signal_index=1, argv=0xbff2c6f8) at kernel/qobject.cpp:3547
#47 0x081e4c45 in KMyMoneyAccountTreeView::openContextMenu (this=0xa0791f0, _t1=...) at /build/buildd/kmymoney-4.6.1/obj-i686-linux-gnu/kmymoney/widgets/kmymoneyaccounttreeview.moc:133
#48 0x081e6568 in KMyMoneyAccountTreeView::customContextMenuRequested (this=0xa0791f0, pos=...) at /build/buildd/kmymoney-4.6.1/kmymoney/widgets/kmymoneyaccounttreeview.cpp:99
#49 0xb61346b1 in QMetaObject::activate (sender=0xa0791f0, m=0xb5f0047c, local_signal_index=0, argv=0xbff2ca48) at kernel/qobject.cpp:3547
#50 0xb55d6f15 in QWidget::customContextMenuRequested (this=0xa0791f0, _t1=...) at .moc/release-shared/moc_qwidget.cpp:374
#51 0xb55e2fd6 in QWidget::event (this=0xa0791f0, event=0xbff2d2ac) at kernel/qwidget.cpp:8532
#52 0xb59ffe55 in QFrame::event (this=0xa0791f0, e=0xbff2d2ac) at widgets/qframe.cpp:557
#53 0xb5a92ab1 in QAbstractScrollArea::viewportEvent (this=0xa0791f0, e=0xbff2d2ac) at widgets/qabstractscrollarea.cpp:1043
#54 0xb5b38acc in QAbstractItemView::viewportEvent (this=0xa0791f0, event=0xbff2d2ac) at itemviews/qabstractitemview.cpp:1644
#55 0xb5b86b66 in QTreeView::viewportEvent (this=0xa0791f0, event=0xbff2d2ac) at itemviews/qtreeview.cpp:1257
#56 0xb5a951d6 in viewportEvent (this=<optimized out>, event=0xbff2d2ac) at widgets/qabstractscrollarea_p.h:100
#57 eventFilter (e=0xbff2d2ac, this=<optimized out>, o=<optimized out>) at widgets/qabstractscrollarea_p.h:116
#58 QAbstractScrollAreaFilter::eventFilter (this=0xa0c1670, o=0xa0b8348, e=0xbff2d2ac) at widgets/qabstractscrollarea_p.h:115
#59 0xb611db16 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9c92f28, receiver=0xa0b8348, event=0xbff2d2ac) at kernel/qcoreapplication.cpp:986
#60 0xb5587ea2 in notify_helper (e=0xbff2d2ac, receiver=0xa0b8348, this=0x9c92f28) at kernel/qapplication.cpp:4555
#61 QApplicationPrivate::notify_helper (this=0x9c92f28, receiver=0xa0b8348, e=0xbff2d2ac) at kernel/qapplication.cpp:4531
#62 0xb558d960 in QApplication::notify (this=0xa0b8348, receiver=0xa0b8348, e=0xbff2d2ac) at kernel/qapplication.cpp:4181
#63 0xb6c56401 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#64 0xb611d97e in QCoreApplication::notifyInternal (this=0x9c8c3a8, receiver=0xa0b8348, event=0xbff2d2ac) at kernel/qcoreapplication.cpp:876
#65 0xb56150f5 in sendSpontaneousEvent (event=0xbff2d2ac, receiver=0xa0b8348) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:234
#66 QETWidget::translateMouseEvent (this=0xa088eb8, event=0xbff2d73c) at kernel/qapplication_x11.cpp:4622
#67 0xb5613c0d in QApplication::x11ProcessEvent (this=0x9c8c3a8, event=0xbff2d73c) at kernel/qapplication_x11.cpp:3732
#68 0xb5640eac in x11EventSourceDispatch (s=0x9c94868, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#69 0xb46d1d86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#70 0xb46d2125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#71 0xb46d2201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#72 0xb6150887 in QEventDispatcherGlib::processEvents (this=0x9c6cea0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#73 0xb5640aaa in QGuiEventDispatcherGlib::processEvents (this=0x9c6cea0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#74 0xb611c50d in QEventLoop::processEvents (this=0xbff2da34, flags=...) at kernel/qeventloop.cpp:149
#75 0xb611c7a9 in QEventLoop::exec (this=0xbff2da34, flags=...) at kernel/qeventloop.cpp:204
#76 0xb6121eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#77 0xb5585a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#78 0x0808a493 in runKMyMoney (splash=0xbff2db88, a=<optimized out>) at /build/buildd/kmymoney-4.6.1/kmymoney/main.cpp:282
#79 0x080889db in main (argc=0, argv=0x0) at /build/buildd/kmymoney-4.6.1/kmymoney/main.cpp:181

This bug may be a duplicate of or related to bug 283327.

Possible duplicates by query: bug 296518, bug 283359, bug 283327.

Reported using DrKonqi
Comment 1 Cristian Oneț 2012-11-27 12:21:58 UTC
Although the steps to reproduce differ this bug is caused by the same error that was causing BUG 309105 and it's fixed by the same fix.

*** This bug has been marked as a duplicate of bug 309105 ***