Bug 296518 - Crash after attempting to change the ledger sort order.
Summary: Crash after attempting to change the ledger sort order.
Status: RESOLVED DUPLICATE of bug 309105
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-21 18:46 UTC by allan
Modified: 2012-11-27 12:20 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.80 KB, text/plain)
2012-10-21 12:22 UTC, Jean-Pierre ROBERT
Details

Note You need to log in before you can comment on or make changes to this bug.
Description allan 2012-03-21 18:46:44 UTC
Application: kmymoney (4.6.90-eccea5f048)
KDE Platform Version: 4.7.4 (4.7.4)
Qt Version: 4.7.4
Operating System: Linux 3.0.0-15-generic-pae i686
Distribution: Linux Mint 12 KDE

-- Information about the crash:
- What I was doing when the application crashed:

The crash occurred immediately after attempting to change the ledger sort order.  I had added 'entry order' to the list and double clicked the box to reverse the order direction.

I had earlier done this successfully in another account.

-- Backtrace:
Application: KMyMoney (kmymoney), signal: Segmentation fault
[Current thread is 1 (Thread 0xb3e19ac0 (LWP 2216))]

Thread 3 (Thread 0xb0ec7b70 (LWP 2217)):
#0  0xb7776424 in __kernel_vsyscall ()
#1  0xb528d40e in __GI___poll (fds=0x93f8af8, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#2  0xb47de34b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb47cf896 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb47cfc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb614fb37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#6  0xb61201dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#7  0xb6120421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#8  0xb602390b in QThread::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#9  0xb6100e2d in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#10 0xb60267b3 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#11 0xb684fd31 in start_thread (arg=0xb0ec7b70) at pthread_create.c:304
#12 0xb529c0ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 2 (Thread 0xaca26b70 (LWP 2503)):
#0  0xb4888d10 in __GI_clock_gettime (clock_id=1, tp=0xaca26028) at ../sysdeps/unix/clock_gettime.c:116
#1  0xb607d7d5 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#2  0xb61504b6 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#3  0xb615080a in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#4  0xb614f053 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#5  0xb614f0ed in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#6  0xb47ce88c in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb47cf637 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb47cfc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb614fb37 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#10 0xb61201dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#11 0xb6120421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#12 0xb602390b in QThread::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#13 0xb6100e2d in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#14 0xb60267b3 in ?? () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#15 0xb684fd31 in start_thread (arg=0xaca26b70) at pthread_create.c:304
#16 0xb529c0ce in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130
Backtrace stopped: Not enough registers or memory available to unwind further

Thread 1 (Thread 0xb3e19ac0 (LWP 2216)):
[KCrash Handler]
#7  InstitutionsModel::slotObjectModified (this=0x92ab308, objType=0, obj=0xca41090) at /home/aga/GITA/kmymoney/kmymoney/models/accountsmodel.cpp:909
#8  0x0841f206 in InstitutionsModel::qt_metacall (this=0x92ab308, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbffeef74) at /home/aga/GITA/kmymoney/build/kmymoney/models/accountsmodel.moc:177
#9  0xb6127b7d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#10 0xb6136a6a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#11 0xb76e757d in MyMoneyFile::objectModified (this=0xb7758b80, _t1=MyMoneyFile::notifyAccount, _t2=0xca41090) at /home/aga/GITA/kmymoney/build/kmymoney/mymoney/mymoneyfile.moc:120
#12 0xb76f0f70 in MyMoneyFile::commitTransaction (this=0xb7758b80) at /home/aga/GITA/kmymoney/kmymoney/mymoney/mymoneyfile.cpp:392
#13 0xb76f13cd in MyMoneyFileTransaction::commit (this=0xbffef06e) at /home/aga/GITA/kmymoney/kmymoney/mymoney/mymoneyfile.cpp:2832
#14 0x0815083f in KGlobalLedgerView::slotSortOptions (this=0x900b560) at /home/aga/GITA/kmymoney/kmymoney/views/kgloballedgerview.cpp:1380
#15 0x0815c1b9 in KGlobalLedgerView::qt_metacall (this=0x900b560, _c=QMetaObject::InvokeMetaMethod, _id=22, _a=0xbffef1e8) at /home/aga/GITA/kmymoney/build/kmymoney/views/kgloballedgerview.moc:229
#16 0xb6127b7d in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#17 0xb6136a6a in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#18 0xb5621e75 in QWidget::customContextMenuRequested(QPoint const&) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#19 0xb562cde6 in QWidget::event(QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#20 0xb5a31285 in QFrame::event(QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#21 0xb5ac3821 in QAbstractScrollArea::viewportEvent(QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#22 0xb5b65bbc in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#23 0xb5b7d8bc in QHeaderView::viewportEvent(QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#24 0xb5ac5f36 in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#25 0xb6121336 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#26 0xb55d1d52 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#27 0xb55d77c4 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#28 0xb6c1d971 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#29 0xb612119e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#30 0xb565f385 in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#31 0xb565de8d in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#32 0xb568a28c in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#33 0xb47cf25f in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#34 0xb47cf990 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#35 0xb47cfc2a in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0xb614fada in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#37 0xb5689e7a in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#38 0xb61201dd in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#39 0xb6120421 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#40 0xb612519d in QCoreApplication::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#41 0xb55cf924 in QApplication::exec() () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#42 0x08089df3 in runKMyMoney (splash=0xbfff0218, a=<optimized out>) at /home/aga/GITA/kmymoney/kmymoney/main.cpp:282
#43 0x080882e2 in main (argc=0, argv=0x0) at /home/aga/GITA/kmymoney/kmymoney/main.cpp:181

Possible duplicates by query: bug 283359, bug 283327, bug 274308, bug 274159.

Reported using DrKonqi
Comment 1 Jean-Pierre ROBERT 2012-10-21 12:22:35 UTC
Created attachment 74697 [details]
New crash information added by DrKonqi

kmymoney (4.6.1) on KDE Platform 4.8.5 (4.8.5) using Qt 4.8.1

- What I was doing when the application crashed: j'étais en train de modifier la hiérarchie des comptes avec les banques

-- Backtrace (Reduced):
#6  InstitutionsModel::slotObjectModified (this=0x2959a10, objType=<optimized out>, obj=0x360c680) at /build/buildd/kmymoney-4.6.1/kmymoney/models/accountsmodel.cpp:909
[...]
#8  0x00007f6aca0e2b3e in MyMoneyFile::objectModified (this=<optimized out>, _t1=MyMoneyFile::notifyAccount, _t2=0x360c680) at /build/buildd/kmymoney-4.6.1/obj-x86_64-linux-gnu/kmymoney/mymoney/mymoneyfile.moc:134
#9  0x00007f6aca0eba79 in MyMoneyFile::commitTransaction (this=0x7f6aca34eb20) at /build/buildd/kmymoney-4.6.1/kmymoney/mymoney/mymoneyfile.cpp:392
#10 0x00007f6aca0ebf05 in MyMoneyFileTransaction::commit (this=0x7fff787aec60) at /build/buildd/kmymoney-4.6.1/kmymoney/mymoney/mymoneyfile.cpp:2786
#11 0x000000000047c604 in KMyMoneyApp::slotAccountEdit (this=0x23c4f20) at /build/buildd/kmymoney-4.6.1/kmymoney/kmymoney.cpp:3558
Comment 2 Cristian Oneț 2012-11-27 12:20:55 UTC
Although the steps to reproduce differ this bug is caused by the same error that was causing BUG 309105 and it's fixed by the same fix.

*** This bug has been marked as a duplicate of bug 309105 ***