Bug 283327 - Crash adding asset account after reorganizing accounts list
Summary: Crash adding asset account after reorganizing accounts list
Status: RESOLVED DUPLICATE of bug 309105
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: 4.6.0
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
: 283359 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-04 17:26 UTC by jasonb
Modified: 2012-11-27 12:21 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jasonb 2011-10-04 17:26:35 UTC
Application: kmymoney (4.6.0)
KDE Platform Version: 4.6.5 (4.6.5)
Qt Version: 4.7.4
Operating System: Linux 2.6.40.4-5.fc15.i686.PAE i686
Distribution: "Fedora release 15 (Lovelock)"

-- Information about the crash:
- What I was doing when the application crashed:

I moved several deeply nested -- second level -- liability and asset groups up to the parent level.  Then, I created a new Asset account, going through the wizard.  Upon hitting 'Finish', application crashed.  Attempted to reproduce by moving accounts, then creating a new account to no avail.  Not sure how to trigger it again.

-- Backtrace:
Application: KMyMoney (kmymoney), signal: Segmentation fault
[KCrash Handler]
#7  InstitutionsModel::slotObjectModified (this=0x95c21c8, objType=0, obj=0xcd32680) at /usr/src/debug/kmymoney-4.6.0/kmymoney/models/accountsmodel.cpp:909
#8  0x0841728e in InstitutionsModel::qt_metacall (this=0x95c21c8, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd648e4) at /usr/src/debug/kmymoney-4.6.0/i686-redhat-linux-gnu/kmymoney/models/accountsmodel.moc:177
#9  0x423fae3e in metacall (argv=0xbfd648e4, idx=34, cl=QMetaObject::InvokeMetaMethod, object=0x95c21c8) at kernel/qmetaobject.cpp:237
#10 QMetaObject::metacall (object=0x95c21c8, cl=QMetaObject::InvokeMetaMethod, idx=34, argv=0xbfd648e4) at kernel/qmetaobject.cpp:232
#11 0x42408dca in QMetaObject::activate (sender=0x434dc8a0, m=0x434db8f8, local_signal_index=3, argv=0xbfd648e4) at kernel/qobject.cpp:3278
#12 0x4346bd6e in MyMoneyFile::objectModified (this=0x434dc8a0, _t1=MyMoneyFile::notifyAccount, _t2=0xcd32680) at /usr/src/debug/kmymoney-4.6.0/i686-redhat-linux-gnu/kmymoney/mymoney/mymoneyfile.moc:120
#13 0x43475948 in MyMoneyFile::commitTransaction (this=0x434dc8a0) at /usr/src/debug/kmymoney-4.6.0/kmymoney/mymoney/mymoneyfile.cpp:391
#14 0x43475dae in MyMoneyFileTransaction::commit (this=0xbfd64cbe) at /usr/src/debug/kmymoney-4.6.0/kmymoney/mymoney/mymoneyfile.cpp:2750
#15 0x080a839f in KMyMoneyApp::slotAccountNew (this=0x937c020, account=...) at /usr/src/debug/kmymoney-4.6.0/kmymoney/kmymoney.cpp:3094
#16 0x080a892e in KMyMoneyApp::slotAccountNew (this=0x937c020) at /usr/src/debug/kmymoney-4.6.0/kmymoney/kmymoney.cpp:3037
#17 0x080d2ad7 in KMyMoneyApp::qt_metacall (this=0x937c020, _c=QMetaObject::InvokeMetaMethod, _id=176, _a=0xbfd650a8) at /usr/src/debug/kmymoney-4.6.0/i686-redhat-linux-gnu/kmymoney/kmymoney.moc:585
#18 0x423fae3e in metacall (argv=0xbfd650a8, idx=222, cl=QMetaObject::InvokeMetaMethod, object=0x937c020) at kernel/qmetaobject.cpp:237
#19 QMetaObject::metacall (object=0x937c020, cl=QMetaObject::InvokeMetaMethod, idx=222, argv=0xbfd650a8) at kernel/qmetaobject.cpp:232
#20 0x42408dca in QMetaObject::activate (sender=0x9403808, m=0x458c7ad8, local_signal_index=1, argv=0xbfd650a8) at kernel/qobject.cpp:3278
#21 0x44f7cfee in QAction::triggered (this=0x9403808, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#22 0x44f7d28b in QAction::activate (this=0x9403808, event=QAction::Trigger) at kernel/qaction.cpp:1257
#23 0x4542611c in QMenuPrivate::activateCausedStack (this=0x94900d8, causedStack=..., action=0x9403808, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1005
#24 0x4542c9bf in QMenuPrivate::activateAction (this=0x94900d8, action=0x9403808, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1097
#25 0x4542f676 in QMenu::mouseReleaseEvent (this=0x9490078, e=0xbfd658d4) at widgets/qmenu.cpp:2296
#26 0x42af01bd in KMenu::mouseReleaseEvent (this=0x9490078, e=0xbfd658d4) at /usr/src/debug/kdelibs-4.6.5/kdeui/widgets/kmenu.cpp:458
#27 0x44fdeee5 in QWidget::event (this=0x9490078, event=0xbfd658d4) at kernel/qwidget.cpp:8295
#28 0x4542e0ec in QMenu::event (this=0x9490078, e=0xbfd658d4) at widgets/qmenu.cpp:2405
#29 0x44f84014 in notify_helper (e=0xbfd658d4, receiver=0x9490078, this=0x9342b20) at kernel/qapplication.cpp:4481
#30 QApplicationPrivate::notify_helper (this=0x9342b20, receiver=0x9490078, e=0xbfd658d4) at kernel/qapplication.cpp:4453
#31 0x44f8a1aa in QApplication::notify (this=0x9342b20, receiver=0x9490078, e=0xbfd658d4) at kernel/qapplication.cpp:4042
#32 0x42a098c2 in KApplication::notify (this=0x933de48, receiver=0x9490078, event=0xbfd658d4) at /usr/src/debug/kdelibs-4.6.5/kdeui/kernel/kapplication.cpp:311
#33 0x423f465e in QCoreApplication::notifyInternal (this=0x933de48, receiver=0x9490078, event=0xbfd658d4) at kernel/qcoreapplication.cpp:787
#34 0x44f84fe6 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:215
#35 QApplicationPrivate::sendMouseEvent (receiver=0x9490078, event=0xbfd658d4, alienWidget=0x0, nativeWidget=0x9490078, buttonDown=0x458e3f54, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3141
#36 0x4500f9e4 in QETWidget::translateMouseEvent (this=0x9490078, event=0xbfd65d8c) at kernel/qapplication_x11.cpp:4395
#37 0x4500e26d in QApplication::x11ProcessEvent (this=0x933de48, event=0xbfd65d8c) at kernel/qapplication_x11.cpp:3587
#38 0x45038eb5 in x11EventSourceDispatch (s=0x9345b40, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#39 0x410c55bf in g_main_dispatch (context=0x9344c70) at gmain.c:2441
#40 g_main_context_dispatch (context=0x9344c70) at gmain.c:3014
#41 0x410c5d30 in g_main_context_iterate (context=0x9344c70, block=1091390080, dispatch=1, self=0x9341c30) at gmain.c:3092
#42 0x410c606f in g_main_context_iteration (context=0x9344c70, may_block=1) at gmain.c:3155
#43 0x42422d58 in QEventDispatcherGlib::processEvents (this=0x9322378, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#44 0x45038b4b in QGuiEventDispatcherGlib::processEvents (this=0x9322378, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#45 0x423f399e in QEventLoop::processEvents (this=0xbfd66090, flags=...) at kernel/qeventloop.cpp:149
#46 0x423f3bf1 in QEventLoop::exec (this=0xbfd66090, flags=...) at kernel/qeventloop.cpp:201
#47 0x45428d08 in QMenu::exec (this=0x9490078, p=..., action=0x0) at widgets/qmenu.cpp:2049
#48 0x08098c20 in KMyMoneyApp::showContextMenu (this=0x937c020, containerName=...) at /usr/src/debug/kmymoney-4.6.0/kmymoney/kmymoney.cpp:5707
#49 0x0809908a in KMyMoneyApp::slotShowAccountContextMenu (this=0x937c020, obj=...) at /usr/src/debug/kmymoney-4.6.0/kmymoney/kmymoney.cpp:5746
#50 0x080d27dc in KMyMoneyApp::qt_metacall (this=0x937c020, _c=QMetaObject::InvokeMetaMethod, _id=144, _a=0xbfd66478) at /usr/src/debug/kmymoney-4.6.0/i686-redhat-linux-gnu/kmymoney/kmymoney.moc:553
#51 0x423fae3e in metacall (argv=0xbfd66478, idx=190, cl=QMetaObject::InvokeMetaMethod, object=0x937c020) at kernel/qmetaobject.cpp:237
#52 QMetaObject::metacall (object=0x937c020, cl=QMetaObject::InvokeMetaMethod, idx=190, argv=0xbfd66478) at kernel/qmetaobject.cpp:232
#53 0x42408dca in QMetaObject::activate (sender=0x95c6b88, m=0x860e87c, local_signal_index=1, argv=0xbfd66478) at kernel/qobject.cpp:3278
#54 0x0812a896 in KAccountsView::openContextMenu (this=0x95c6b88, _t1=...) at /usr/src/debug/kmymoney-4.6.0/i686-redhat-linux-gnu/kmymoney/views/kaccountsview.moc:152
#55 0x0813053e in KAccountsView::qt_metacall (this=0x95c6b88, _c=QMetaObject::InvokeMetaMethod, _id=1, _a=0xbfd665d8) at /usr/src/debug/kmymoney-4.6.0/i686-redhat-linux-gnu/kmymoney/views/kaccountsview.moc:115
#56 0x423fae3e in metacall (argv=0xbfd665d8, idx=28, cl=QMetaObject::InvokeMetaMethod, object=0x95c6b88) at kernel/qmetaobject.cpp:237
#57 QMetaObject::metacall (object=0x95c6b88, cl=QMetaObject::InvokeMetaMethod, idx=28, argv=0xbfd665d8) at kernel/qmetaobject.cpp:232
#58 0x42408dca in QMetaObject::activate (sender=0x95c7638, m=0x860ff7c, local_signal_index=1, argv=0xbfd665d8) at kernel/qobject.cpp:3278
#59 0x081e2216 in KMyMoneyAccountTreeView::openContextMenu (this=0x95c7638, _t1=...) at /usr/src/debug/kmymoney-4.6.0/i686-redhat-linux-gnu/kmymoney/widgets/kmymoneyaccounttreeview.moc:119
#60 0x081e3b0e in KMyMoneyAccountTreeView::customContextMenuRequested (this=0x95c7638, pos=...) at /usr/src/debug/kmymoney-4.6.0/kmymoney/widgets/kmymoneyaccounttreeview.cpp:99
#61 0x081e4dc3 in KMyMoneyAccountTreeView::qt_metacall (this=0x95c7638, _c=QMetaObject::InvokeMetaMethod, _id=<optimized out>, _a=0xbfd66968) at /usr/src/debug/kmymoney-4.6.0/i686-redhat-linux-gnu/kmymoney/widgets/kmymoneyaccounttreeview.moc:99
#62 0x423fae3e in metacall (argv=0xbfd66968, idx=96, cl=QMetaObject::InvokeMetaMethod, object=0x95c7638) at kernel/qmetaobject.cpp:237
#63 QMetaObject::metacall (object=0x95c7638, cl=QMetaObject::InvokeMetaMethod, idx=96, argv=0xbfd66968) at kernel/qmetaobject.cpp:232
#64 0x42408dca in QMetaObject::activate (sender=0x95c7638, m=0x458c8b7c, local_signal_index=0, argv=0xbfd66968) at kernel/qobject.cpp:3278
#65 0x44fd4526 in QWidget::customContextMenuRequested (this=0x95c7638, _t1=...) at .moc/release-shared/moc_qwidget.cpp:360
#66 0x44fdfd06 in QWidget::event (this=0x95c7638, event=0xbfd671cc) at kernel/qwidget.cpp:8465
#67 0x453e3486 in QFrame::event (this=0x95c7638, e=0xbfd671cc) at widgets/qframe.cpp:557
#68 0x45475f22 in QAbstractScrollArea::viewportEvent (this=0x95c7638, e=0xbfd671cc) at widgets/qabstractscrollarea.cpp:1043
#69 0x455189cc in QAbstractItemView::viewportEvent (this=0x95c7638, event=0xbfd671cc) at itemviews/qabstractitemview.cpp:1628
#70 0x455638b7 in QTreeView::viewportEvent (this=0x95c7638, event=0xbfd671cc) at itemviews/qtreeview.cpp:1256
#71 0x454786a6 in viewportEvent (this=<optimized out>, event=0xbfd671cc) at widgets/qabstractscrollarea_p.h:100
#72 eventFilter (e=0xbfd671cc, this=<optimized out>, o=<optimized out>) at widgets/qabstractscrollarea_p.h:116
#73 QAbstractScrollAreaFilter::eventFilter (this=0x95cad28, o=0x95c8ac0, e=0xbfd671cc) at widgets/qabstractscrollarea_p.h:115
#74 0x423f4806 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x9342b20, receiver=0x95c8ac0, event=0xbfd671cc) at kernel/qcoreapplication.cpp:902
#75 0x44f83fe3 in notify_helper (e=0xbfd671cc, receiver=0x95c8ac0, this=0x9342b20) at kernel/qapplication.cpp:4477
#76 QApplicationPrivate::notify_helper (this=0x9342b20, receiver=0x95c8ac0, e=0xbfd671cc) at kernel/qapplication.cpp:4453
#77 0x44f89b1f in QApplication::notify (this=0x95c8ac0, receiver=0x95c8ac0, e=0xbfd671cc) at kernel/qapplication.cpp:4121
#78 0x42a098c2 in KApplication::notify (this=0x933de48, receiver=0x95c8ac0, event=0xbfd671cc) at /usr/src/debug/kdelibs-4.6.5/kdeui/kernel/kapplication.cpp:311
#79 0x423f465e in QCoreApplication::notifyInternal (this=0x933de48, receiver=0x95c8ac0, event=0xbfd671cc) at kernel/qcoreapplication.cpp:787
#80 0x4500f32d in sendSpontaneousEvent (event=0xbfd671cc, receiver=0x95c8ac0) at ../../src/corelib/kernel/qcoreapplication.h:218
#81 QETWidget::translateMouseEvent (this=0x95c6b88, event=0xbfd6765c) at kernel/qapplication_x11.cpp:4466
#82 0x4500e26d in QApplication::x11ProcessEvent (this=0x933de48, event=0xbfd6765c) at kernel/qapplication_x11.cpp:3587
#83 0x45038eb5 in x11EventSourceDispatch (s=0x9345b40, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#84 0x410c55bf in g_main_dispatch (context=0x9344c70) at gmain.c:2441
#85 g_main_context_dispatch (context=0x9344c70) at gmain.c:3014
#86 0x410c5d30 in g_main_context_iterate (context=0x9344c70, block=1091390080, dispatch=1, self=0x9341c30) at gmain.c:3092
#87 0x410c606f in g_main_context_iteration (context=0x9344c70, may_block=1) at gmain.c:3155
#88 0x42422d58 in QEventDispatcherGlib::processEvents (this=0x9322378, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#89 0x45038b4b in QGuiEventDispatcherGlib::processEvents (this=0x9322378, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#90 0x423f399e in QEventLoop::processEvents (this=0xbfd67964, flags=...) at kernel/qeventloop.cpp:149
#91 0x423f3bf1 in QEventLoop::exec (this=0xbfd67964, flags=...) at kernel/qeventloop.cpp:201
#92 0x423f835b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1064
#93 0x44f81df5 in QApplication::exec () at kernel/qapplication.cpp:3755
#94 0x0808a4d4 in runKMyMoney (a=0x0, splash=0xbfd67b1c) at /usr/src/debug/kmymoney-4.6.0/kmymoney/main.cpp:282
#95 0x08088a1a in main (argc=1, argv=0xbfd67e04) at /usr/src/debug/kmymoney-4.6.0/kmymoney/main.cpp:181

Possible duplicates by query: bug 274308, bug 274159, bug 268953.

Reported using DrKonqi
Comment 1 jasonb 2011-10-04 17:33:23 UTC
Actually, I can reproduce it.  I repeated what I did completely:

My hierarchy from gnucash import is:

Asset -> Assets -> Current Assets -> blah

First, I moved Current Assets to Asset -> Current Assets.  Then, I deleted "Assets" as it was an unnecessary level of nesting.  Finally, I created a new account under Asset -> Current Assets.  I went through the wizard, then when I clicked "Finish" it crashed.

Last time I forgot the delete step -- perhaps that is the crucial piece of information?

Let me know if I can provide any additional information.
Comment 2 Thomas Baumgart 2011-10-09 11:01:50 UTC
*** Bug 283359 has been marked as a duplicate of this bug. ***
Comment 3 Cristian Oneț 2012-11-27 12:21:17 UTC
Although the steps to reproduce differ this bug is caused by the same error that was causing BUG 309105 and it's fixed by the same fix.

*** This bug has been marked as a duplicate of bug 309105 ***