Bug 305260 - Amarok crashes on (almost) every shutdown
Summary: Amarok crashes on (almost) every shutdown
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: openSUSE RPMs Linux
: NOR crash (vote)
Target Milestone: 2.7
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-16 13:37 UTC by jarlgjessing
Modified: 2012-08-16 13:42 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jarlgjessing 2012-08-16 13:37:05 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.9.00 "release 558"
Qt Version: 4.8.2
Operating System: Linux 3.4.6-1.1-desktop x86_64
Distribution: "openSUSE 12.2 (x86_64)"

-- Information about the crash:
- What I was doing when the application crashed:
I pressed Shutdown and restart. Then KDE started shutting down applications and stopped here

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9ba4ad7780 (LWP 1543))]

Thread 11 (Thread 0x7f9b8c480700 (LWP 1718)):
#0  0x00007f9bb63551dd in read () from /lib64/libc.so.6
#1  0x00007f9bb03d675f in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9bb039b259 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9bb039b672 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f9bb039b7f4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f9bb6cea3f6 in QEventDispatcherGlib::processEvents (this=0x7f9b84000900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f9bb6cbaebf in QEventLoop::processEvents (this=this@entry=0x7f9b8c47fdf0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f9bb6cbb148 in QEventLoop::exec (this=0x7f9b8c47fdf0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f9bb6bbeef0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f9bb6c9b89f in QInotifyFileSystemWatcherEngine::run (this=0x262f430) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f9bb6bc1e8b in QThreadPrivate::start (arg=0x262f430) at thread/qthread_unix.cpp:307
#11 0x00007f9bb4489e0e in start_thread () from /lib64/libpthread.so.0
#12 0x00007f9bb63612bd in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7f9b8ac7e700 (LWP 1721)):
#0  0x00007f9bb448d8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9bb6bc238b in wait (time=18446744073709551615, this=0x2645830) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2779fc0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9bb37ee971 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f9bb37f11bb in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f9bb37f002f in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f9bb37f00bb in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f9bb6bc1e8b in QThreadPrivate::start (arg=0x275d060) at thread/qthread_unix.cpp:307
#8  0x00007f9bb4489e0e in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9bb63612bd in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7f9b898b6700 (LWP 1722)):
#0  0x00007f9bb63551dd in read () from /lib64/libc.so.6
#1  0x00007f9bb03d675f in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9bb039b259 in g_main_context_check () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9bb039b672 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f9bb039b7f4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f9bb6cea3f6 in QEventDispatcherGlib::processEvents (this=0x7f9b800008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f9bb6cbaebf in QEventLoop::processEvents (this=this@entry=0x7f9b898b5e20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f9bb6cbb148 in QEventLoop::exec (this=0x7f9b898b5e20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f9bb6bbeef0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f9bb6bc1e8b in QThreadPrivate::start (arg=0x282d5d0) at thread/qthread_unix.cpp:307
#10 0x00007f9bb4489e0e in start_thread () from /lib64/libpthread.so.0
#11 0x00007f9bb63612bd in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7f9b88a39700 (LWP 1723)):
#0  0x00007f9bb448cd9f in __pthread_mutex_unlock_usercnt () from /lib64/libpthread.so.0
#1  0x00007f9bb03d73d1 in g_mutex_unlock () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9bb039af05 in g_main_context_prepare () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f9bb039b5fb in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f9bb039b7f4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f9bb6cea3f6 in QEventDispatcherGlib::processEvents (this=0x7f9b740008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f9bb6cbaebf in QEventLoop::processEvents (this=this@entry=0x7f9b88a38e20, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f9bb6cbb148 in QEventLoop::exec (this=0x7f9b88a38e20, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f9bb6bbeef0 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f9bb6bc1e8b in QThreadPrivate::start (arg=0x2746890) at thread/qthread_unix.cpp:307
#10 0x00007f9bb4489e0e in start_thread () from /lib64/libpthread.so.0
#11 0x00007f9bb63612bd in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7f9b7b5f8700 (LWP 1725)):
#0  0x00007f9bb448d8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9bb6bc238b in wait (time=18446744073709551615, this=0x2645830) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2779fc0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9bb37ee971 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f9bb37f11bb in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f9bb37f002f in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f9bb37f00bb in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f9bb6bc1e8b in QThreadPrivate::start (arg=0x2758fb0) at thread/qthread_unix.cpp:307
#8  0x00007f9bb4489e0e in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9bb63612bd in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7f9b79f68700 (LWP 1726)):
#0  0x00007f9bb448d8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9bb6bc238b in wait (time=18446744073709551615, this=0x2645830) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2779fc0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9bb37ee971 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f9bb37f11bb in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f9bb37f002f in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f9bb37f00bb in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f9bb6bc1e8b in QThreadPrivate::start (arg=0x2b4ddf0) at thread/qthread_unix.cpp:307
#8  0x00007f9bb4489e0e in start_thread () from /lib64/libpthread.so.0
#9  0x00007f9bb63612bd in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7f9b79767700 (LWP 1727)):
#0  0x00007f9bb448d8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9bb6bc238b in wait (time=18446744073709551615, this=0x2645830) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x2779fc0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f9bb37ee971 in ?? () from /usr/lib64/libthreadweaver.so.4
#4  0x00007f9bb37f11bb in ?? () from /usr/lib64/libthreadweaver.so.4
#5  0x00007f9bb37f11d4 in ?? () from /usr/lib64/libthreadweaver.so.4
#6  0x00007f9bb37f002f in ?? () from /usr/lib64/libthreadweaver.so.4
#7  0x00007f9bb37f00bb in ThreadWeaver::Thread::run() () from /usr/lib64/libthreadweaver.so.4
#8  0x00007f9bb6bc1e8b in QThreadPrivate::start (arg=0x2b4c970) at thread/qthread_unix.cpp:307
#9  0x00007f9bb4489e0e in start_thread () from /lib64/libpthread.so.0
#10 0x00007f9bb63612bd in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f9b78924700 (LWP 1728)):
#0  0x00007f9bb448d8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9bad205077 in ?? () from /usr/lib64/libQtWebKit.so.4
#2  0x00007f9bad2050a9 in ?? () from /usr/lib64/libQtWebKit.so.4
#3  0x00007f9bb4489e0e in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9bb63612bd in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f9b6752a700 (LWP 1731)):
#0  0x00007f9bb448d8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9bb2830217 in ?? () from /usr/lib64/libQtScript.so.4
#2  0x00007f9bb2830249 in ?? () from /usr/lib64/libQtScript.so.4
#3  0x00007f9bb4489e0e in start_thread () from /lib64/libpthread.so.0
#4  0x00007f9bb63612bd in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f9b5a268700 (LWP 2525)):
#0  0x00007f9bb448d8f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9bb03d761f in g_cond_wait () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f9ba86becb3 in ?? () from /usr/lib64/libgstreamer-0.10.so.0
#3  0x00007f9bb03be862 in ?? () from /usr/lib64/libglib-2.0.so.0
#4  0x00007f9bb03be065 in ?? () from /usr/lib64/libglib-2.0.so.0
#5  0x00007f9bb4489e0e in start_thread () from /lib64/libpthread.so.0
#6  0x00007f9bb63612bd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f9ba4ad7780 (LWP 1543)):
[KCrash Handler]
#5  0x0000000000000000 in ?? ()
#6  0x00007f9bb88ef367 in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/QtCore/qalgorithms.h:322
#7  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/QtCore/qalgorithms.h:330
#8  CollectionManager::~CollectionManager (this=0x2566480, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:137
#9  0x00007f9bb88ef5e9 in CollectionManager::~CollectionManager (this=0x2566480, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:145
#10 0x00007f9bb88ed486 in CollectionManager::destroy () at /usr/src/debug/amarok-2.5.0/src/core-impl/collections/support/CollectionManager.cpp:107
#11 0x00007f9bb8a19c35 in App::~App (this=0x7fffdc869690, __in_chrg=<optimized out>) at /usr/src/debug/amarok-2.5.0/src/App.cpp:248
#12 0x0000000000408f39 in main (argc=3, argv=0x7fffdc8697f8) at /usr/src/debug/amarok-2.5.0/src/main.cpp:303

Possible duplicates by query: bug 305205, bug 304925, bug 304818, bug 304719, bug 304474.

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-08-16 13:42:42 UTC

*** This bug has been marked as a duplicate of bug 285951 ***