Bug 304925 - Amarok plante quand je le ferme
Summary: Amarok plante quand je le ferme
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.6
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-08-10 15:21 UTC by dl.neustrie
Modified: 2012-08-10 17:48 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dl.neustrie 2012-08-10 15:21:00 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.4 (4.8.4)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-27-generic x86_64
Distribution: Ubuntu 12.04 LTS

-- Information about the crash:
- What I was doing when the application crashed:

A chaque fois que j'éteinds Amarok 2.5 j'ai un message d'alerte qui de me demande de le fermer ou de le relancer.
Amarok 2.5 et KDE 4.8.4

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f5c35753780 (LWP 4906))]

Thread 12 (Thread 0x7f5c13ba7700 (LWP 4909)):
#0  0x00007f5c3203bb03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5c2a49835f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#2  0x00007f5c2a48976c in pa_mainloop_poll () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#3  0x00007f5c2a489dd9 in pa_mainloop_iterate () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007f5c2a489e90 in pa_mainloop_run () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#5  0x00007f5c2a49830f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#6  0x00007f5c258ddd18 in ?? () from /usr/lib/x86_64-linux-gnu/libpulsecommon-1.1.so
#7  0x00007f5c2e758e9a in start_thread (arg=0x7f5c13ba7700) at pthread_create.c:308
#8  0x00007f5c320474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 11 (Thread 0x7f5c0e6c4700 (LWP 4911)):
#0  0x00007f5c3203a0bd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007f5c2cc758cf in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5c2cc3aba4 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5c2cc3afd6 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f5c2cc3b164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f5c329d2426 in QEventDispatcherGlib::processEvents (this=0x7f5bfc000900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f5c329a1c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f5c329a1ed7 in QEventLoop::exec (this=0x7f5c0e6c3dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f5c328a0fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f5c329819ff in QInotifyFileSystemWatcherEngine::run (this=0x1e7db30) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f5c328a3fcb in QThreadPrivate::start (arg=0x1e7db30) at thread/qthread_unix.cpp:298
#11 0x00007f5c2e758e9a in start_thread (arg=0x7f5c0e6c4700) at pthread_create.c:308
#12 0x00007f5c320474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7f5c03ffe700 (LWP 4912)):
#0  0x00007f5c3203bb03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5c2cc3b036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5c2cc3b164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5c329d2426 in QEventDispatcherGlib::processEvents (this=0x7f5bf40008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f5c329a1c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f5c329a1ed7 in QEventLoop::exec (this=0x7f5c03ffde00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f5c328a0fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f5c328a3fcb in QThreadPrivate::start (arg=0x2145ec0) at thread/qthread_unix.cpp:298
#8  0x00007f5c2e758e9a in start_thread (arg=0x7f5c03ffe700) at pthread_create.c:308
#9  0x00007f5c320474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7f5c02fac700 (LWP 4913)):
#0  0x00007f5c3203bb03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5c2cc3b036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5c2cc3b164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5c329d2426 in QEventDispatcherGlib::processEvents (this=0x7f5bf00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f5c329a1c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f5c329a1ed7 in QEventLoop::exec (this=0x7f5c02fabe00, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f5c328a0fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f5c328a3fcb in QThreadPrivate::start (arg=0x217e7c0) at thread/qthread_unix.cpp:298
#8  0x00007f5c2e758e9a in start_thread (arg=0x7f5c02fac700) at pthread_create.c:308
#9  0x00007f5c320474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7f5c01b9f700 (LWP 4915)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5c328a44db in wait (time=18446744073709551615, this=0x21e5c20) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x21e5da0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f5c2fced0eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x21e5ad0, th=0x21e61c0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f5c2fcef9db in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e5e70, th=0x21e61c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f5c2fcef9f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e5e70, th=0x21e61c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f5c2fcef9f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e5e70, th=0x21e61c0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f5c2fcee84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f5c01b9ee20, parent=0x21e5ad0, th=0x21e61c0) at ../../../threadweaver/Weaver/Thread.cpp:87
#8  0x00007f5c2fcee8db in ThreadWeaver::Thread::run (this=0x21e61c0) at ../../../threadweaver/Weaver/Thread.cpp:142
#9  0x00007f5c328a3fcb in QThreadPrivate::start (arg=0x21e61c0) at thread/qthread_unix.cpp:298
#10 0x00007f5c2e758e9a in start_thread (arg=0x7f5c01b9f700) at pthread_create.c:308
#11 0x00007f5c320474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#12 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f5bfbdbf700 (LWP 4916)):
#0  0x00007f5c3203bb03 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f5c2cc3b036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f5c2cc3b164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f5c329d2426 in QEventDispatcherGlib::processEvents (this=0x7f5be00008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f5c329a1c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f5c329a1ed7 in QEventLoop::exec (this=0x7f5bfbdbedd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f5c328a0fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007f5c329819ff in QInotifyFileSystemWatcherEngine::run (this=0x25a9490) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007f5c328a3fcb in QThreadPrivate::start (arg=0x25a9490) at thread/qthread_unix.cpp:298
#9  0x00007f5c2e758e9a in start_thread (arg=0x7f5bfbdbf700) at pthread_create.c:308
#10 0x00007f5c320474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f5bfb5be700 (LWP 4917)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5c328a44db in wait (time=18446744073709551615, this=0x21e5c20) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x21e5da0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f5c2fced0eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x21e5ad0, th=0x26476f0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f5c2fcef9db in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e5e70, th=0x26476f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f5c2fcee84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f5bfb5bde20, parent=0x21e5ad0, th=0x26476f0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f5c2fcee8db in ThreadWeaver::Thread::run (this=0x26476f0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f5c328a3fcb in QThreadPrivate::start (arg=0x26476f0) at thread/qthread_unix.cpp:298
#8  0x00007f5c2e758e9a in start_thread (arg=0x7f5bfb5be700) at pthread_create.c:308
#9  0x00007f5c320474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f5bfadbd700 (LWP 4918)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5c328a44db in wait (time=18446744073709551615, this=0x21e5c20) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x21e5da0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f5c2fced0eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x21e5ad0, th=0x2648380) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f5c2fcef9db in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e5e70, th=0x2648380) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f5c2fcee84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f5bfadbce20, parent=0x21e5ad0, th=0x2648380) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007f5c2fcee8db in ThreadWeaver::Thread::run (this=0x2648380) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007f5c328a3fcb in QThreadPrivate::start (arg=0x2648380) at thread/qthread_unix.cpp:298
#8  0x00007f5c2e758e9a in start_thread (arg=0x7f5bfadbd700) at pthread_create.c:308
#9  0x00007f5c320474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f5bfa5bc700 (LWP 4919)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5c328a44db in wait (time=18446744073709551615, this=0x21e5c20) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x21e5da0, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007f5c2fced0eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x21e5ad0, th=0x2649050) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007f5c2fcef9db in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e5e70, th=0x2649050) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007f5c2fcef9f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e5e70, th=0x2649050) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#6  0x00007f5c2fcef9f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e5e70, th=0x2649050) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#7  0x00007f5c2fcef9f4 in ThreadWeaver::WorkingHardState::applyForWork (this=0x21e5e70, th=0x2649050) at ../../../threadweaver/Weaver/WorkingHardState.cpp:74
#8  0x00007f5c2fcee84f in ThreadWeaver::ThreadRunHelper::run (this=0x7f5bfa5bbe20, parent=0x21e5ad0, th=0x2649050) at ../../../threadweaver/Weaver/Thread.cpp:87
#9  0x00007f5c2fcee8db in ThreadWeaver::Thread::run (this=0x2649050) at ../../../threadweaver/Weaver/Thread.cpp:142
#10 0x00007f5c328a3fcb in QThreadPrivate::start (arg=0x2649050) at thread/qthread_unix.cpp:298
#11 0x00007f5c2e758e9a in start_thread (arg=0x7f5bfa5bc700) at pthread_create.c:308
#12 0x00007f5c320474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f5bf977a700 (LWP 4920)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5c29876dec in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#2  0x00007f5c29876f19 in ?? () from /usr/lib/x86_64-linux-gnu/libQtWebKit.so.4
#3  0x00007f5c2e758e9a in start_thread (arg=0x7f5bf977a700) at pthread_create.c:308
#4  0x00007f5c320474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5bd77fe700 (LWP 4923)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f5c2ed32222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007f5c2ed32259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007f5c2e758e9a in start_thread (arg=0x7f5bd77fe700) at pthread_create.c:308
#4  0x00007f5c320474bd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5c35753780 (LWP 4906)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f5c345f002e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#8  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  CollectionManager::~CollectionManager (this=0x1d6e920, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:137
#10 0x00007f5c345f0209 in CollectionManager::~CollectionManager (this=0x1d6e920, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:145
#11 0x00007f5c345ee4b6 in CollectionManager::destroy () at ../../src/core-impl/collections/support/CollectionManager.cpp:107
#12 0x00007f5c347234cf in App::~App (this=0x7fff557b0a00, __in_chrg=<optimized out>) at ../../src/App.cpp:248
#13 0x0000000000408e5a in main (argc=1, argv=0x7fff557b2e88) at ../../src/main.cpp:303

This bug may be a duplicate of or related to bug 285951.

Possible duplicates by query: bug 304818, bug 304719, bug 304474, bug 304007, bug 303999.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2012-08-10 17:48:53 UTC
English, please!

Also please check the duplicate reports Dr. Konqi suggests before you submit a report, this has already been reported numerous times and is fixed in the upcoming Amarok 2.6

*** This bug has been marked as a duplicate of bug 285951 ***